aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvs-syncmail
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-02 17:18:29 +0800
committermarino <marino@FreeBSD.org>2014-03-02 17:18:29 +0800
commit5a4800718f70e17eb0f5cbd140f65a593d3c05e6 (patch)
treec7eb2fbd04086a3e71bec87af6cc26a38726fb3c /devel/cvs-syncmail
parentf26294fb26329d741f0d60460a91d1a71348e88f (diff)
downloadfreebsd-ports-gnome-5a4800718f70e17eb0f5cbd140f65a593d3c05e6.tar.gz
freebsd-ports-gnome-5a4800718f70e17eb0f5cbd140f65a593d3c05e6.tar.zst
freebsd-ports-gnome-5a4800718f70e17eb0f5cbd140f65a593d3c05e6.zip
net-mgmt/rancid, devel/cvs(2html,-syncmail): Fix recent cvs dependency
CVS is no longer in base on FreeBSD 10 and later, but it's still in DragonFly's base, and the devel/cvs port doesn't even build on DF. The dependence on CVS was added to some ports recently, make sure that only applies to FreeBSD. Note the rancid approach where it further limits it to FreeBSD 10+ is better than devel/cvs* where they pull in CVS unconditionally on FreeBSD 8 and 9 where it's not needed. The unmaintained cvs-syncmail port was updated to be like rancid, but I didn't make the same update to the maintained cvs2html port.
Diffstat (limited to 'devel/cvs-syncmail')
-rw-r--r--devel/cvs-syncmail/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/cvs-syncmail/Makefile b/devel/cvs-syncmail/Makefile
index bf09a6e6e278..281f88d3a953 100644
--- a/devel/cvs-syncmail/Makefile
+++ b/devel/cvs-syncmail/Makefile
@@ -11,8 +11,6 @@ EXTRACT_SUFX=
MAINTAINER= ports@FreeBSD.org
COMMENT= CVS notification tool
-RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
-
USES= shebangfix
SHEBANG_FILES= ${DISTNAME}
NO_BUILD= yes
@@ -21,6 +19,12 @@ USE_PYTHON= yes
PLIST_FILES= bin/${DISTNAME}
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OPSYS} > 1000000
+RUN_DEPENDS= cvs:${PORTSDIR}/devel/cvs
+.endif
+
do-extract:
@${MKDIR} ${WRKSRC}
${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
@@ -28,4 +32,4 @@ do-extract:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/${DISTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>