aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvslines/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-02-08 06:28:37 +0800
committertrevor <trevor@FreeBSD.org>2002-02-08 06:28:37 +0800
commit4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e (patch)
tree91e55ad080b9715b5ce71c7f6b43f4e65c9c5a75 /devel/cvslines/Makefile
parent5da665f74e7220406774cadd92ded03bc88769fe (diff)
downloadfreebsd-ports-gnome-4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e.tar.gz
freebsd-ports-gnome-4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e.tar.zst
freebsd-ports-gnome-4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e.zip
"It has been established that persons who have recently died have
been returning to life and committing acts of murder." -- Night of the Living Dead (1968) Update to new layout. Update master sites. Update link to home page. Fix path to perl5 (fixes a bug reported in PR 14353). Use system rcs by default (same fix as in PR 14353). Correct several instances of doubled word "the the" in man page. Take over maintainership. Missing repository files replaced by: joe Permissions problem fixed by: the unknown cvsmeister PR: 14353, 34530, and 34702
Diffstat (limited to 'devel/cvslines/Makefile')
-rw-r--r--devel/cvslines/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/cvslines/Makefile b/devel/cvslines/Makefile
new file mode 100644
index 000000000000..10f397864dc9
--- /dev/null
+++ b/devel/cvslines/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: cvslines
+# Date created: 24 Aug 1998
+# Whom: jkoshy
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvslines
+PORTVERSION= 1.6.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.netsw.org/softeng/versioncontrol/repository/cvs/cvslines/
+MASTER_SITE_SUBDIR= jkoshy
+
+MAINTAINER= trevor@FreeBSD.org
+
+PLIST= ${WRKDIR}/pkg-plist
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= cvslines.1
+
+pre-patch:
+ ${PERL} -pi -e "s:usr/local/bin/perl5:${PERL5}:g" ${WRKSRC}/cvslines
+ ${PERL} -pi -e "s:the the:the:g" ${WRKSRC}/cvslines.1
+
+pre-install:
+.for i in s s_check s-status s-check s-commit s-config
+ ${ECHO_CMD} bin/cvsline$i >> ${PLIST}
+.endfor
+
+do-install:
+ PREFIX=${PREFIX} ${PERL5} ${WRKSRC}/INSTALL ${WRKSRC}/CONFIG
+
+.include <bsd.port.mk>