aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvslines
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-02-08 06:28:37 +0800
committertrevor <trevor@FreeBSD.org>2002-02-08 06:28:37 +0800
commit4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e (patch)
tree91e55ad080b9715b5ce71c7f6b43f4e65c9c5a75 /devel/cvslines
parent5da665f74e7220406774cadd92ded03bc88769fe (diff)
downloadfreebsd-ports-gnome-4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e.tar.gz
freebsd-ports-gnome-4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e.tar.zst
freebsd-ports-gnome-4eac91a92c3b5b4ec2dc359a12a5a526aa275f7e.zip
"It has been established that persons who have recently died have
been returning to life and committing acts of murder." -- Night of the Living Dead (1968) Update to new layout. Update master sites. Update link to home page. Fix path to perl5 (fixes a bug reported in PR 14353). Use system rcs by default (same fix as in PR 14353). Correct several instances of doubled word "the the" in man page. Take over maintainership. Missing repository files replaced by: joe Permissions problem fixed by: the unknown cvsmeister PR: 14353, 34530, and 34702
Diffstat (limited to 'devel/cvslines')
-rw-r--r--devel/cvslines/Makefile35
-rw-r--r--devel/cvslines/distinfo1
-rw-r--r--devel/cvslines/files/patch-aa32
-rw-r--r--devel/cvslines/files/patch-ab32
-rw-r--r--devel/cvslines/pkg-comment1
-rw-r--r--devel/cvslines/pkg-descr8
6 files changed, 109 insertions, 0 deletions
diff --git a/devel/cvslines/Makefile b/devel/cvslines/Makefile
new file mode 100644
index 000000000000..10f397864dc9
--- /dev/null
+++ b/devel/cvslines/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: cvslines
+# Date created: 24 Aug 1998
+# Whom: jkoshy
+#
+# $FreeBSD$
+#
+
+PORTNAME= cvslines
+PORTVERSION= 1.6.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://www.netsw.org/softeng/versioncontrol/repository/cvs/cvslines/
+MASTER_SITE_SUBDIR= jkoshy
+
+MAINTAINER= trevor@FreeBSD.org
+
+PLIST= ${WRKDIR}/pkg-plist
+USE_PERL5= yes
+NO_BUILD= yes
+
+MAN1= cvslines.1
+
+pre-patch:
+ ${PERL} -pi -e "s:usr/local/bin/perl5:${PERL5}:g" ${WRKSRC}/cvslines
+ ${PERL} -pi -e "s:the the:the:g" ${WRKSRC}/cvslines.1
+
+pre-install:
+.for i in s s_check s-status s-check s-commit s-config
+ ${ECHO_CMD} bin/cvsline$i >> ${PLIST}
+.endfor
+
+do-install:
+ PREFIX=${PREFIX} ${PERL5} ${WRKSRC}/INSTALL ${WRKSRC}/CONFIG
+
+.include <bsd.port.mk>
diff --git a/devel/cvslines/distinfo b/devel/cvslines/distinfo
new file mode 100644
index 000000000000..1948840acee9
--- /dev/null
+++ b/devel/cvslines/distinfo
@@ -0,0 +1 @@
+MD5 (cvslines-1.6.7.tar.gz) = efca84137a552925f84b0084d833021a
diff --git a/devel/cvslines/files/patch-aa b/devel/cvslines/files/patch-aa
new file mode 100644
index 000000000000..906c7ad6f8cd
--- /dev/null
+++ b/devel/cvslines/files/patch-aa
@@ -0,0 +1,32 @@
+--- CONFIG.old Wed May 21 11:39:38 1997
++++ CONFIG Fri Feb 1 04:43:42 2002
+@@ -14,17 +14,17 @@
+ # The absolute path to the perl interpreter to use.
+ # INSTALL will substitute this into the #!... line.
+ #
+-if (! defined($PERL5)) { $PERL5 = "/usr/local/bin/perl5"; } # cfg
++if (! defined($PERL5)) { $PERL5 = "$ENV{'PERL5'}"; } # cfg
+
+ # Where to install the cvslines scripts...
+ # (Absolute path)
+ #
+-if (! defined($BINDIR)) { $BINDIR = "/usr/local/bin"; } # cfg
++if (! defined($BINDIR)) { $BINDIR = "$ENV{'PREFIX'}/bin"; } # cfg
+
+ # Where to install the cvslines man page...
+ # (Absolute path)
+ #
+-if (! defined($MANDIR)) { $MAN1DIR = "/usr/local/man/man1"; } # cfg
++if (! defined($MANDIR)) { $MAN1DIR = "$ENV{'PREFIX'}/man/man1"; } # cfg
+
+ ######################################################################
+ #
+@@ -52,7 +52,7 @@
+
+ # Where the RCS to use with cvslines is kept.
+ #
+-\$RCSBIN = "$BINDIR"; # cfg
++\$RCSBIN = "/usr/bin/"; # cfg
+
+ 1;
+
diff --git a/devel/cvslines/files/patch-ab b/devel/cvslines/files/patch-ab
new file mode 100644
index 000000000000..9265dc0bbc4d
--- /dev/null
+++ b/devel/cvslines/files/patch-ab
@@ -0,0 +1,32 @@
+--- INSTALL-- Thu May 22 03:36:16 1997
++++ INSTALL Tue Aug 25 14:26:30 1998
+@@ -73,7 +73,7 @@
+ }
+
+
+-$uname = `/bin/uname -a`; chop $uname;
++$uname = `/usr/bin/uname -a`; chop $uname;
+ ($u_os, $u_host, $u_osrel) = split(/\s+/, $uname);
+
+ # Try to find things in the usual places, but failing those,
+@@ -121,7 +121,8 @@
+ {
+ if ( ! ( ($u_os eq "SunOS" && $u_osrel =~ /^5\./)
+ || ($u_os eq "SunOS" && $u_osrel =~ /^4\./)
+- || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)))
++ || ($u_os eq "OSF1" && $u_osrel =~ /^V[34]\./)
++ || ($u_os eq "FreeBSD")))
+ {
+ print STDERR <<MSG;
+ $Myname:
+@@ -148,9 +149,8 @@
+ cvslines has been tested with cvs 1.9. The "cvs" command found via
+ your \$PATH provided the following version information:
+ $cvs_versmsg
+- (press Return to continue with the install...)
+ MSG
+- $ans = <STDIN>;
++ # $ans = <STDIN>;
+
+ }
+ }
diff --git a/devel/cvslines/pkg-comment b/devel/cvslines/pkg-comment
new file mode 100644
index 000000000000..fe1e18dfd1b8
--- /dev/null
+++ b/devel/cvslines/pkg-comment
@@ -0,0 +1 @@
+A wrapper to help with merging changes between various cvs branches
diff --git a/devel/cvslines/pkg-descr b/devel/cvslines/pkg-descr
new file mode 100644
index 000000000000..6717801378d8
--- /dev/null
+++ b/devel/cvslines/pkg-descr
@@ -0,0 +1,8 @@
+cvslines extends the capability of the cvs commit command, to provide
+extra support in managing multiple concurrent lines of development.
+
+cvslines is a "wrapper" facility that helps out with merging changes
+between various cvs branches, where the branches represent different
+lines of development.
+
+WWW: http://www.floating.co.uk/netapp/technology/freeware/cvslines/