aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cvsnt/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2004-08-01 02:18:42 +0800
committerfjoe <fjoe@FreeBSD.org>2004-08-01 02:18:42 +0800
commita3d95e18451870ca783ccca3cb51f92ad75f4746 (patch)
tree22928586780552d0afd66a04ff4343cb07442c1c /devel/cvsnt/Makefile
parent9c48ddd156a204b89cc4dc698b66298147aa4b11 (diff)
downloadfreebsd-ports-gnome-a3d95e18451870ca783ccca3cb51f92ad75f4746.tar.gz
freebsd-ports-gnome-a3d95e18451870ca783ccca3cb51f92ad75f4746.tar.zst
freebsd-ports-gnome-a3d95e18451870ca783ccca3cb51f92ad75f4746.zip
- Update to 2.0.51.
- Add startup script for cvslockd.
Diffstat (limited to 'devel/cvsnt/Makefile')
-rw-r--r--devel/cvsnt/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/devel/cvsnt/Makefile b/devel/cvsnt/Makefile
index 2f5681b69f4e..0b1c8515b4e2 100644
--- a/devel/cvsnt/Makefile
+++ b/devel/cvsnt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cvsnt
-PORTVERSION= 2.0.34
+PORTVERSION= 2.0.51
CATEGORIES= devel
MASTER_SITES= http://www.cvsnt.org/archive/ \
http://homepages.nildram.co.uk/~tmhoyle/
@@ -15,7 +15,8 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= CVS clone
USE_LIBLTDL= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
+USE_RC_SUBR= yes
CONFIGURE_ARGS= --enable-fork
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GETOPT_LONG=yes
@@ -31,5 +32,16 @@ PLIST_SUB= GSERVER=""
.else
PLIST_SUB= GSERVER="@comment "
.endif
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
+STARTUPDIR= etc/rc.d
+STARTUPFILES= cvslockd.sh
+
+post-install:
+.for file in ${STARTUPFILES}
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/${file} > ${WRKDIR}/${file}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${file} ${PREFIX}/${STARTUPDIR}/${file}
+.endfor
.include <bsd.port.mk>