aboutsummaryrefslogtreecommitdiffstats
path: root/devel/cxref/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1996-10-24 15:59:56 +0800
committertg <tg@FreeBSD.org>1996-10-24 15:59:56 +0800
commit85a92871bb5ed8d79de6fb3d4758741b7235e6bd (patch)
tree515aa65f9cb351c7250a6e36446f4496f5434102 /devel/cxref/Makefile
parent00bf3fe0faae9a08e00e540d6231939b1729877c (diff)
downloadfreebsd-ports-gnome-85a92871bb5ed8d79de6fb3d4758741b7235e6bd.tar.gz
freebsd-ports-gnome-85a92871bb5ed8d79de6fb3d4758741b7235e6bd.tar.zst
freebsd-ports-gnome-85a92871bb5ed8d79de6fb3d4758741b7235e6bd.zip
Add a port of cxref-1.2b, a C program cross-referencing tool.
Diffstat (limited to 'devel/cxref/Makefile')
-rw-r--r--devel/cxref/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel/cxref/Makefile b/devel/cxref/Makefile
new file mode 100644
index 000000000000..c6821b028146
--- /dev/null
+++ b/devel/cxref/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: cxref
+# Version required: 1.2b
+# Date created: 26 May 1995
+# Whom: Satoshi Asami <asami@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= cxref-1.2
+PKGNAME= cxref-1.2b
+CATEGORIES+= devel
+MASTER_SITES= ftp://ftp.demon.co.uk/pub/unix/unix/tools/
+EXTRACT_SUFX= .tgz
+
+PATCHFILES= cxref-1.2-1.2a.diff.gz cxref-1.2a-1.2b.diff.gz
+PATCH_SITES= ${MASTER_SITES}
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= tg@freebsd.org
+
+WRKSRC= ${WRKDIR}/cxref
+USE_GMAKE= yes
+ALL_TARGET= program
+
+DOCDIR= ${PREFIX}/share/doc/cxref
+
+do-install:
+ @mkdir -p ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/cxref ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/query/cxref-query ${PREFIX}/bin
+ @mkdir -p ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/cxref.sty ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/fonts.sty ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/page.sty ${DOCDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/README.c ${DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}/README.cxref
+ ${INSTALL_DATA} ${WRKSRC}/query/README ${DOCDIR}/README.query
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Unfortunately, there's no man page."
+ @${ECHO_MSG} "Please see ${DOCDIR}/README* for documentation."
+.endif
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to use the LaTeX output from cxref,"
+ @${ECHO_MSG} "you should copy ${DOCDIR}/*.sty"
+ @${ECHO_MSG} "to a directory where TeX looks for its input files."
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>