aboutsummaryrefslogtreecommitdiffstats
path: root/devel/dbus-sharp
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2007-02-05 06:44:39 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2007-02-05 06:44:39 +0800
commitf5ded4ca3ad3d2bbfc601d12db2c706b2333f731 (patch)
treeeccb65c8860458b7e5e083aeab7bf6fdf5a98364 /devel/dbus-sharp
parentb2fd2d151103266906b799e50d672a12e3647f3e (diff)
downloadfreebsd-ports-gnome-f5ded4ca3ad3d2bbfc601d12db2c706b2333f731.tar.gz
freebsd-ports-gnome-f5ded4ca3ad3d2bbfc601d12db2c706b2333f731.tar.zst
freebsd-ports-gnome-f5ded4ca3ad3d2bbfc601d12db2c706b2333f731.zip
- Move to LOCALBASE
- USE_GNOME+=gtksharp20 - remove the mono-tools dependency since it wasn't even installing doc when it was present. (It's really not worth installing the doc since this API is going the way of the dodo.) NOTE: This port can probably go away now that it is no longer developed up stream and I believe all its past consumers now contain their own version of the new managed dbus assemblies. Project by: BSD# (http://www.mono-project.com/Mono:FreeBSD)
Diffstat (limited to 'devel/dbus-sharp')
-rw-r--r--devel/dbus-sharp/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/devel/dbus-sharp/Makefile b/devel/dbus-sharp/Makefile
index 627e82e7d8e9..9cc404601640 100644
--- a/devel/dbus-sharp/Makefile
+++ b/devel/dbus-sharp/Makefile
@@ -3,12 +3,12 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.18 2006/01/02 20:54:03 tmclau02 Exp $
+# $Id: Makefile,v 1.26 2006/11/15 16:22:08 tmclau02 Exp $
#
PORTNAME= dbus-sharp
PORTVERSION= 0.62
-PORTREVISION= 17
+PORTREVISION= 19
CATEGORIES= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus/
DISTNAME= dbus-${PORTVERSION}
@@ -17,13 +17,11 @@ MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Mono interface to the D-BUS messaging system
LIB_DEPENDS= dbus-1.3:${PORTSDIR}/devel/dbus
-BUILD_DEPENDS= monodoc:${PORTSDIR}/devel/mono-tools
-RUN_DEPENDS= monodoc:${PORTSDIR}/devel/mono-tools
BUILD_WRKSRC= ${WRKSRC}/mono
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-USE_GNOME= gnomehack gnometarget
+USE_GNOME= gnomehack gnometarget gtksharp10
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-mono \
@@ -37,14 +35,9 @@ CONFIGURE_ARGS= --enable-mono \
--with-session-socket-dir=/var/tmp \
--disable-doxygen-docs \
--disable-xml-docs
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-# Disable those, since it doesn't install docs yet.
-#post-patch:
-# @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-# ${WRKSRC}/mono/doc/Makefile.in
-
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>