aboutsummaryrefslogtreecommitdiffstats
path: root/devel/devhelp
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /devel/devhelp
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'devel/devhelp')
-rw-r--r--devel/devhelp/Makefile11
-rw-r--r--devel/devhelp/distinfo6
-rw-r--r--devel/devhelp/files/patch-src_dh-base.c19
-rw-r--r--devel/devhelp/pkg-plist24
4 files changed, 30 insertions, 30 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 46f4d75ff26b..5f0c3dca365c 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -3,16 +3,15 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-#
+# $MCom: ports/devel/devhelp/Makefile,v 1.10 2009/01/09 22:20:28 kwm Exp $
PORTNAME= devhelp
-PORTVERSION= 0.19.1
-PORTREVISION= 1
+PORTVERSION= 0.22
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kwm@FreeBSD.org
COMMENT= Developer help browser for GNOME 2
USE_BZIP2= yes
@@ -43,10 +42,6 @@ PLIST_SUB+= GEDIT=""
PLIST_SUB+= GEDIT="@comment "
.endif
-# This target is only meant to be used by the port maintainer.
-x-generate-plist:
- (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX}|${SED} -E 's,.*share/nls/.+$$,,g;s,^@dirrm share/((gnome/[^d]|pixmaps|application|locale).*|gnome$$),,;s,^@dirrm etc/gconf.*,,;s,^etc/gconf/gconf.*,,'|${TR} -s '\n') > temp-pkg-plist
-
post-patch:
.if defined(WITHOUT_GEDIT)
@${REINPLACE_CMD} -e 's|gedit-plugin||' \
diff --git a/devel/devhelp/distinfo b/devel/devhelp/distinfo
index 6421119815df..8c21dd82e15f 100644
--- a/devel/devhelp/distinfo
+++ b/devel/devhelp/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/devhelp-0.19.1.tar.bz2) = 6c12a272a94ac9cfc1dc6234590b46d8
-SHA256 (gnome2/devhelp-0.19.1.tar.bz2) = be447b9496b09e97bde51e6d638c94e6e4718feebe6b3c76cf256a18baf22e4f
-SIZE (gnome2/devhelp-0.19.1.tar.bz2) = 533193
+MD5 (gnome2/devhelp-0.22.tar.bz2) = 7cdd0688dba0184b6dd2688532af24cb
+SHA256 (gnome2/devhelp-0.22.tar.bz2) = 1fa4b69c99b10de0e27374e18eea7988e3e8f9243020a22a47f79c9ccad92947
+SIZE (gnome2/devhelp-0.22.tar.bz2) = 517581
diff --git a/devel/devhelp/files/patch-src_dh-base.c b/devel/devhelp/files/patch-src_dh-base.c
index ffa3c3b54602..3dbf1c71cf4e 100644
--- a/devel/devhelp/files/patch-src_dh-base.c
+++ b/devel/devhelp/files/patch-src_dh-base.c
@@ -1,13 +1,14 @@
---- src/dh-base.c.orig Tue May 15 13:00:24 2007
-+++ src/dh-base.c Sun Jul 8 03:48:13 2007
-@@ -233,6 +233,10 @@ base_add_books_in_data_dir (DhBase *base
- dir = g_build_filename (data_dir, "devhelp", "books", NULL);
- base_add_books (base, dir);
- g_free (dir);
+--- src/dh-base.c.orig 2008-10-11 00:00:18.000000000 +0200
++++ src/dh-base.c 2009-01-09 23:10:12.000000000 +0100
+@@ -214,6 +214,11 @@ base_add_books_in_data_dir (DhBase
+ dir = g_build_filename (data_dir, "devhelp", "books", NULL);
+ base_add_books (base, dir);
+ g_free (dir);
++
++ dir = g_build_filename (data_dir, "doc", NULL);
++ base_add_books (base, dir);
++ g_free (dir);
+
-+ dir = g_build_filename (data_dir, "doc", NULL);
-+ base_add_books (base, dir);
-+ g_free (dir);
}
static void
diff --git a/devel/devhelp/pkg-plist b/devel/devhelp/pkg-plist
index 4584ddfe5609..83649fae27a5 100644
--- a/devel/devhelp/pkg-plist
+++ b/devel/devhelp/pkg-plist
@@ -1,16 +1,13 @@
bin/devhelp
+include/devhelp-1.0/devhelp/dh-assistant-view.h
+include/devhelp-1.0/devhelp/dh-assistant.h
include/devhelp-1.0/devhelp/dh-base.h
include/devhelp-1.0/devhelp/dh-book-tree.h
include/devhelp-1.0/devhelp/dh-error.h
-include/devhelp-1.0/devhelp/dh-html.h
include/devhelp-1.0/devhelp/dh-keyword-model.h
include/devhelp-1.0/devhelp/dh-link.h
-include/devhelp-1.0/devhelp/dh-parser.h
-include/devhelp-1.0/devhelp/dh-preferences.h
include/devhelp-1.0/devhelp/dh-search.h
-include/devhelp-1.0/devhelp/dh-util.h
include/devhelp-1.0/devhelp/dh-window.h
-include/devhelp-1.0/devhelp/eggfindbar.h
%%GEDIT%%lib/gedit-2/plugins/devhelp.gedit-plugin
%%GEDIT%%lib/gedit-2/plugins/devhelp/__init__.py
%%GEDIT%%lib/gedit-2/plugins/devhelp/__init__.pyc
@@ -24,12 +21,11 @@ lib/libdevhelp-1.so
lib/libdevhelp-1.so.0
libdata/pkgconfig/libdevhelp-1.0.pc
share/applications/devhelp.desktop
-share/devhelp/default-prefs.js
-share/devhelp/devhelp.glade
+share/devhelp/assistant/assistant.css
+share/devhelp/assistant/assistant.js
+share/devhelp/devhelp.defaults
share/devhelp/dtd/devhelp-1.dtd
-share/devhelp/images/book_closed.png
-share/devhelp/images/book_open.png
-share/devhelp/images/helpdoc.png
+share/devhelp/ui/devhelp.builder
share/devhelp/ui/window.ui
share/icons/hicolor/16x16/apps/devhelp.png
share/icons/hicolor/22x22/apps/devhelp.png
@@ -81,6 +77,7 @@ share/locale/oc/LC_MESSAGES/devhelp.mo
share/locale/or/LC_MESSAGES/devhelp.mo
share/locale/pa/LC_MESSAGES/devhelp.mo
share/locale/pl/LC_MESSAGES/devhelp.mo
+share/locale/ps/LC_MESSAGES/devhelp.mo
share/locale/pt/LC_MESSAGES/devhelp.mo
share/locale/pt_BR/LC_MESSAGES/devhelp.mo
share/locale/ru/LC_MESSAGES/devhelp.mo
@@ -103,6 +100,7 @@ share/locale/zh_TW/LC_MESSAGES/devhelp.mo
@dirrm share/devhelp/ui
@dirrm share/devhelp/images
@dirrm share/devhelp/dtd
+@dirrm share/devhelp/assistant
@dirrm share/devhelp
@dirrm include/devhelp-1.0/devhelp
@dirrm include/devhelp-1.0
@@ -110,10 +108,16 @@ share/locale/zh_TW/LC_MESSAGES/devhelp.mo
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@Latn/LC_MESSAGES
+@dirrmtry share/locale/sr@Latn
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES