aboutsummaryrefslogtreecommitdiffstats
path: root/devel/devhelp
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-05-19 03:53:17 +0800
committermezz <mezz@FreeBSD.org>2008-05-19 03:53:17 +0800
commitba02c8c4e0b6521a63a929bd69d48184db311cd7 (patch)
tree7a8e4408c6f45c37c1ff3dcef6b616544c41cef5 /devel/devhelp
parent3e76dfd4716a4c5a38d37dd992e0785e2edd3249 (diff)
downloadfreebsd-ports-gnome-ba02c8c4e0b6521a63a929bd69d48184db311cd7.tar.gz
freebsd-ports-gnome-ba02c8c4e0b6521a63a929bd69d48184db311cd7.tar.zst
freebsd-ports-gnome-ba02c8c4e0b6521a63a929bd69d48184db311cd7.zip
-Convert to current gecko framework (USE_GECKO).
-Remove seamonkey option; it doesn't build. [1] -Correct the USE_LDCONFIG. (Unsure why it has lib/${MOZILLA}.) PR: ports/117327 [1] Reported by: Marat N.Afanasyev <marat@zealot.ksu.ru> [1]
Diffstat (limited to 'devel/devhelp')
-rw-r--r--devel/devhelp/Makefile32
1 files changed, 5 insertions, 27 deletions
diff --git a/devel/devhelp/Makefile b/devel/devhelp/Makefile
index 38aa91973b40..9ebdf7669c08 100644
--- a/devel/devhelp/Makefile
+++ b/devel/devhelp/Makefile
@@ -9,45 +9,31 @@ PORTNAME= devhelp
PORTVERSION= 0.19
PORTREVISION= 1
CATEGORIES= devel gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C,^([[:digit:]]+\.[[:digit:]]+).*,\1,}
+MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
MAINTAINER= ports@FreeBSD.org
COMMENT= Developer help browser for GNOME 2
-BUILD_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-RUN_DEPENDS= ${LOCALBASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-
-MOZILLA= firefox
-
-.if !defined(WITH_MOZILLA)
-MOZILLA= firefox
-.else
-.if ${WITH_MOZILLA} == "xulrunner"
-MOZILLA= xulrunner
-.elif ${WITH_MOZILLA} == "seamonkey"
-MOZILLA= seamonkey
-.endif
-.endif
-
USE_BZIP2= yes
USE_XORG= x11
USE_GETTEXT= yes
+USE_GECKO= firefox xulrunner
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui libwnck
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_LDCONFIG= ${LOCALBASE}/lib/${MOZILLA}
+USE_LDCONFIG= yes
GCONF_SCHEMAS= devhelp.schemas
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gecko=${MOZILLA}
+CONFIGURE_ARGS= --with-gecko=${GECKO}
OPTIONS= GEDIT "Enable GEdit plug-in support" off
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.if defined(WITH_GEDIT)
BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
@@ -67,12 +53,4 @@ post-patch:
${WRKSRC}/misc/Makefile.in
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} " By default the port uses www/firefox for html rendering, but you can"
- @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
- @${ECHO_MSG}
- @${ECHO_MSG} " xulrunner seamonkey "
- @${ECHO_MSG} ""
-
.include <bsd.port.post.mk>