aboutsummaryrefslogtreecommitdiffstats
path: root/devel/devtodo
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-01-27 21:18:02 +0800
committerpav <pav@FreeBSD.org>2007-01-27 21:18:02 +0800
commit8c54c80249291280c439df4921a8794b30cc177c (patch)
tree72d772d80657fe321df9a3d897b3a8ebe21e846a /devel/devtodo
parent3edbc8cee394b4176fcb1822778d6f69ec22c3d4 (diff)
downloadfreebsd-ports-gnome-8c54c80249291280c439df4921a8794b30cc177c.tar.gz
freebsd-ports-gnome-8c54c80249291280c439df4921a8794b30cc177c.tar.zst
freebsd-ports-gnome-8c54c80249291280c439df4921a8794b30cc177c.zip
- Fix build with gcc4
- Take maintainership
Diffstat (limited to 'devel/devtodo')
-rw-r--r--devel/devtodo/Makefile2
-rw-r--r--devel/devtodo/files/patch-Todo.h11
-rw-r--r--devel/devtodo/files/patch-TodoDB.h11
3 files changed, 23 insertions, 1 deletions
diff --git a/devel/devtodo/Makefile b/devel/devtodo/Makefile
index 09e7d9436e71..fb868ce39c80 100644
--- a/devel/devtodo/Makefile
+++ b/devel/devtodo/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 0.1.19
CATEGORIES= devel
MASTER_SITES= http://swapoff.org/files/devtodo/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= pav@FreeBSD.org
COMMENT= Tool to effectively maintain todo lists aimed at developers
GNU_CONFIGURE= yes
diff --git a/devel/devtodo/files/patch-Todo.h b/devel/devtodo/files/patch-Todo.h
new file mode 100644
index 000000000000..f8e43a8de29b
--- /dev/null
+++ b/devel/devtodo/files/patch-Todo.h
@@ -0,0 +1,11 @@
+--- src/Todo.h.orig Fri Sep 3 11:35:13 2004
++++ src/Todo.h Sat Jan 27 14:10:54 2007
+@@ -14,6 +14,8 @@
+ 01/02/01 Initial creation
+ */
+
++class TodoDB;
++
+ class Todo {
+ public :
+ friend class TodoDB;
diff --git a/devel/devtodo/files/patch-TodoDB.h b/devel/devtodo/files/patch-TodoDB.h
new file mode 100644
index 000000000000..44bba33a9fbb
--- /dev/null
+++ b/devel/devtodo/files/patch-TodoDB.h
@@ -0,0 +1,11 @@
+--- src/TodoDB.h.orig Fri Sep 3 11:35:14 2004
++++ src/TodoDB.h Sat Jan 27 14:11:37 2007
+@@ -108,7 +108,7 @@
+ void initColour();
+ void initColourPost();
+ Todo::Priority getPriority(string current = "");
+- int TodoDB::markDone(Todo &todo);
++ int markDone(Todo &todo);
+
+ void formatItem(ostream &out, int depth, Todo const &item, string const &format);
+