aboutsummaryrefslogtreecommitdiffstats
path: root/devel/diffuse
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-12 06:27:51 +0800
committermiwi <miwi@FreeBSD.org>2009-04-12 06:27:51 +0800
commiteb3494b4516e28924fda8128521768904ee5455e (patch)
tree733f414c45401e5030733474e1e336bf02174c04 /devel/diffuse
parentaa17bc9377752bc2d078eeab77d4ae1baa95f912 (diff)
downloadfreebsd-ports-gnome-eb3494b4516e28924fda8128521768904ee5455e.tar.gz
freebsd-ports-gnome-eb3494b4516e28924fda8128521768904ee5455e.tar.zst
freebsd-ports-gnome-eb3494b4516e28924fda8128521768904ee5455e.zip
Diffuse is a graphical tool for merging and comparing text files. Diffuse is
able to compare an arbitrary number of files side-by-side and gives users the ability to manually adjust line matching and directly edit files. Diffuse can also retrieve revisions of files from Bazaar, CVS, Darcs, Git, Mercurial, Monotone, Subversion, and SVK repositories for comparison and merging. Some key features of Diffuse: - ability to compare and merge an arbitrary number of files side-by-side (n-way merges) - line matching can be manually corrected by the user - ability to directly edit files - syntax highlighting - Bazaar, CVS, Darcs, Git, Mercurial, Monotone, Subversion, and SVK support - support for UTF-8 encoded unicode - unlimited undo - easy keyboard navigation WWW: http://diffuse.sourceforge.net/ PR: ports/132027 Submitted by: Marco Broeder <marco.broeder at gmx.eu>
Diffstat (limited to 'devel/diffuse')
-rw-r--r--devel/diffuse/Makefile106
-rw-r--r--devel/diffuse/distinfo3
-rw-r--r--devel/diffuse/pkg-descr19
-rw-r--r--devel/diffuse/pkg-plist48
4 files changed, 176 insertions, 0 deletions
diff --git a/devel/diffuse/Makefile b/devel/diffuse/Makefile
new file mode 100644
index 000000000000..16653cf222c2
--- /dev/null
+++ b/devel/diffuse/Makefile
@@ -0,0 +1,106 @@
+# Ports collection makefile for: diffuse
+# Date created: 2009-02-22
+# Whom: Marco Broeder <marco.broeder@gmx.eu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diffuse
+PORTVERSION= 0.3.1
+CATEGORIES= devel python
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= diffuse
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= ${DISTFILES}
+
+MAINTAINER= marco.broeder@gmx.eu
+COMMENT= A graphical N-way diff and merge tool written in python
+
+NO_BUILD= yes
+
+USE_PYTHON= 2.5+
+USE_GNOME= pygtk2
+USE_BZIP2= yes
+
+MAN1= diffuse.1
+
+OPTIONS= MENU "Add desktop menu (needs desktop-file-utils)" on \
+ OMF "Install OMF manual (needs scrollkeeper)" on
+
+.include <bsd.port.pre.mk>
+
+.ifndef (NOPORTDOCS)
+DOCS= AUTHORS ChangeLog COPYING README TODO
+.endif
+
+.ifdef (WITH_MENU)
+PLIST_SUB+= MENU=""
+RUN_DEPENDS+= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
+INSTALLS_ICONS= yes
+.else
+PLIST_SUB+= MENU="@comment "
+.endif
+
+.ifdef (WITH_OMF)
+PLIST_SUB+= OMF=""
+RUN_DEPENDS+= scrollkeeper-update:${PORTSDIR}/textproc/scrollkeeper
+INSTALLS_OMF= yes
+.else
+PLIST_SUB+= OMF="@comment "
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|../usr|${PREFIX}|g' \
+ ${WRKSRC}/src/etc/${PORTNAME}rc
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/usr/bin/${PORTNAME} \
+ ${PREFIX}/bin/${PORTNAME}
+
+ ${INSTALL_DATA} ${WRKSRC}/src/etc/${PORTNAME}rc ${PREFIX}/etc/
+
+post-install:
+ ${MKDIR} ${DATADIR}/syntax
+ ${INSTALL_DATA} ${WRKSRC}/src/usr/share/${PORTNAME}/syntax/*.syntax \
+ ${DATADIR}/syntax/
+
+ ${INSTALL_MAN} ${WRKSRC}/src/usr/share/man/man1/*.1 \
+ ${MANPREFIX}/man/man1/
+
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ for n in ${DOCS}; do \
+ ${INSTALL_MAN} ${WRKSRC}/$${n} ${DOCSDIR}; \
+ done
+
+.endif
+
+.ifdef (WITH_OMF)
+
+ ${MKDIR} ${PREFIX}/share/gnome/help/${PORTNAME}/C
+ ${INSTALL_DATA} ${WRKSRC}/src/usr/share/gnome/help/${PORTNAME}/C/*.xml \
+ ${PREFIX}/share/gnome/help/${PORTNAME}/C/
+
+ ${MKDIR} ${PREFIX}/share/omf/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/usr/share/omf/${PORTNAME}/*.omf \
+ ${PREFIX}/share/omf/${PORTNAME}/
+
+ ${PREFIX}/bin/scrollkeeper-update -q
+
+.endif
+
+.ifdef (WITH_MENU)
+
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/src/usr/share/pixmaps/${PORTNAME}.png \
+ ${PREFIX}/share/pixmaps/
+
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/src/usr/share/applications/*.desktop \
+ ${DESKTOPDIR}
+
+ ${PREFIX}/bin/update-desktop-database
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/diffuse/distinfo b/devel/diffuse/distinfo
new file mode 100644
index 000000000000..95db06a917b7
--- /dev/null
+++ b/devel/diffuse/distinfo
@@ -0,0 +1,3 @@
+MD5 (diffuse-0.3.1.tar.bz2) = b590426677579fe1be761a1bb6678578
+SHA256 (diffuse-0.3.1.tar.bz2) = f0fc932332748a80c0a244771f38ecf653cc6cb89c5c89c5124cb5c6abfc28b7
+SIZE (diffuse-0.3.1.tar.bz2) = 88923
diff --git a/devel/diffuse/pkg-descr b/devel/diffuse/pkg-descr
new file mode 100644
index 000000000000..725f69ace128
--- /dev/null
+++ b/devel/diffuse/pkg-descr
@@ -0,0 +1,19 @@
+Diffuse is a graphical tool for merging and comparing text files. Diffuse is
+able to compare an arbitrary number of files side-by-side and gives users the
+ability to manually adjust line matching and directly edit files. Diffuse can
+also retrieve revisions of files from Bazaar, CVS, Darcs, Git, Mercurial,
+Monotone, Subversion, and SVK repositories for comparison and merging.
+
+Some key features of Diffuse:
+
+- ability to compare and merge an arbitrary number of files side-by-side
+ (n-way merges)
+- line matching can be manually corrected by the user
+- ability to directly edit files
+- syntax highlighting
+- Bazaar, CVS, Darcs, Git, Mercurial, Monotone, Subversion, and SVK support
+- support for UTF-8 encoded unicode
+- unlimited undo
+- easy keyboard navigation
+
+WWW: http://diffuse.sourceforge.net/
diff --git a/devel/diffuse/pkg-plist b/devel/diffuse/pkg-plist
new file mode 100644
index 000000000000..83d664cbaf78
--- /dev/null
+++ b/devel/diffuse/pkg-plist
@@ -0,0 +1,48 @@
+bin/diffuse
+etc/diffuserc
+%%DATADIR%%/syntax/bash.syntax
+%%DATADIR%%/syntax/c++.syntax
+%%DATADIR%%/syntax/csh.syntax
+%%DATADIR%%/syntax/csharp.syntax
+%%DATADIR%%/syntax/css.syntax
+%%DATADIR%%/syntax/gettext.syntax
+%%DATADIR%%/syntax/html.syntax
+%%DATADIR%%/syntax/ini.syntax
+%%DATADIR%%/syntax/java.syntax
+%%DATADIR%%/syntax/javascript.syntax
+%%DATADIR%%/syntax/jsp.syntax
+%%DATADIR%%/syntax/makefile.syntax
+%%DATADIR%%/syntax/objective-c++.syntax
+%%DATADIR%%/syntax/octave.syntax
+%%DATADIR%%/syntax/pascal.syntax
+%%DATADIR%%/syntax/patch.syntax
+%%DATADIR%%/syntax/perl.syntax
+%%DATADIR%%/syntax/php.syntax
+%%DATADIR%%/syntax/python.syntax
+%%DATADIR%%/syntax/ruby.syntax
+%%DATADIR%%/syntax/sql.syntax
+%%DATADIR%%/syntax/tcl.syntax
+%%DATADIR%%/syntax/vb.syntax
+%%DATADIR%%/syntax/verilog.syntax
+%%DATADIR%%/syntax/vhdl.syntax
+%%DATADIR%%/syntax/xml.syntax
+@dirrm %%DATADIR%%/syntax
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%OMF%%share/gnome/help/diffuse/C/diffuse.xml
+%%OMF%%@dirrm share/gnome/help/diffuse/C
+%%OMF%%@dirrm share/gnome/help/diffuse
+%%OMF%%@dirrmtry share/gnome/help
+%%OMF%%@dirrmtry share/gnome
+%%OMF%%share/omf/diffuse/diffuse-C.omf
+%%OMF%%@dirrm share/omf/diffuse
+%%OMF%%@dirrmtry share/omf
+%%MENU%%share/applications/diffuse.desktop
+%%MENU%%@dirrmtry share/applications
+%%MENU%%share/pixmaps/diffuse.png
+%%MENU%%@dirrmtry share/pixmaps