aboutsummaryrefslogtreecommitdiffstats
path: root/devel/directfb
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-07-03 22:25:53 +0800
committermezz <mezz@FreeBSD.org>2009-07-03 22:25:53 +0800
commitbd5831d3490fce384b8f5870e94f47b895505f53 (patch)
tree070286f9bcc6549d8fd1117b6f6c106cbe7c07e5 /devel/directfb
parent4807d72819d7161f6ae367046aeb84dcd69a8aa2 (diff)
downloadfreebsd-ports-gnome-bd5831d3490fce384b8f5870e94f47b895505f53.tar.gz
freebsd-ports-gnome-bd5831d3490fce384b8f5870e94f47b895505f53.tar.zst
freebsd-ports-gnome-bd5831d3490fce384b8f5870e94f47b895505f53.zip
Use LTMAIN instead of hardcore.
Approved by: Anatoly Borodin <anatoly.borodin@gmail.com> (maintainer)
Diffstat (limited to 'devel/directfb')
-rw-r--r--devel/directfb/Makefile5
-rw-r--r--devel/directfb/files/patch-configure2
2 files changed, 4 insertions, 3 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index ccb0b94018da..52ac0a217429 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -76,7 +76,8 @@ BROKEN= Does not compile on alpha
.endif
post-patch:
- @${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure.in
+ @${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/g ; \
+ s/-lpthread/${PTHREAD_LIBS}/g ; s|%%LTMAIN%%|${LTMAIN}|g' \
+ ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/devel/directfb/files/patch-configure b/devel/directfb/files/patch-configure
index 1340d6d592c9..40df29c5b482 100644
--- a/devel/directfb/files/patch-configure
+++ b/devel/directfb/files/patch-configure
@@ -5,7 +5,7 @@
# This can be used to rebuild libtool when needed
-LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+LIBTOOL_DEPS="--disable-ltlibs /usr/local/share/libtool/ltmain.sh"
++LIBTOOL_DEPS="--disable-ltlibs %%LTMAIN%%"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.