aboutsummaryrefslogtreecommitdiffstats
path: root/devel/distcc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
committermarcus <marcus@FreeBSD.org>2007-10-25 07:37:25 +0800
commit43bd9f14d9ce11690e9538bf3b03d3462faa6dbe (patch)
treeda347910089a96d6d726b8bb080f62c773263828 /devel/distcc
parent2e669ed08a56339ee1a8b2a0573a30147f95bd82 (diff)
downloadfreebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.gz
freebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.tar.zst
freebsd-ports-gnome-43bd9f14d9ce11690e9538bf3b03d3462faa6dbe.zip
Presenting GNOME 2.20.1 and all related works for FreeBSD. The official
GNOME 2.20 release notes can be found at http://www.gnome.org/start/2.20/notes/en/ . Beyond that, this update includes the new GIMP 2.4 (courtesy of ahze). The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME hierarchy. We are now using the more standard DATADIR of ${PREFIX}/share rather than ${PREFIX}/share/gnome. The result is that fewer patches and hacks are needed to port GNOME components to FreeBSD. This will mean some user changes may be required, so be sure to read /usr/ports/UPDATING for more details. This release and the things we accomplished in it would not have been possible without mezz's crazy idea to collapse DATADIR, and his persistence to make it happen successfully. Ahze and pav also deserve thanks for their work on porting modules and testing the whole ball of wax on pointyhat (respectively). The FreeBSD GNOME team would also like to thank our various testers and contributors: Yasuda Keisuke Frank Jahnke Pawel Worach Brian Gruber Franz Klammer Yuri Pankov Nick Barkas Cristian KLEIN Tony Maher Scot Hetzel Martin Matuska (mm) Benoit Dejean Martin Wilke (miwi) (And anyone else I may have missed) PRs fixed in this release: 111272, 113470, 115995, 116338
Diffstat (limited to 'devel/distcc')
-rw-r--r--devel/distcc/Makefile25
-rw-r--r--devel/distcc/distinfo3
-rw-r--r--devel/distcc/files/distccd.sh.in2
3 files changed, 20 insertions, 10 deletions
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
index 4a7cbdb0f06a..e622d240b51a 100644
--- a/devel/distcc/Makefile
+++ b/devel/distcc/Makefile
@@ -3,13 +3,15 @@
# Whom: Frerich Raabe <frerich.raabe@gmx.de>
#
# $FreeBSD$
+# $MCom: ports/devel/distcc/Makefile,v 1.3 2007/10/21 02:46:13 ahze Exp $
#
PORTNAME= distcc
PORTVERSION= 2.18.3
-PORTREVISION= 5
-CATEGORIES= devel ipv6
+PORTREVISION= 7
+CATEGORIES= devel
MASTER_SITES= http://distcc.samba.org/ftp/distcc/
+PATCH_SITES= http://0pointer.de/public/
MAINTAINER= ahze@FreeBSD.org
COMMENT= Distribute compilation of C(++) code acrosss machines on a network
@@ -20,19 +22,28 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-rfc2553
WANT_GNOME= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
DISTCCD_PIDFILE=/var/run/distccd.pid
USE_RC_SUBR= distccd.sh
SUB_LIST= DISTCCD_PIDFILE=${DISTCCD_PIDFILE}
-OPTIONS= GNOME "Build GUI monitor based on GNOME" Off \
+OPTIONS= AVAHI "Enable Avahi Zeroconf/mDNS/Bonjour support" Off \
+ GNOME "Build GUI monitor based on GNOME" Off \
GTK "Build GUI monitor based on GTK" Off \
- IPV6 "Enable IPV6" Off \
- COMPILER_LINKS "Create symlinks to distcc" Off
+ COMPILER_LINKS "Create symlinks to distcc" On
.include <bsd.port.pre.mk>
+.if defined(WITH_AVAHI)
+PATCHFILES+= distcc-avahi.patch
+LIB_DEPENDS+= avahi-glib.1:${PORTSDIR}/net/avahi
+PATCH_DIST_STRIP= -p1
+USE_AUTOTOOLS+= autoconf:261
+CFLAGS+= -DHAVE_AVAHI
+.endif
+
.if defined(WITH_COMPILER_LINKS)
CCLINKDIR?= libexec/distcc
PLIST_DIRS= ${CCLINKDIR}
@@ -61,10 +72,6 @@ PLIST_SUB+= WITH_GNOME=""
PLIST_SUB+= WITH_GNOME="@comment "
.endif
-.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-rfc2553
-.endif
-
MAN1= distcc.1 distccd.1
DOC_FILES= AUTHORS INSTALL NEWS README \
doc/protocol-1.txt doc/status-1.txt \
diff --git a/devel/distcc/distinfo b/devel/distcc/distinfo
index e20d0e56e131..1d8af34f329c 100644
--- a/devel/distcc/distinfo
+++ b/devel/distcc/distinfo
@@ -1,3 +1,6 @@
MD5 (distcc-2.18.3.tar.bz2) = 0d6b80a1efc3a3d816c4f4175f63eaa2
SHA256 (distcc-2.18.3.tar.bz2) = 6500f1bc2a30b1f044ebed79c6ce15457d1712263e65f0db7d6046af262ba434
SIZE (distcc-2.18.3.tar.bz2) = 341601
+MD5 (distcc-avahi.patch) = 621dc7dc1e3b9b6770110117df45611a
+SHA256 (distcc-avahi.patch) = e6651e3de7fee6d953b6ee56732eafa7d4666cb4070db5a925ba071626067c9a
+SIZE (distcc-avahi.patch) = 54086
diff --git a/devel/distcc/files/distccd.sh.in b/devel/distcc/files/distccd.sh.in
index d5a9efb91add..0942b3014f7a 100644
--- a/devel/distcc/files/distccd.sh.in
+++ b/devel/distcc/files/distccd.sh.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-#
+# $MCom: ports/devel/distcc/files/distccd.sh.in,v 1.1 2007/05/19 17:43:14 ahze Exp $
# PROVIDE: distccd
# REQUIRE: NETWORKING