aboutsummaryrefslogtreecommitdiffstats
path: root/devel/distcc
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-08-26 10:39:05 +0800
committerlioux <lioux@FreeBSD.org>2002-08-26 10:39:05 +0800
commit6b0d2ddebad463e7fe6460a36643c92f9d5eb5eb (patch)
tree0aae113fd2523aebe7bc698f2a8f0bd7e8357367 /devel/distcc
parent9ea2ca13fe785016590a1352922354ed9db64fa7 (diff)
downloadfreebsd-ports-gnome-6b0d2ddebad463e7fe6460a36643c92f9d5eb5eb.tar.gz
freebsd-ports-gnome-6b0d2ddebad463e7fe6460a36643c92f9d5eb5eb.tar.zst
freebsd-ports-gnome-6b0d2ddebad463e7fe6460a36643c92f9d5eb5eb.zip
o Problem: "libstdc++-v3's configure script (and others) execute
commands such as .../xgcc -B.../ conftest.C -c -S. Assuming that xgcc invokes the distcc client, this makes the distcc client write the assembly output to conftest.o even though it should go into conftest.s. The cause of this is that distcc currently does not honour the fact that -S supersedes -c. Interestingly, if you add "-o conftest.s" to the command line, it's the distcc server that fails, claiming it couldn't find conftest.C." o The attached patch fixes this behaviour. Courtesy of [1] PR: 42019 Submitted by: MAINTAINER, Alexandre Oliva <aoliva@redhat.com> [1]
Diffstat (limited to 'devel/distcc')
-rw-r--r--devel/distcc/Makefile1
-rw-r--r--devel/distcc/files/patch-src::arg.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/devel/distcc/Makefile b/devel/distcc/Makefile
index 25e85df88abc..63de728362fb 100644
--- a/devel/distcc/Makefile
+++ b/devel/distcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= distcc
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://distcc.samba.org/ftp/distcc/
diff --git a/devel/distcc/files/patch-src::arg.c b/devel/distcc/files/patch-src::arg.c
new file mode 100644
index 000000000000..d5a319c554b6
--- /dev/null
+++ b/devel/distcc/files/patch-src::arg.c
@@ -0,0 +1,20 @@
+--- src/arg.c.orig Thu Aug 15 10:52:19 2002
++++ src/arg.c Sun Aug 25 23:32:17 2002
+@@ -200,12 +200,13 @@
+ /* FIXME: This doesn't handle a.out, but that doesn't matter.
+ */
+ char *ofile;
+- if (seen_opt_c) {
+- if (dcc_output_from_source(*input_file, ".o", &ofile))
+- return -1;
+- } else if (seen_opt_s) {
++ /* -S takes precedence over -c. */
++ if (seen_opt_s) {
+ if (dcc_output_from_source(*input_file, ".s", &ofile))
+ return -1;
++ } else if (seen_opt_c) {
++ if (dcc_output_from_source(*input_file, ".o", &ofile))
++ return -1;
+ } else {
+ rs_log_crit("this can't be happening(%d)!", __LINE__);
+ return -1;