aboutsummaryrefslogtreecommitdiffstats
path: root/devel/dmalloc/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-04 11:05:48 +0800
committeredwin <edwin@FreeBSD.org>2002-11-04 11:05:48 +0800
commit011f3a2a13f514a55dae8ea737db2d626983191d (patch)
treeef9e57574419ab4a95c9adca518cce23e6a78895 /devel/dmalloc/Makefile
parentf2bc149e9a1f30296a05f9c708c6729f700c8234 (diff)
downloadfreebsd-ports-gnome-011f3a2a13f514a55dae8ea737db2d626983191d.tar.gz
freebsd-ports-gnome-011f3a2a13f514a55dae8ea737db2d626983191d.tar.zst
freebsd-ports-gnome-011f3a2a13f514a55dae8ea737db2d626983191d.zip
PERL -> REINPLACE
and russian/mod_ssl has USE_PERL5=yes Notices on: bento
Diffstat (limited to 'devel/dmalloc/Makefile')
-rw-r--r--devel/dmalloc/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/dmalloc/Makefile b/devel/dmalloc/Makefile
index a8ecfa7b6c9c..3ab314bd33e3 100644
--- a/devel/dmalloc/Makefile
+++ b/devel/dmalloc/Makefile
@@ -16,6 +16,7 @@ MAINTAINER= jeremy@external.org
INSTALLS_SHLIB= YES
GNU_CONFIGURE= YES
+USE_REINPLACE= yes
CONFIGURE_ARGS+=--enable-threads --enable-shlib
# NOTE: we make the test program first because otherwise it screws up
@@ -23,7 +24,7 @@ CONFIGURE_ARGS+=--enable-threads --enable-shlib
ALL_TARGET= dmalloc_t all light
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dmalloc ${PREFIX}/bin