aboutsummaryrefslogtreecommitdiffstats
path: root/devel/doxygen
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-03-04 08:10:14 +0800
committerlofi <lofi@FreeBSD.org>2004-03-04 08:10:14 +0800
commitaf30d2f2de4cca0ee97aee90ed56548356abfe31 (patch)
tree1ce7a4cc4f328fe18b8138104128c88760cc0ebd /devel/doxygen
parent77e283716694dfa05fff5659a328508e2f8fb06d (diff)
downloadfreebsd-ports-gnome-af30d2f2de4cca0ee97aee90ed56548356abfe31.tar.gz
freebsd-ports-gnome-af30d2f2de4cca0ee97aee90ed56548356abfe31.tar.zst
freebsd-ports-gnome-af30d2f2de4cca0ee97aee90ed56548356abfe31.zip
${PERL} -pi -> ${REINPLACE_CMD}
(Sorry for the delay, kde@freebsd.org was down for 1.5 weeks) Noticed by: Adam Weinberger <adamw@magnesium.net>
Diffstat (limited to 'devel/doxygen')
-rw-r--r--devel/doxygen/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 20e7ae1cb77c..d28c975e5cea 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -52,6 +52,7 @@ PLIST_SUB+= HAVE_DOXYWIZARD="@comment "
.endif # !WITHOUT_DOXYWIZARD
USE_PERL5= yes
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
QT_NONSTANDARD= yes # non-standard configure arguments
@@ -63,7 +64,7 @@ CONFIGURE_ARGS+= --enable-langs no
.endif
pre-configure:
- @${PERL} -pi -e "s:gcc:${CC}:g; \
+ @${REINPLACE_CMD} -e "s:gcc:${CC}:g; \
s:g\+\+:${CXX}:g; \
s:%%LIBQT%%:-l${QTNAME}:g; \
s:%%MOC%%:${MOC}:g; \
@@ -76,7 +77,7 @@ pre-configure:
${WRKSRC}/tmake/lib/freebsd-g++/tmake.conf
post-patch:
- @${PERL} -pi.fbsd -e 's|<malloc.h>|<stdlib.h>|g' \
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' \
${WRKSRC}/libpng/pngconf.h \
${WRKSRC}/libpng/zutil.h ${WRKSRC}/src/pngenc.cpp