aboutsummaryrefslogtreecommitdiffstats
path: root/devel/duplo
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-10-05 10:32:22 +0800
committerijliao <ijliao@FreeBSD.org>2006-10-05 10:32:22 +0800
commit16801521adcda27ff6070148e1b365277543212a (patch)
treef1343176c550b780d48d9b48a4d2e0beb16e447f /devel/duplo
parent334ff16bcb583f3f7ad18c65ca1f53763b9f346e (diff)
downloadfreebsd-ports-gnome-16801521adcda27ff6070148e1b365277543212a.tar.gz
freebsd-ports-gnome-16801521adcda27ff6070148e1b365277543212a.tar.zst
freebsd-ports-gnome-16801521adcda27ff6070148e1b365277543212a.zip
add duplo 0.2.0
Find duplicated code blocks in large C/C++/Java/C#/VB.Net systems
Diffstat (limited to 'devel/duplo')
-rw-r--r--devel/duplo/Makefile34
-rw-r--r--devel/duplo/distinfo3
-rw-r--r--devel/duplo/pkg-descr4
3 files changed, 41 insertions, 0 deletions
diff --git a/devel/duplo/Makefile b/devel/duplo/Makefile
new file mode 100644
index 000000000000..c0864703a81d
--- /dev/null
+++ b/devel/duplo/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: duplo
+# Date created: Oct 5, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= duplo
+PORTVERSION= 0.2.0
+CATEGORIES= devel
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Find duplicated code blocks in large C/C++/Java/C#/VB.Net systems
+
+USE_GMAKE= yes
+
+PLIST_FILES= bin/duplo %%DATADIR%%/duplo.xsl
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,^CC,#CC," \
+ -e "s,^CXXFLAGS,#CXXFLAGS," \
+ -e "s,[$$]{CC},$$\{CXX\}," \
+ ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/duplo ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/duplo.xsl ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/devel/duplo/distinfo b/devel/duplo/distinfo
new file mode 100644
index 000000000000..f15f45c9f176
--- /dev/null
+++ b/devel/duplo/distinfo
@@ -0,0 +1,3 @@
+MD5 (duplo_0.2.0_src.tar.gz) = 1eea4c2b761ee7feab501148cc850392
+SHA256 (duplo_0.2.0_src.tar.gz) = 8862437ee6e46b793bd43f13727024732f719823a74559d97097845948825bd9
+SIZE (duplo_0.2.0_src.tar.gz) = 22246
diff --git a/devel/duplo/pkg-descr b/devel/duplo/pkg-descr
new file mode 100644
index 000000000000..f31720fed8dd
--- /dev/null
+++ b/devel/duplo/pkg-descr
@@ -0,0 +1,4 @@
+Duplicated source code blocks can harm maintainability of software systems.
+Duplo is a tool to find duplicated code blocks in large C/C++/Java systems.
+
+WWW: http://duplo.giants.ch/