aboutsummaryrefslogtreecommitdiffstats
path: root/devel/eblob
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2014-08-17 02:39:56 +0800
committermva <mva@FreeBSD.org>2014-08-17 02:39:56 +0800
commit5ed39e0e547f838846dd97ecf99f46e03c4beb80 (patch)
tree5a5fb4927885a7c34367faeeee2971aef924368c /devel/eblob
parentad667cbd39bf9d282052c5ad73cdd6dc5bd538d4 (diff)
downloadfreebsd-ports-gnome-5ed39e0e547f838846dd97ecf99f46e03c4beb80.tar.gz
freebsd-ports-gnome-5ed39e0e547f838846dd97ecf99f46e03c4beb80.tar.zst
freebsd-ports-gnome-5ed39e0e547f838846dd97ecf99f46e03c4beb80.zip
- Enable stagedir support
- Convert USE_PYTHON -> USES=python
Diffstat (limited to 'devel/eblob')
-rw-r--r--devel/eblob/Makefile12
-rw-r--r--devel/eblob/pkg-plist1
2 files changed, 7 insertions, 6 deletions
diff --git a/devel/eblob/Makefile b/devel/eblob/Makefile
index d8b15de69d85..b83210a56a66 100644
--- a/devel/eblob/Makefile
+++ b/devel/eblob/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 0.18.2
PORTREVISION= 3
CATEGORIES= devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Append-only low-level I/O library
LICENSE= GPLv2
@@ -25,7 +25,6 @@ OPTIONS_DEFINE= ASSERT PYTHON SNAPPY EXAMPLES TESTS
OPTIONS_DEFAULT=PYTHON SNAPPY EXAMPLES TESTS
TESTS_DESC= Build tests
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MASSERT}
@@ -36,11 +35,9 @@ CMAKE_ARGS+= -DWITH_ASSERTS=OFF
.if ${PORT_OPTIONS:MPYTHON}
LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
-USE_PYTHON= yes
+USES+= python
CMAKE_ARGS+= -DWITH_PYTHON=ON
-INSTALLS_EGGINFO= yes
-PYDISTUTILS_PKGVERSION= 0.0.1
-PLIST_SUB+= PYTHON=""
+PLIST_SUB+= PYTHON="" PYTHON_VER=${PYTHON_VER}
.else
CMAKE_ARGS+= -DWITH_PYTHON=OFF
PLIST_SUB+= PYTHON="@comment "
@@ -70,6 +67,9 @@ CMAKE_ARGS+= -DWITH_TESTS=OFF
post-patch:
.if ! ${PORT_OPTIONS:MPYTHON}
@${REINPLACE_CMD} -e 's, python),),' ${WRKSRC}/CMakeLists.txt
+.else
+ @${REINPLACE_CMD} -e 's,$$ENV{DESTDIR},${STAGEDIR},' \
+ ${WRKSRC}/bindings/python/python/CMakeLists.txt
.endif
@${REINPLACE_CMD} -e 's, -fstack-protector-all,,' \
${WRKSRC}/CMakeLists.txt
diff --git a/devel/eblob/pkg-plist b/devel/eblob/pkg-plist
index 9c73015d3684..d03f88527467 100644
--- a/devel/eblob/pkg-plist
+++ b/devel/eblob/pkg-plist
@@ -15,4 +15,5 @@ lib/libeblob_cpp.so.0.17.5
%%PYTHON%%lib/libeblob_python.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/eblob.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/eblob.pyc
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/eblob-0.0.1-py%%PYTHON_VER%%.egg-info
@dirrm include/eblob