aboutsummaryrefslogtreecommitdiffstats
path: root/devel/eblob
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 18:53:38 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 18:53:38 +0800
commitafa514e55d965168153a8b1b6e4843fb8bf7785a (patch)
tree6cb6f0da787d4b67708abc802fa739d71222bbdc /devel/eblob
parentc8a4e806481ba453004f7526561a209d7f21e6aa (diff)
downloadfreebsd-ports-gnome-afa514e55d965168153a8b1b6e4843fb8bf7785a.tar.gz
freebsd-ports-gnome-afa514e55d965168153a8b1b6e4843fb8bf7785a.tar.zst
freebsd-ports-gnome-afa514e55d965168153a8b1b6e4843fb8bf7785a.zip
Convert LIB_DEPENDS for ports depending on boost
Diffstat (limited to 'devel/eblob')
-rw-r--r--devel/eblob/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/eblob/Makefile b/devel/eblob/Makefile
index a5a43e43e053..0bf736b0c583 100644
--- a/devel/eblob/Makefile
+++ b/devel/eblob/Makefile
@@ -10,7 +10,7 @@ COMMENT= Append-only low-level I/O library
LICENSE= GPLv2
-LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
@@ -34,7 +34,7 @@ CMAKE_ARGS+= -DWITH_ASSERTS=OFF
.endif
.if ${PORT_OPTIONS:MPYTHON}
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
USE_PYTHON= yes
CMAKE_ARGS+= -DWITH_PYTHON=ON
INSTALLS_EGGINFO= yes
@@ -46,7 +46,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MSNAPPY}
-LIB_DEPENDS+= snappy:${PORTSDIR}/archivers/snappy
+LIB_DEPENDS+= libsnappy.so:${PORTSDIR}/archivers/snappy
CMAKE_ARGS+= -DWITH_SNAPPY=ON
.else
CMAKE_ARGS+= -DWITH_SNAPPY=OFF