aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ecgi/files
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-13 06:08:31 +0800
committerwill <will@FreeBSD.org>2001-03-13 06:08:31 +0800
commit9c676e15d91e05fe78472fb0b1d14cf5cfb48eaf (patch)
tree24c3acc7d7e6e3adfe2b3ab06ef46864d6a218f4 /devel/ecgi/files
parent3a8a6d7d5badedc884c63a6b8c6de7daea73dae2 (diff)
downloadfreebsd-ports-gnome-9c676e15d91e05fe78472fb0b1d14cf5cfb48eaf.tar.gz
freebsd-ports-gnome-9c676e15d91e05fe78472fb0b1d14cf5cfb48eaf.tar.zst
freebsd-ports-gnome-9c676e15d91e05fe78472fb0b1d14cf5cfb48eaf.zip
Add ecgi 0.6.2, a library for the creation of CGI-based Web
applications. PR: 25080 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
Diffstat (limited to 'devel/ecgi/files')
-rw-r--r--devel/ecgi/files/patch-Makefile56
-rw-r--r--devel/ecgi/files/patch-html2h::Makefile21
2 files changed, 77 insertions, 0 deletions
diff --git a/devel/ecgi/files/patch-Makefile b/devel/ecgi/files/patch-Makefile
new file mode 100644
index 000000000000..19a535ac36de
--- /dev/null
+++ b/devel/ecgi/files/patch-Makefile
@@ -0,0 +1,56 @@
+--- Makefile.orig Tue Feb 13 23:46:51 2001
++++ Makefile Tue Feb 13 23:47:50 2001
+@@ -1,14 +1,14 @@
+ SHAREDOPT = -shared
+-LIBDIR = /usr/lib
+-INCDIR = /usr/include
++LIBDIR = $(PREFIX)/usr/lib
++INCDIR = $(PREFIX)/include
+ AR = ar
+-CC = gcc
++CC?= gcc
+ INCS = -Iinclude/ -I.
+-FLAGS = -Wall
++CFLAGS += -Wall
+
+ all: obj/ecgi.o obj/ecgitk.o libecgi.a
+- make -C html2h/
+- make libecgi.so
++ $(MAKE) -C html2h/
++ $(MAKE) libecgi.so
+
+ shared: libecgi.so
+ cp libecgi.so /usr/lib
+@@ -26,25 +26,25 @@
+ cp ecgi.h $(INCDIR)
+ cp include/memfile.h $(INCDIR)
+ cp ecgitk.h $(INCDIR)
+- make -C html2h/ install
++ $(MAKE) -C html2h/ install
+ cp libecgi.so $(LIBDIR)
+
+ tests: all
+- $(CC) tests/test.c -o tests/test.cgi $(INCS) $(FLAGS) libecgi.a
+- $(CC) tests/testload.c -o tests/testload libecgi.a $(INCS) $(FLAGS)
++ $(CC) tests/test.c -o tests/test.cgi $(INCS) $(CFLAGS) libecgi.a
++ $(CC) tests/testload.c -o tests/testload libecgi.a $(INCS) $(CFLAGS)
+
+ obj/ecgi.o: src/ecgi.c ecgi.h obj/memfile.o
+- $(CC) -c src/ecgi.c $(INCS) $(FLAGS) -o obj/ecgi.o
++ $(CC) -c src/ecgi.c $(INCS) $(CFLAGS) -o obj/ecgi.o
+
+ obj/memfile.o: src/memfile.c include/memfile.h
+- $(CC) -o obj/memfile.o -c src/memfile.c $(INCS) $(FLAGS)
++ $(CC) -o obj/memfile.o -c src/memfile.c $(INCS) $(CFLAGS)
+
+ obj/ecgitk.o: src/ecgitk.c ecgitk.h
+- $(CC) -c src/ecgitk.c $(INCS) $(FLAGS) -o obj/ecgitk.o
++ $(CC) -c src/ecgitk.c $(INCS) $(CFLAGS) -o obj/ecgitk.o
+
+ clean:
+ rm -f obj/* *.a *.so -f tests/test.cgi tests/testload
+- make -C html2h/ clean
++ $(MAKE) -C html2h/ clean
+
+ zip: clean
+ rm -f ../ecgi-0.6.2.zip
diff --git a/devel/ecgi/files/patch-html2h::Makefile b/devel/ecgi/files/patch-html2h::Makefile
new file mode 100644
index 000000000000..7ec659184ed7
--- /dev/null
+++ b/devel/ecgi/files/patch-html2h::Makefile
@@ -0,0 +1,21 @@
+--- html2h/Makefile Tue Feb 13 23:46:49 2001
++++ html2h/Makefile Tue Feb 13 23:49:09 2001
+@@ -1,14 +1,14 @@
+-CC = gcc
++CC?= gcc
+ INCS = -I../include/ -I.
+-FLAGS = -Wall
++CFLAGS += -Wall
+
+ all: html2h
+
+ html2h: html2h.c html2h.h
+- $(CC) html2h.c -o html2h $(INCS) $(FLAGS) ../obj/memfile.o
++ $(CC) html2h.c -o html2h $(INCS) $(CFLAGS) ../obj/memfile.o
+
+ install: all
+ cp html2h /usr/bin
+
+ clean:
+- rm -f html2h
++ rm -f html2h