aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fb-adb
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /devel/fb-adb
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'devel/fb-adb')
-rw-r--r--devel/fb-adb/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index 5d438d2da2f6..a61eeb27b586 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -54,15 +54,14 @@ NDK_MASTER_SITES= https://dl.google.com/android/ndk/:ndk,p7zip
# Prefer NDK from environment
WRKSRC_ndk= ${ANDROID_NDK}
.else
-NDK_DISTFILES= ${NDK_DISTFILES_${LINUX_RPM_ARCH}}
-NDK_DISTFILES_i686= android-ndk-r10e-linux-x86.bin:ndk,p7zip
+NDK_DISTFILES= ${NDK_DISTFILES_${LINUX_ARCH}}
+NDK_DISTFILES_i386= android-ndk-r10e-linux-x86.bin:ndk,p7zip
NDK_DISTFILES_x86_64= android-ndk-r11c-linux-x86_64.zip:ndk
WRKSRC_ndk= ${WRKDIR}/${NDK_DISTFILES:R:C/(-[^-]+){2}$//}
.endif
-NDK_BUILD_DEPENDS= ${LINUX_BASE_PORT}
-NDK_USES= 7z:partial
-NDK_USE= LINUX=yes # build
-NDK_SHELL= ${SETENV} UNAME_s=Linux UNAME_m=${LINUX_RPM_ARCH} ${SH}
+NDK_USES= 7z:partial linux
+NDK_USE= LINUX=base:build
+NDK_SHELL= ${LINUXBASE}/bin/sh
NDK_CONFIGURE_ENV= ANDROID_NDK="${WRKSRC_ndk}" \
ANDROID_NDK_SHELL="${NDK_SHELL}" \
NDK_TMPDIR="${WRKDIR}"
@@ -85,15 +84,13 @@ post-patch:
# XXX Decouple -Werror from --enable-checking (ASSERT=on)
@${REINPLACE_CMD} -e '/CPPFLAGS.*-Werror/d' ${WRKSRC}/configure.ac
+post-patch-NDK-on:
+ @${REINPLACE_CMD} 's,mkdir,/compat/linux/../../bin/mkdir,' \
+ ${WRKSRC_ndk}/build/tools/make-standalone-toolchain.sh \
+ ${WRKSRC_ndk}/build/tools/ndk-common.sh
+
post-patch-NDK-off:
@${REINPLACE_CMD} -i '.aux.bak' -e 's/linux-android/aux-&/' \
${WRKSRC}/stub-*/configure
.include <bsd.port.mk>
-
-# XXX Bug 204615: Teach USE_LINUX about build-only deps
-.if defined(.PARSEDIR)
-RUN_DEPENDS:= ${RUN_DEPENDS:N${LINUX_BASE_PORT}}
-.else
-RUN_DEPENDS:= ${RUN_DEPENDS:N*linux_base*}
-.endif