aboutsummaryrefslogtreecommitdiffstats
path: root/devel/flux
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-07 13:17:18 +0800
committerwill <will@FreeBSD.org>2002-01-07 13:17:18 +0800
commit4c9bc4cf4fc464a94f7486903c6ef07a09432007 (patch)
treef88ab04c6fd0f648d1059ae32b271d5fcf54eec2 /devel/flux
parent455a45f034ab9cd05eb1f4a05fa2565cacd3f300 (diff)
downloadfreebsd-ports-gnome-4c9bc4cf4fc464a94f7486903c6ef07a09432007.tar.gz
freebsd-ports-gnome-4c9bc4cf4fc464a94f7486903c6ef07a09432007.tar.zst
freebsd-ports-gnome-4c9bc4cf4fc464a94f7486903c6ef07a09432007.zip
Additional regexes to tweak the behavior of this port. It will now work
correctly even in the presence of newer auto*.
Diffstat (limited to 'devel/flux')
-rw-r--r--devel/flux/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/devel/flux/Makefile b/devel/flux/Makefile
index b09bfb87e758..c727e756f957 100644
--- a/devel/flux/Makefile
+++ b/devel/flux/Makefile
@@ -17,6 +17,23 @@ USE_GMAKE= yes
USE_AUTOMAKE_VER=14
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+REGEX= "s@EXTRA_DIST \+@EXTRA_DIST @g"
+
+pre-configure:
+.for M in examples include src util
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/${M}/Makefile.am
+.endfor
+.for M in build cgi cipher comm fifobuf fstring log mem misc mt nvtp ph proc \
+ random smtp sock tn url xml
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/src/${M}/Makefile.am
+.endfor
+.for M in framework/application framework/application/src test
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/util/${M}/Makefile.am
+.endfor
+.for M in smtp
+ @${PERL} -pi -e ${REGEX} ${WRKSRC}/examples/${M}/Makefile.am
+.endfor
+ ${PERL} -pi -e "s@autoheader,@${AUTOHEADER},@g" ${WRKSRC}/aclocal.m4
post-install:
.if !defined(NOPORTDOCS)