aboutsummaryrefslogtreecommitdiffstats
path: root/devel/frama-c
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-03 21:37:05 +0800
committermarino <marino@FreeBSD.org>2014-06-03 21:37:05 +0800
commit0a7aab4ddd6c4a00aee62a21ce41d3f045c96b43 (patch)
tree558d5314f448895669a467665dd9bb9d671b7055 /devel/frama-c
parentda761378703a7330d2b44ab0d02668ec5eedbc96 (diff)
downloadfreebsd-ports-gnome-0a7aab4ddd6c4a00aee62a21ce41d3f045c96b43.tar.gz
freebsd-ports-gnome-0a7aab4ddd6c4a00aee62a21ce41d3f045c96b43.tar.zst
freebsd-ports-gnome-0a7aab4ddd6c4a00aee62a21ce41d3f045c96b43.zip
devel/frama-c: Re-stage to correct -print-libpath
The approach to staging had a bug. frama-c -print-libpath returned a path to /wrkdirs (the standard work directory in poudriere). Improve staging so frama-c knows where its installed.
Diffstat (limited to 'devel/frama-c')
-rw-r--r--devel/frama-c/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/frama-c/Makefile b/devel/frama-c/Makefile
index bfd6caa3a754..54cea4b17942 100644
--- a/devel/frama-c/Makefile
+++ b/devel/frama-c/Makefile
@@ -4,6 +4,7 @@
PORTNAME= frama-c
DISTVERSIONPREFIX= Neon-
DISTVERSION= 20140301
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://frama-c.com/download/ LOCAL/bf
@@ -18,8 +19,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/ocaml/ocamlgraph/graph.a:${PORTSDIR}/math/ocaml-oc
USES= gmake
USE_OCAML= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-cpp="${FRAMAC_DEFAULT_CPP}"
-MAKE_ENV+= FRAMAC_LIBDIR="${STAGEDIR}${PREFIX}/lib/frama-c"
+CONFIGURE_ARGS+=--with-cpp="${FRAMAC_DEFAULT_CPP}"
+MAKE_ENV+= FRAMAC_LIBDIR="${PREFIX}/lib/frama-c"
OPTIONS_DEFINE= ALTERGO COQ GUI PLUGINS
OPTIONS_DEFAULT=ALTERGO GUI PLUGINS
@@ -86,6 +87,8 @@ post-patch:
-e '\|$$(CP) frama-c|s|$$(CP)|${INSTALL_SCRIPT}|' \
${WRKSRC}/share/Makefile.dynamic
@${REINPLACE_CMD} -e '\|^# Installation|,\|^# File headers|{ \
+ \|_LIBDIR|s|(FRAMAC_LIBDIR)|(DESTDIR)$$(FRAMAC_LIBDIR)|; \
+ \|_PLUGINDIR|s|(FRAMAC_PLUGINDIR)|(DESTDIR)$$(FRAMAC_PLUGINDIR)|; \
\|$$(CP).*bin|s|$$(CP)|${INSTALL_SCRIPT}|; \
\|$$(CP).*man/|s|$$(CP)|${INSTALL_MAN}|; \
s|$$(CP)|${INSTALL_DATA}|; }' \