aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fuel
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-26 02:01:01 +0800
committermakc <makc@FreeBSD.org>2013-11-26 02:01:01 +0800
commite5d433bbd915367a15941a73c3079f8ad7a1b51f (patch)
tree695f8d271052730dc7b604a2d300deea8fe2d6b6 /devel/fuel
parent280eb430d1143c038a9e70f5b6fb66ce38ccfaf2 (diff)
downloadfreebsd-ports-gnome-e5d433bbd915367a15941a73c3079f8ad7a1b51f.tar.gz
freebsd-ports-gnome-e5d433bbd915367a15941a73c3079f8ad7a1b51f.tar.zst
freebsd-ports-gnome-e5d433bbd915367a15941a73c3079f8ad7a1b51f.zip
- Convert to USES=qmake
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Diffstat (limited to 'devel/fuel')
-rw-r--r--devel/fuel/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/devel/fuel/Makefile b/devel/fuel/Makefile
index 70bd5476b3b2..f7adbafb2223 100644
--- a/devel/fuel/Makefile
+++ b/devel/fuel/Makefile
@@ -13,18 +13,13 @@ LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/fossil:${PORTSDIR}/devel/fossil
+USES= qmake
USE_QT4= corelib gui \
- qmake_build moc_build rcc_build uic_build
+ moc_build rcc_build uic_build
-HAS_CONFIGURE= yes
-
-PLIST_FILES+= bin/Fuel
-
-NO_STAGE= yes
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS}
+PLIST_FILES= bin/Fuel
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/Fuel ${PREFIX}/bin/Fuel
+ ${INSTALL_PROGRAM} ${WRKSRC}/Fuel ${STAGEDIR}${PREFIX}/bin/Fuel
.include <bsd.port.mk>