aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gamin
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-07-14 00:13:00 +0800
committerjylefort <jylefort@FreeBSD.org>2005-07-14 00:13:00 +0800
commit638ecb1b6dfadfed1d756204f06af5e05d9a28a0 (patch)
treecabba714134cad13c0332a7881a746f610d14811 /devel/gamin
parentdefcee062f5f24d3801e2a42ceb6fb7d3e562ce4 (diff)
downloadfreebsd-ports-gnome-638ecb1b6dfadfed1d756204f06af5e05d9a28a0.tar.gz
freebsd-ports-gnome-638ecb1b6dfadfed1d756204f06af5e05d9a28a0.tar.zst
freebsd-ports-gnome-638ecb1b6dfadfed1d756204f06af5e05d9a28a0.zip
Update to 0.1.2
Diffstat (limited to 'devel/gamin')
-rw-r--r--devel/gamin/Makefile2
-rw-r--r--devel/gamin/distinfo4
-rw-r--r--devel/gamin/files/patch-server_gam_connection.c23
3 files changed, 26 insertions, 3 deletions
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index 275908cf7054..497c1151bfb5 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gamin
-PORTVERSION= 0.1.1
+PORTVERSION= 0.1.2
CATEGORIES?= devel
MASTER_SITES= http://www.gnome.org/~veillard/gamin/sources/
diff --git a/devel/gamin/distinfo b/devel/gamin/distinfo
index 33c432b80685..6e9b51839d78 100644
--- a/devel/gamin/distinfo
+++ b/devel/gamin/distinfo
@@ -1,2 +1,2 @@
-MD5 (gamin-0.1.1.tar.gz) = 5c5330c3df26ece7d71b69a0b8f4a126
-SIZE (gamin-0.1.1.tar.gz) = 512316
+MD5 (gamin-0.1.2.tar.gz) = cb43e73d43e2c5d428229dea0288d66d
+SIZE (gamin-0.1.2.tar.gz) = 513784
diff --git a/devel/gamin/files/patch-server_gam_connection.c b/devel/gamin/files/patch-server_gam_connection.c
new file mode 100644
index 000000000000..6b49538ee871
--- /dev/null
+++ b/devel/gamin/files/patch-server_gam_connection.c
@@ -0,0 +1,23 @@
+--- server/gam_connection.c.orig Wed Jul 13 17:54:01 2005
++++ server/gam_connection.c Wed Jul 13 17:54:54 2005
+@@ -30,10 +30,7 @@
+ GMainLoop *loop; /* the Glib loop used */
+ GIOChannel *source; /* the Glib I/O Channel used */
+ int request_len; /* how many bytes of request are valid */
+- union {
+- GAMPacket request; /* the next request being read */
+- void *request_data; /* the next request as a char * */
+- };
++ GAMPacket request; /* the next request being read */
+ GamListener *listener; /* the listener associated with the connection */
+ };
+
+@@ -245,7 +242,7 @@
+ g_assert(data);
+ g_assert(size);
+
+- *data = (char *) &conn->request_data + conn->request_len;
++ *data = (char *) &conn->request + conn->request_len;
+ *size = sizeof(GAMPacket) - conn->request_len;
+
+ return (0);