aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gauche-sdl
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-07-08 15:49:00 +0800
committermiwi <miwi@FreeBSD.org>2006-07-08 15:49:00 +0800
commitc531311ee01c720178a447f51eba6e1b8f9cfae8 (patch)
tree22d81fb8ae72cebc24e812f460c56bd6106f2e24 /devel/gauche-sdl
parent0c6680b7d4b37047deae71c7471c2fe4ea6dea1c (diff)
downloadfreebsd-ports-gnome-c531311ee01c720178a447f51eba6e1b8f9cfae8.tar.gz
freebsd-ports-gnome-c531311ee01c720178a447f51eba6e1b8f9cfae8.tar.zst
freebsd-ports-gnome-c531311ee01c720178a447f51eba6e1b8f9cfae8.zip
- Update MASTER_SITES (Author rerolled the tarball)
PR: ports/97622 Submitted by: miwi Approved by: krion (mentor), maintainer
Diffstat (limited to 'devel/gauche-sdl')
-rw-r--r--devel/gauche-sdl/Makefile14
-rw-r--r--devel/gauche-sdl/distinfo6
-rw-r--r--devel/gauche-sdl/files/patch-configure68
-rw-r--r--devel/gauche-sdl/files/patch-src::gauche-sdl.h11
-rw-r--r--devel/gauche-sdl/files/patch-src::image::gauche-sdl-image.h10
-rw-r--r--devel/gauche-sdl/files/patch-src::image::sdl-image-lib.stub20
-rw-r--r--devel/gauche-sdl/files/patch-src::mixer::gauche-sdl-mixer.h11
-rw-r--r--devel/gauche-sdl/files/patch-src::sdl-lib.stub60
-rw-r--r--devel/gauche-sdl/files/patch-src::ttf::gauche-sdl-ttf.h11
-rw-r--r--devel/gauche-sdl/pkg-plist3
10 files changed, 13 insertions, 201 deletions
diff --git a/devel/gauche-sdl/Makefile b/devel/gauche-sdl/Makefile
index b633a8504ea3..525b0a340ed2 100644
--- a/devel/gauche-sdl/Makefile
+++ b/devel/gauche-sdl/Makefile
@@ -8,8 +8,9 @@
PORTNAME= gauche-sdl
PORTVERSION= 0.5.1
CATEGORIES= devel scheme
-MASTER_SITES= http://www.michaelvess.com/code/
-DISTNAME= ${PORTFAKENAME}-${PORTVERSION}
+MASTER_SITES= http://michaelvess.com/files/
+DISTNAME= ${PORTFAKENAME}
+EXTRACT_SUFX= .tgz
MAINTAINER= erik@smluc.org
COMMENT= Scheme script interpreter with multibyte character handling
@@ -21,10 +22,10 @@ RUN_DEPENDS= gosh:${PORTSDIR}/lang/gauche \
PLIST_SUB= GAUCHE_VERSION="`gauche-config -V`"\
TARGET="${CONFIGURE_TARGET}"
-WRKSRC= ${WRKDIR}/${PORTFAKENAME}
-PORTFAKENAME= Gauche-sdl
+PORTFAKENAME= Gauche-sdl-${PORTVERSION}
USE_SDL= image mixer sdl ttf
GNU_CONFIGURE= yes
+CFLAGS+= -fPIC
pre-configure:
.for DIR in . image mixer ttf
@@ -33,9 +34,14 @@ pre-configure:
-e "s|-lSDL|`${SDL_CONFIG} --libs`|"\
${WRKSRC}/src/${DIR}/Makefile.in
.endfor
+.for FILE in gfx/gauche-sdl-gfx.h image/gauche-sdl-image.h \
+ mixer/gauche-sdl-mixer.h ttf/gauche-sdl-ttf.h gauche-sdl.h
+ ${REINPLACE_CMD} -e "s|SDL/SDL|SDL|g" ${WRKSRC}/src/${FILE}
+.endfor
${REINPLACE_CMD} \
-e "s|SDL/SDL|SDL|g"\
-e "s|%%SDL_CFLAGS%%|`${SDL_CONFIG} --cflags`|"\
+ -e "s|\"-lSDL\"|\"`${SDL_CONFIG} --libs`\"|" \
${WRKSRC}/configure
${REINPLACE_CMD} -e "s|^CFLAGS.*|& `${SDL_CONFIG} --cflags`|" \
${WRKSRC}/src/gfx/Makefile.in
diff --git a/devel/gauche-sdl/distinfo b/devel/gauche-sdl/distinfo
index 8e9acb72f1e9..16781c052614 100644
--- a/devel/gauche-sdl/distinfo
+++ b/devel/gauche-sdl/distinfo
@@ -1,3 +1,3 @@
-MD5 (Gauche-sdl-0.5.1.tar.gz) = 402998451db9d6fb98b0814439393fa5
-SHA256 (Gauche-sdl-0.5.1.tar.gz) = 7363ca581a3acd020e19bfd33212390253929907c2590c1899a14ddfdb31a7ee
-SIZE (Gauche-sdl-0.5.1.tar.gz) = 121766
+MD5 (Gauche-sdl-0.5.1.tgz) = faeb4511c3533dadae08ed0bef5987b2
+SHA256 (Gauche-sdl-0.5.1.tgz) = 14f724556768c6c839ec55c2e3546336f287e680c7531f2897938b97e433a4dc
+SIZE (Gauche-sdl-0.5.1.tgz) = 141359
diff --git a/devel/gauche-sdl/files/patch-configure b/devel/gauche-sdl/files/patch-configure
deleted file mode 100644
index 283fe0a9a6a2..000000000000
--- a/devel/gauche-sdl/files/patch-configure
+++ /dev/null
@@ -1,68 +0,0 @@
---- configure.orig Tue Jan 21 23:22:40 2003
-+++ configure Mon Jan 2 04:06:03 2006
-@@ -737,7 +737,7 @@
- fi
- echo "$ac_t""$CPP" 1>&6
-
--for ac_hdr in SDL/SDL.h
-+for ac_hdr in SDL.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -777,8 +777,10 @@
- fi
- done
-
-+MYLAMEOLDCPPFLAGS="${CPPFLAGS}"
-+CPPFLAGS="${CPPFLAGS} -I/usr/local/include/SDL11 -I/usr/local/include -D_REENTRANT"
-
--for ac_hdr in SDL/SDL_framerate.h
-+for ac_hdr in SDL_framerate.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -812,7 +814,7 @@
- cat >> confdefs.h <<EOF
- #define $ac_tr_hdr 1
- EOF
-- HAVE_SDL_GFX=1
-+# HAVE_SDL_GFX=1
- else
- echo "$ac_t""no" 1>&6
- fi
-@@ -820,7 +822,7 @@
-
-
-
--for ac_hdr in SDL/SDL_image.h
-+for ac_hdr in SDL_image.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -862,7 +864,7 @@
-
-
-
--for ac_hdr in SDL/SDL_mixer.h
-+for ac_hdr in SDL_mixer.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -904,7 +906,7 @@
-
-
-
--for ac_hdr in SDL/SDL_ttf.h
-+for ac_hdr in SDL_ttf.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -944,7 +946,7 @@
- fi
- done
-
--
-+CPPFLAGS="${MYLAMEOLDCPPFLAGS}"
-
- # Sets the default value of INSTALL_TYPE macro.
-
diff --git a/devel/gauche-sdl/files/patch-src::gauche-sdl.h b/devel/gauche-sdl/files/patch-src::gauche-sdl.h
deleted file mode 100644
index 48f8c5d2fdc2..000000000000
--- a/devel/gauche-sdl/files/patch-src::gauche-sdl.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gauche-sdl.h.orig Mon Feb 24 21:20:18 2003
-+++ src/gauche-sdl.h Sun Feb 15 18:27:17 2004
-@@ -20,7 +20,7 @@
-
- #include <gauche/uvector.h>
-
--#include <SDL/SDL.h>
-+#include <SDL.h>
-
- /*****************************************************************************
- * Miscellaneous
diff --git a/devel/gauche-sdl/files/patch-src::image::gauche-sdl-image.h b/devel/gauche-sdl/files/patch-src::image::gauche-sdl-image.h
deleted file mode 100644
index 33cae8af6e16..000000000000
--- a/devel/gauche-sdl/files/patch-src::image::gauche-sdl-image.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/image/gauche-sdl-image.h.orig Sun Feb 15 18:29:18 2004
-+++ src/image/gauche-sdl-image.h Sun Feb 15 18:29:37 2004
-@@ -20,6 +20,6 @@
-
- #include "../gauche-sdl.h"
-
--#include <SDL/SDL_image.h>
-+#include <SDL_image.h>
-
- #endif /* GAUCHE_SDL_IMAGE_H */
diff --git a/devel/gauche-sdl/files/patch-src::image::sdl-image-lib.stub b/devel/gauche-sdl/files/patch-src::image::sdl-image-lib.stub
deleted file mode 100644
index b1b64ae05cef..000000000000
--- a/devel/gauche-sdl/files/patch-src::image::sdl-image-lib.stub
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/image/sdl-image-lib.stub.orig Mon Jan 2 04:11:06 2006
-+++ src/image/sdl-image-lib.stub Mon Jan 2 04:11:38 2006
-@@ -61,7 +61,7 @@
- (define-cproc img-load (file::<string>)
- "ScmSdlSurface *s = SCM_NEW(ScmSdlSurface);
- SCM_SET_CLASS(s, SCM_CLASS_SDL_SURFACE);
-- s->surface = IMG_Load((const char *)(SCM_STRING(file)->start));
-+ s->surface = IMG_Load((const char *)(SCM_STRING_START(file)));
-
- if (s->surface == NULL) SCM_RETURN(SCM_UNDEFINED);
-
-@@ -82,7 +82,7 @@
- "ScmSdlSurface *s = SCM_NEW(ScmSdlSurface);
- SCM_SET_CLASS(s, SCM_CLASS_SDL_SURFACE);
- s->surface = IMG_LoadTyped_RW(src, 0,
-- (char *)(SCM_STRING(type)->start));
-+ (char *)(SCM_STRING_START(type)));
-
- if (s->surface == NULL) SCM_RETURN(SCM_UNDEFINED);
-
diff --git a/devel/gauche-sdl/files/patch-src::mixer::gauche-sdl-mixer.h b/devel/gauche-sdl/files/patch-src::mixer::gauche-sdl-mixer.h
deleted file mode 100644
index a4f27f143371..000000000000
--- a/devel/gauche-sdl/files/patch-src::mixer::gauche-sdl-mixer.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mixer/gauche-sdl-mixer.h.orig Sun Feb 15 18:31:18 2004
-+++ src/mixer/gauche-sdl-mixer.h Sun Feb 15 18:31:38 2004
-@@ -20,7 +20,7 @@
-
- #include "../gauche-sdl.h"
-
--#include <SDL/SDL_mixer.h>
-+#include <SDL_mixer.h>
-
- /*****************************************************************************
- * Mixer
diff --git a/devel/gauche-sdl/files/patch-src::sdl-lib.stub b/devel/gauche-sdl/files/patch-src::sdl-lib.stub
deleted file mode 100644
index 82948e84575b..000000000000
--- a/devel/gauche-sdl/files/patch-src::sdl-lib.stub
+++ /dev/null
@@ -1,60 +0,0 @@
---- src/sdl-lib.stub.orig Mon Feb 24 21:20:18 2003
-+++ src/sdl-lib.stub Sat Dec 31 13:22:35 2005
-@@ -868,7 +868,7 @@
- (define-cproc sdl-load-bmp (file::<string>)
- "ScmSdlSurface *s = SCM_NEW(ScmSdlSurface);
- SCM_SET_CLASS(s, SCM_CLASS_SDL_SURFACE);
-- s->surface = SDL_LoadBMP((const char *)(SCM_STRING(file)->start));
-+ s->surface = SDL_LoadBMP((const char *)(SCM_STRING_START(file)));
-
- if (s->surface == NULL) SCM_RETURN(SCM_UNDEFINED);
-
-@@ -876,7 +876,7 @@
- SCM_RETURN(SCM_OBJ(s));")
-
- (define-cproc sdl-save-bmp (surface::<sdl-surface> file::<string>)
-- "int result = SDL_SaveBMP(surface, (const char *)(SCM_STRING(file)->start));
-+ "int result = SDL_SaveBMP(surface, (const char *)(SCM_STRING_START(file)));
- SCM_RETURN(SCM_MAKE_INT(result));")
-
- (define-cproc sdl-set-color-key (surface::<sdl-surface> flag::<uint> key::<uint>)
-@@ -950,7 +950,7 @@
- (return <int> "SDL_ShowCursor"))
-
- (define-cproc sdl-gl-load-library (path::<string>)
-- "int result = SDL_GL_LoadLibrary((const char *)(SCM_STRING(path)->start));
-+ "int result = SDL_GL_LoadLibrary((const char *)(SCM_STRING_START(path)));
- SCM_RETURN(SCM_MAKE_INT(result));")
-
- ;; MISSING:
-@@ -1055,8 +1055,8 @@
- ;;
-
- (define-cproc sdl-wm-set-caption (title::<string> icon::<string>)
-- "SDL_WM_SetCaption((const char *)(SCM_STRING(title)->start),
-- (const char *)(SCM_STRING(icon)->start));
-+ "SDL_WM_SetCaption((const char *)(SCM_STRING_START(title)),
-+ (const char *)(SCM_STRING_START(icon)));
- SCM_RETURN(SCM_UNDEFINED);")
-
- (define-cproc sdl-wm-get-caption ()
-@@ -1269,7 +1269,7 @@
- SCM_SET_CLASS(w, SCM_CLASS_SDL_WAV);
- spec = &(SCM_SDL_WAV_SPEC(w));
-
-- spec = SDL_LoadWAV((const char *)(SCM_STRING(file)->start), spec, &buffer,
-+ spec = SDL_LoadWAV((const char *)(SCM_STRING_START(file)), spec, &buffer,
- &len);
-
- SCM_SDL_WAV_BUFFER(w) = Scm_MakeU8VectorFromArrayShared(len, buffer);
-@@ -1384,8 +1384,8 @@
- (define-cproc sdl-rw-from-file (file::<string> mode::<string>)
- "ScmSdlRWops *rw = SCM_NEW(ScmSdlRWops);
- SCM_SET_CLASS(rw, SCM_CLASS_SDL_RWOPS);
-- rw->rwops = SDL_RWFromFile((const char *)(SCM_STRING(file)->start),
-- (const char *)(SCM_STRING(mode)->start));
-+ rw->rwops = SDL_RWFromFile((const char *)(SCM_STRING_START(file)),
-+ (const char *)(SCM_STRING_START(mode)));
-
- if (rw->rwops == NULL) SCM_RETURN(SCM_UNDEFINED);
-
diff --git a/devel/gauche-sdl/files/patch-src::ttf::gauche-sdl-ttf.h b/devel/gauche-sdl/files/patch-src::ttf::gauche-sdl-ttf.h
deleted file mode 100644
index 9c05dd661537..000000000000
--- a/devel/gauche-sdl/files/patch-src::ttf::gauche-sdl-ttf.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ttf/gauche-sdl-ttf.h.orig Sun Feb 15 18:31:53 2004
-+++ src/ttf/gauche-sdl-ttf.h Sun Feb 15 18:32:10 2004
-@@ -20,7 +20,7 @@
-
- #include "../gauche-sdl.h"
-
--#include <SDL/SDL_ttf.h>
-+#include <SDL_ttf.h>
-
- /*****************************************************************************
- * TTF
diff --git a/devel/gauche-sdl/pkg-plist b/devel/gauche-sdl/pkg-plist
index ee5dc8e50463..8d28ac34f949 100644
--- a/devel/gauche-sdl/pkg-plist
+++ b/devel/gauche-sdl/pkg-plist
@@ -1,6 +1,3 @@
-lib/gauche/%%GAUCHE_VERSION%%/%%TARGET%%/gauche-sdl-image.so
-lib/gauche/%%GAUCHE_VERSION%%/%%TARGET%%/gauche-sdl-mixer.so
-lib/gauche/%%GAUCHE_VERSION%%/%%TARGET%%/gauche-sdl-ttf.so
lib/gauche/%%GAUCHE_VERSION%%/%%TARGET%%/gauche-sdl.so
share/gauche/%%GAUCHE_VERSION%%/lib/sdl.scm
share/gauche/%%GAUCHE_VERSION%%/lib/sdl/color.scm