aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gcc-arm-embedded/Makefile
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-08-09 23:36:27 +0800
committertz <tz@FreeBSD.org>2017-08-09 23:36:27 +0800
commita3537c6381cd0ec5638da6f9fb8744b5ecdc51ef (patch)
treef31a3d2fc3a895f34bf4352290679f4d27ada23e /devel/gcc-arm-embedded/Makefile
parent445b4f5869cd608c9a48e0f1bb13f000101d7c7d (diff)
downloadfreebsd-ports-gnome-a3537c6381cd0ec5638da6f9fb8744b5ecdc51ef.tar.gz
freebsd-ports-gnome-a3537c6381cd0ec5638da6f9fb8744b5ecdc51ef.tar.zst
freebsd-ports-gnome-a3537c6381cd0ec5638da6f9fb8744b5ecdc51ef.zip
devel/gcc-arm-embedded: Remove unnecessary LIB_DEPENDS on libelf
Also: - added missing plist entries - add missing gettext-runtime to USES - corrected minor spelling mistake PR: 220782 Submitted by: Jonathan Chen <jonc@chen.org.nz> Approved by: portmgr (maintainer timeout, 2 weeks) MFH: 2017Q3
Diffstat (limited to 'devel/gcc-arm-embedded/Makefile')
-rw-r--r--devel/gcc-arm-embedded/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/devel/gcc-arm-embedded/Makefile b/devel/gcc-arm-embedded/Makefile
index adcc85026803..2bc415d5fce2 100644
--- a/devel/gcc-arm-embedded/Makefile
+++ b/devel/gcc-arm-embedded/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gcc-arm-embedded
PORTVERSION= 6.3.20170628
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://developer.arm.com/-/media/Files/downloads/gnu-rm/6-2017q2/
DISTNAME= ${ORIGINAL_PACKAGE_NAME}-src
@@ -19,7 +19,7 @@ OPTIONS_DEFINE= PYGDB EXAMPLES HTML PDF DOCS
OPTIONS_DEFAULT=PYGDB
HTML_DESC= Install HTML documentation
PDF_DESC= Install PDF documentation (requires TeX, it is huge)
-PYGDB_DESC= Build and install pyhon-enabled gdb in addition to standard one
+PYGDB_DESC= Build and install python-enabled gdb in addition to standard one
PDF_USE= TEX=base:build,tex:build,dvipsk:build
PDF_BUILD_DEPENDS= texi2dvi:print/texinfo
@@ -35,10 +35,9 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libgmp.so:math/gmp \
libmpfr.so:math/mpfr \
libmpc.so:math/mpc \
- libisl.so:devel/isl \
- libelf.so:devel/libelf
+ libisl.so:devel/isl
-USES= bison compiler cpe gmake iconv makeinfo tar:bzip2
+USES= bison compiler cpe gmake gettext-runtime iconv makeinfo tar:bzip2
GNU_CONFIGURE= yes