aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gccxml
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2007-08-28 17:33:13 +0800
committervs <vs@FreeBSD.org>2007-08-28 17:33:13 +0800
commit858ac61cf8de601af11b242298d515278491b46a (patch)
tree327ae547afbba5b10bdd83d3c497636fb7398cdb /devel/gccxml
parente701a4594693ff68f609150d13badb825df11f99 (diff)
downloadfreebsd-ports-gnome-858ac61cf8de601af11b242298d515278491b46a.tar.gz
freebsd-ports-gnome-858ac61cf8de601af11b242298d515278491b46a.tar.zst
freebsd-ports-gnome-858ac61cf8de601af11b242298d515278491b46a.zip
Unbreak on -CURRENT by falling back to gcc3.4
PRs: ports/114427, ports/115694 (Scot Hetzel and cokane@)
Diffstat (limited to 'devel/gccxml')
-rw-r--r--devel/gccxml/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/devel/gccxml/Makefile b/devel/gccxml/Makefile
index 074d90df8c74..cee0444736c8 100644
--- a/devel/gccxml/Makefile
+++ b/devel/gccxml/Makefile
@@ -31,6 +31,7 @@ do-configure:
${REINPLACE_CMD} -e "s,x86_64,amd64," \
${WRKSRC}/../gccxml-0.6.0/GCC/gcc/config.gcc
cd ${WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} \
${LOCALBASE}/bin/cmake ../${DISTNAME} -DCMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
-DGCCXML_MAN_DIR:PATH="/man"
@@ -39,7 +40,16 @@ do-configure:
.if ${ARCH} == "alpha"
BROKEN= Build fails on alpha
.elif ${OSVERSION} >= 700000
-BROKEN= Does not compile
+# GCC-XML has some constructs that GCC 4.2 does not like. Namely,
+# the use of casted-pointer-dereferences as an lvalue to post-increment
+# operations.
+USE_GCC= 3.4
+CONFIGURE_ENV+= CC=${LOCALBASE}/bin/gcc34 \
+ CPP="${CC} -E" \
+ CXX=${LOCALBASE}/bin/g++34
+MAKE_ENV+= CC=${LOCALBASE}/bin/gcc34 \
+ CPP="${CC} -E" \
+ CXX=${LOCALBASE}/bin/g++34
.endif
.include <bsd.port.post.mk>