aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gcvs/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-03-31 19:42:00 +0800
committerdinoex <dinoex@FreeBSD.org>2001-03-31 19:42:00 +0800
commit199ffb2e89888a26c21be68559ac1b048cd2653d (patch)
tree767a3eaa5831a1e271109015ad4a28a4f8c734d7 /devel/gcvs/Makefile
parent91489156a3fc0558b94ec447e3a94dc9e7f83cb4 (diff)
downloadfreebsd-ports-gnome-199ffb2e89888a26c21be68559ac1b048cd2653d.tar.gz
freebsd-ports-gnome-199ffb2e89888a26c21be68559ac1b048cd2653d.tar.zst
freebsd-ports-gnome-199ffb2e89888a26c21be68559ac1b048cd2653d.zip
A set of C++ front-end for cvs distributed under GPL.
CvsGui features WinCvs is written in C++ using the Microsoft MFC. MacCvs is written in C++ using Metrowerks PowerPlant. gCvs is written in C++ using GNU gtk+. They are using the latest cvs source code. They are making cvs easier for the novice. They are increasing the power of cvs by providing an high-end interface. The project is growing because it is supported and developed by several cvs users. WWW: http://cvsgui.sourceforge.net/
Diffstat (limited to 'devel/gcvs/Makefile')
-rw-r--r--devel/gcvs/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
new file mode 100644
index 000000000000..db35fe848438
--- /dev/null
+++ b/devel/gcvs/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gvcs
+# Date Created: 28 Mar 2001
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gcvs
+PORTVERSION= 1.0a7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cvsgui
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+BUILD_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+RUN_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --with-tclinclude=${LOCALBASE}/include/tcl8.3
+CONFIGURE_ARGS+= --with-tcllib=${LOCALBASE}/lib/tcl8.3
+LIBS+= -lgnugetopt
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib/ ${LIBS}"
+MAN= cvs.1 cvs.5 cvsbug.8
+
+.include <bsd.port.mk>