aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-11-18 14:34:51 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-11-18 14:34:51 +0800
commite58f29898f55958144212520459b343368b13882 (patch)
treed222bd6ae18223f24c004abf6c32ddf88650a944 /devel/gdb/Makefile
parentea85c1087051d85268271ac37a652da05ebf9845 (diff)
downloadfreebsd-ports-gnome-e58f29898f55958144212520459b343368b13882.tar.gz
freebsd-ports-gnome-e58f29898f55958144212520459b343368b13882.tar.zst
freebsd-ports-gnome-e58f29898f55958144212520459b343368b13882.zip
- Add OPTIONS: THREAD for optional thread support (default on)
- Change comment to match current version PR: ports/162641 Submitted by: Luca Pizzamiglio <luca.pizzamiglio@gmail.com> (maintainer) Feature safe: yes
Diffstat (limited to 'devel/gdb/Makefile')
-rw-r--r--devel/gdb/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index a849595929dc..1c74d06ee71b 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -1,5 +1,5 @@
# ex:ts=8
-# Ports collection makefile for: GDB 7.1
+# Ports collection makefile for: GDB 7.3.x
# Date created: 16 November 2010
# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
#
@@ -42,7 +42,8 @@ ONLY_FOR_ARCHS= i386 amd64 # untested elsewhere, might work
OPTIONS= DEBUG "Build with debugging symbols" off \
EXPAT "Enable XML parsing for metadata" off \
- PYTHON "Enable Python support" off
+ PYTHON "Enable Python support" off \
+ THREAD "Enable Thread support" on
.include <bsd.port.options.mk>
@@ -83,7 +84,9 @@ CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
post-patch:
@${REINPLACE_CMD} -e 's/$$/ [GDB v${PORTVERSION} for FreeBSD]/' \
${WRKSRC}/gdb/version.in
- @${CP} ${FILESDIR}/fbsd-threads.c ${WRKSRC}/gdb
+.if !defined(WITHOUT_THREAD)
+ @${CP} ${FILESDIR}/fbsd-threads.c ${WRKSRC}/gdb/
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/gdb${VER}