aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb66
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
commit41290677b018da2819144b0188ac8bd1b91a88e4 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /devel/gdb66
parent02239bfdfc92a832c32cc57d07d3a1a4b3fc4ad9 (diff)
downloadfreebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.gz
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.zst
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Diffstat (limited to 'devel/gdb66')
-rw-r--r--devel/gdb66/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index c76e578b4692..1d91e5dd5a4d 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
--enable-target=all \
- --enable-tui --with-libiconv-prefix=${LOCALBASE}
+ --enable-tui
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
@@ -38,6 +38,10 @@ MAN1= gdb${VER}.1
.include <bsd.port.options.mk>
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+= --with-libiconv-prefix=${LOCALBASE}
+.endif
+
.if ${PORT_OPTIONS:MINSIGHT}
PKGNAMESUFFIX= -insight
USE_TK= 84+
@@ -87,7 +91,7 @@ post-patch:
${WRKSRC}/gdb/version.in
@${REINPLACE_CMD} -e 's/^READLINE/#READLINE/' \
-e 's/^readline/#readline/' \
- -e 's,^LIBICONV =.*,LIBICONV=-L${LOCALBASE}/lib -liconv,' \
+ -e 's,^LIBICONV =.*,LIBICONV=-L${LOCALBASE}/lib ${ICONV_LIB},' \
${WRKSRC}/gdb/Makefile.in
${ECHO} 'READLINE = -lreadline' >> ${WRKSRC}/gdb/Makefile.in