aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-11-06 02:48:46 +0800
committertijl <tijl@FreeBSD.org>2015-11-06 02:48:46 +0800
commita7dd2ce18395e19e04a2ac048bbceda171e714a1 (patch)
tree1049a5c79874f01fa37c580676e31b102cfcf68e /devel/gdb
parentdda7a8023c8ac79dd4f1b3c64f72f76164b398a6 (diff)
downloadfreebsd-ports-gnome-a7dd2ce18395e19e04a2ac048bbceda171e714a1.tar.gz
freebsd-ports-gnome-a7dd2ce18395e19e04a2ac048bbceda171e714a1.tar.zst
freebsd-ports-gnome-a7dd2ce18395e19e04a2ac048bbceda171e714a1.zip
- Fix a potential parallel build issue
- Fix a regression when debugging a threaded process that forks (like r399623, but for vfork(2)) PR: 203661 Submitted by: luca.pizzamiglio@gmail.com (maintainer)
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile2
-rw-r--r--devel/gdb/files/extrapatch-kgdb10
-rw-r--r--devel/gdb/files/fbsd-threads.c1
3 files changed, 12 insertions, 1 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index bad5e47e1466..f8787e2b5115 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdb
PORTVERSION= 7.10
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= GNU
diff --git a/devel/gdb/files/extrapatch-kgdb b/devel/gdb/files/extrapatch-kgdb
index 93621d0c6dcd..33a623bf8590 100644
--- a/devel/gdb/files/extrapatch-kgdb
+++ b/devel/gdb/files/extrapatch-kgdb
@@ -2,6 +2,16 @@ diff --git gdb/Makefile.in gdb/Makefile.in
index dfaa8a3..182d875 100644
--- gdb/Makefile.in
+++ gdb/Makefile.in
+@@ -207,7 +207,8 @@
+
+ # Generated headers in the gnulib directory. These must be listed
+ # so that they are generated before other files are compiled.
+-GNULIB_H = $(GNULIB_BUILDDIR)/import/string.h @GNULIB_STDINT_H@
++GNULIB_H = $(GNULIB_BUILDDIR)/import/string.h \
++ $(GNULIB_BUILDDIR)/import/alloca.h @GNULIB_STDINT_H@
+
+ #
+ # CLI sub directory definitons
@@ -650,7 +650,8 @@ ALL_64_TARGET_OBS = \
ia64-linux-tdep.o ia64-vms-tdep.o ia64-tdep.o \
mips64obsd-tdep.o \
diff --git a/devel/gdb/files/fbsd-threads.c b/devel/gdb/files/fbsd-threads.c
index cd7b186c0975..689128bb3e3f 100644
--- a/devel/gdb/files/fbsd-threads.c
+++ b/devel/gdb/files/fbsd-threads.c
@@ -766,6 +766,7 @@ fbsd_thread_wait (struct target_ops *ops,
ret = beneath->to_wait (beneath, ptid, ourstatus, options);
if (GET_PID(ret) >= 0 &&
( ourstatus->kind == TARGET_WAITKIND_STOPPED ||
+ ourstatus->kind == TARGET_WAITKIND_VFORKED ||
ourstatus->kind == TARGET_WAITKIND_FORKED ) )
{
lwp = get_current_lwp (GET_PID(ret));