aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
committerbapt <bapt@FreeBSD.org>2013-04-29 16:57:12 +0800
commit1ca518c98321627ea34bdaae84c439a2f0df0cdf (patch)
tree526d65e6697f1e03c06ab0d0f901688aa2c4e18d /devel/gdb
parent81215f7fb03620d52b441a5714e6af1fb655c743 (diff)
downloadfreebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.gz
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.tar.zst
freebsd-ports-gnome-1ca518c98321627ea34bdaae84c439a2f0df0cdf.zip
Rely on bsdtar to autodetermine the format of the distfiles when possible
For a while now bsdtar is able to autotermine compression and archive format. Let's then use tar directly instead of piping to tar. Now USE_BZIP2 and USE_XZ only set EXTRACT_SUFX to the right format
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 952048823691..cf68b0447b44 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -25,8 +25,7 @@ CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect sim texinfo intl
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - ${EXCLUDE:S/^/--exclude /} \
- --no-same-owner --no-same-permissions
+EXTRACT_AFTER_ARGS= ${EXCLUDE:S/^/--exclude /}
VER= ${PORTVERSION:S/.//g}
PLIST_SUB= VER=${VER}
MAN1= gdb${VER}.1