aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gettext/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2002-08-01 10:30:59 +0800
committerade <ade@FreeBSD.org>2002-08-01 10:30:59 +0800
commitce9aea3f9f796f09f65ce9e78805af7dd85729ec (patch)
tree76dfc9d5a434bbc5ac9aa3ecf3f9de3f73a5c4fb /devel/gettext/Makefile
parent09b5c2f799579bb13b94f9d62ae42b63d3bfae49 (diff)
downloadfreebsd-ports-gnome-ce9aea3f9f796f09f65ce9e78805af7dd85729ec.tar.gz
freebsd-ports-gnome-ce9aea3f9f796f09f65ce9e78805af7dd85729ec.tar.zst
freebsd-ports-gnome-ce9aea3f9f796f09f65ce9e78805af7dd85729ec.zip
(1) Update to 0.11.4
(2) install po-compat.el in addition to po-mode.el PR: (1) 41170 (2) 41170, 40670 Submitted by: 40670: Olivier Tharan <olive@oban.frmug.org> 41170: Ports Fury
Diffstat (limited to 'devel/gettext/Makefile')
-rw-r--r--devel/gettext/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 7f219c6fb5f3..cdf1e17dc0ba 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gettext
-PORTVERSION= 0.11.2
-PORTREVISION= 1
+PORTVERSION= 0.11.4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gettext
@@ -17,20 +16,25 @@ MAINTAINER= portmgr@FreeBSD.org
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
expat.3:${PORTSDIR}/textproc/expat2
-USE_BISON= yes
-INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= ACLOCAL="${TRUE}" \
+ AUTOCONF="${TRUE}" \
+ AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}" \
+ MAKEINFO="makeinfo --no-split" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-libexpat-prefix=${LOCALBASE}/lib
+INSTALLS_SHLIB= yes
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
VERSION=${PORTVERSION}
-MAN1= gettext.1 msgattrib.1 msgcat.1 msgcmp.1 msgcomm.1 \
- msgconv.1 msgen.1 msgexec.1 msgfilter.1 msgfmt.1 \
- msggrep.1 msginit.1 msgmerge.1 msgunfmt.1 msguniq.1 \
- ngettext.1 xgettext.1
+MAN1= autopoint.1 gettext.1 gettextize.1 msgattrib.1 msgcat.1 \
+ msgcmp.1 msgcomm.1 msgconv.1 msgen.1 msgexec.1 \
+ msgfilter.1 msgfmt.1 msggrep.1 msginit.1 msgmerge.1 \
+ msgunfmt.1 msguniq.1 ngettext.1 xgettext.1
MAN3= bind_textdomain_codeset.3 bindtextdomain.3 dcgettext.3 \
dcngettext.3 dgettext.3 dngettext.3 gettext.3 ngettext.3 \
textdomain.3
@@ -41,8 +45,9 @@ pre-configure:
post-install:
@install-info ${PREFIX}/info/gettext.info ${PREFIX}/info/dir
${MKDIR} ${PREFIX}/share/emacs/site-lisp
- ${INSTALL_DATA} ${WRKSRC}/misc/po-mode.el \
- ${PREFIX}/share/emacs/site-lisp/po-mode.el
+.for file in po-compat.el po-mode.el
+ ${INSTALL_DATA} ${WRKSRC}/misc/${file} ${PREFIX}/share/emacs/site-lisp
+.endfor
${MKDIR} ${X11BASE}/share/locale
.include <bsd.port.mk>