aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gettext
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2004-04-03 10:03:27 +0800
committertrevor <trevor@FreeBSD.org>2004-04-03 10:03:27 +0800
commitebc238836eafce4643ef50b2124d133f88b3c737 (patch)
tree25ea908ce1931777571a1649ee46d10e52349bda /devel/gettext
parent69e2516840c81986ffd2cd703c64ee8392943889 (diff)
downloadfreebsd-ports-gnome-ebc238836eafce4643ef50b2124d133f88b3c737.tar.gz
freebsd-ports-gnome-ebc238836eafce4643ef50b2124d133f88b3c737.tar.zst
freebsd-ports-gnome-ebc238836eafce4643ef50b2124d133f88b3c737.zip
Correct packing list.
Diffstat (limited to 'devel/gettext')
-rw-r--r--devel/gettext/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/gettext/Makefile b/devel/gettext/Makefile
index 068612dd8e3c..26d4dba7a7be 100644
--- a/devel/gettext/Makefile
+++ b/devel/gettext/Makefile
@@ -33,6 +33,7 @@ INSTALLS_SHLIB= yes
OPTIONS= EXAMPLES "install example files" off
PLIST= ${WRKDIR}/plist
+PLISTU= ${WRKDIR}/plist-unsorted
PLIST_SUB= LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
VERSION=${PORTVERSION}
@@ -71,18 +72,21 @@ post-build:
.endif
pre-install:
- @${RM} -f ${PLIST}
+ @${RM} -f ${PLISTU}
+ @${TOUCH} ${PLISTU}
.if defined (WITH_EXAMPLES)
cd ${WRKSRC}/gettext-tools && \
${FIND} -s examples -type f | ${GREP} -vw examples/po | \
${GREP} -v ChangeLog | ${GREP} -v examples/Makefile | \
${GREP} -v examples/installpaths.in | \
- ${SED} 's:^:share/doc/gettext/:' > ${PLIST} && \
+ ${SED} 's:^:share/doc/gettext/:' > ${PLISTU} && \
${FIND} -d examples -type d | ${GREP} -v examples/po | \
- ${SED} -e 's:^:@dirrm share/doc/gettext/:' \
- >> ${PLIST}
+ ${GREP} / | ${SED} -e 's:^:@dirrm share/doc/gettext/:' \
+ >> ${PLISTU}
.endif
- @${CAT} ${.CURDIR}/pkg-plist >> ${PLIST}
+ @${CAT} ${.CURDIR}/pkg-plist ${PLISTU} | ${GREP} -v ^@ > ${PLIST}
+ @${SORT} -r ${.CURDIR}/pkg-plist ${PLISTU} | ${GREP} ^@dirrm >> ${PLIST}
+ @${GREP} -h ^@ ${.CURDIR}/pkg-plist ${PLISTU} | ${GREP} exec >> ${PLIST}
post-install:
.for f in po-compat.el po-mode.el