aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gide/files
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-05-18 00:34:01 +0800
committerade <ade@FreeBSD.org>2000-05-18 00:34:01 +0800
commit012bf243b3e096a6900b1cbe6dfaef67f921fb95 (patch)
tree95d8021c71fb816c8eda804bfb1e2e1096f8ce06 /devel/gide/files
parent614a1e50eced1a96f2d1c75c5fdc1464abcfbe55 (diff)
downloadfreebsd-ports-gnome-012bf243b3e096a6900b1cbe6dfaef67f921fb95.tar.gz
freebsd-ports-gnome-012bf243b3e096a6900b1cbe6dfaef67f921fb95.tar.zst
freebsd-ports-gnome-012bf243b3e096a6900b1cbe6dfaef67f921fb95.zip
Update to 0.3.0, claim MAINTAINERship from ports@FreeBSD.org
Diffstat (limited to 'devel/gide/files')
-rw-r--r--devel/gide/files/patch-bb36
-rw-r--r--devel/gide/files/patch-bc66
-rw-r--r--devel/gide/files/patch-bd11
3 files changed, 113 insertions, 0 deletions
diff --git a/devel/gide/files/patch-bb b/devel/gide/files/patch-bb
new file mode 100644
index 000000000000..28789b97b335
--- /dev/null
+++ b/devel/gide/files/patch-bb
@@ -0,0 +1,36 @@
+--- configure.orig Fri May 12 16:14:47 2000
++++ configure Wed May 17 09:36:16 2000
+@@ -2238,8 +2238,9 @@
+ #define WITH_REGEX 1
+ EOF
+
+- echo $ac_n "checking for GNU regex in libc""... $ac_c" 1>&6
+-echo "configure:2243: checking for GNU regex in libc" >&5
++LIBS="$LIBS -lgnuregex"
++ echo $ac_n "checking for GNU regex in libgnuregex""... $ac_c" 1>&6
++echo "configure:2243: checking for GNU regex in libgnuregex" >&5
+ if eval "test \"`echo '$''{'am_cv_gnu_regex'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+@@ -5163,15 +5164,15 @@
+ fi
+
+
+- USE_INCLUDED_LIBINTL=yes
++ USE_INCLUDED_LIBINTL=no
+ CATOBJEXT=.gmo
+ INSTOBJEXT=.mo
+ DATADIRNAME=share
+- INTLDEPS='$(top_builddir)/intl/libintl.a'
+- INTLLIBS=$INTLDEPS
+- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+- nls_cv_header_intl=intl/libintl.h
+- nls_cv_header_libgt=intl/libgettext.h
++ INTLDEPS=
++ INTLLIBS=
++ LIBS='-lintl'
++ nls_cv_header_intl=
++ nls_cv_header_libgt=
+ fi
+
+ if test "$XGETTEXT" != ":"; then
diff --git a/devel/gide/files/patch-bc b/devel/gide/files/patch-bc
new file mode 100644
index 000000000000..f6228f6a6bcd
--- /dev/null
+++ b/devel/gide/files/patch-bc
@@ -0,0 +1,66 @@
+--- plugins/asciitable/Makefile.in.orig Sun May 14 10:11:31 2000
++++ plugins/asciitable/Makefile.in Wed May 17 09:39:52 2000
+@@ -157,7 +157,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+ LIBS = @LIBS@
+-libgide_asciitable_la_LDFLAGS =
++libgide_asciitable_la_LDFLAGS = -avoid-version
+ libgide_asciitable_la_LIBADD =
+ libgide_asciitable_la_OBJECTS = plugin_asciitable.lo
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+--- plugins/browser/Makefile.in.orig Sun May 14 10:11:35 2000
++++ plugins/browser/Makefile.in Wed May 17 09:40:10 2000
+@@ -163,7 +163,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+ LIBS = @LIBS@
+-libgide_browser_la_LDFLAGS =
++libgide_browser_la_LDFLAGS = -avoid-version
+ libgide_browser_la_DEPENDENCIES = GtkSCB/libGtkSCB.la
+ libgide_browser_la_OBJECTS = plugin_browser.lo
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+--- plugins/calculator/Makefile.in.orig Sun May 14 10:11:33 2000
++++ plugins/calculator/Makefile.in Wed May 17 09:40:22 2000
+@@ -157,7 +157,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+ LIBS = @LIBS@
+-libgide_calculator_la_LDFLAGS =
++libgide_calculator_la_LDFLAGS = -avoid-version
+ libgide_calculator_la_LIBADD =
+ libgide_calculator_la_OBJECTS = plugin_calculator.lo
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+--- plugins/docstat/Makefile.in.orig Sun May 14 10:11:34 2000
++++ plugins/docstat/Makefile.in Wed May 17 09:40:34 2000
+@@ -157,7 +157,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+ LIBS = @LIBS@
+-libgide_docstat_la_LDFLAGS =
++libgide_docstat_la_LDFLAGS = -avoid-version
+ libgide_docstat_la_LIBADD =
+ libgide_docstat_la_OBJECTS = plugin_docstat.lo
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+--- plugins/sample/Makefile.in.orig Sun May 14 10:11:29 2000
++++ plugins/sample/Makefile.in Wed May 17 09:40:45 2000
+@@ -163,7 +163,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+ LIBS = @LIBS@
+-libgide_sample_la_LDFLAGS =
++libgide_sample_la_LDFLAGS = -avoid-version
+ libgide_sample_la_LIBADD =
+ libgide_sample_la_OBJECTS = plugin-sample.lo
+ COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+--- plugins/text/Makefile.in.orig Sun May 14 10:11:32 2000
++++ plugins/text/Makefile.in Wed May 17 09:40:55 2000
+@@ -158,7 +158,7 @@
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I../..
+ LIBS = @LIBS@
+-libgide_text_la_LDFLAGS =
++libgide_text_la_LDFLAGS = -avoid-version
+ libgide_text_la_LIBADD =
+ libgide_text_la_OBJECTS = plugin_text.lo plugin_text_insert.lo \
+ plugin_text_delete.lo plugin_text_replace.lo
diff --git a/devel/gide/files/patch-bd b/devel/gide/files/patch-bd
new file mode 100644
index 000000000000..36011e1c05c8
--- /dev/null
+++ b/devel/gide/files/patch-bd
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sun May 14 10:11:41 2000
++++ src/Makefile.in Wed May 17 09:46:40 2000
+@@ -161,7 +161,7 @@
+
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I..
+-LIBS = @LIBS@
++LIBS = @LIBS@ -lgnuregex
+ gide_OBJECTS = gI_about.o gI_cfp.o gI_compile.o gI_document.o gI_edit.o \
+ gI_file.o gI_files.o gI_functions.o gI_help.o gI_menus.o gI_prefs.o \
+ gI_project.o gI_search.o gI_tools.o gI_run.o gI_tree.o gI_window.o \