aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gindent
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-14 00:54:13 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-14 00:54:13 +0800
commitf474b349ca76c3614f2f862cfb328e9d2b6621f2 (patch)
tree964b7af3f393dd115d5d697f03cdefe6cbff449a /devel/gindent
parentc7a6389b710b9c0da1e5c58bd3485b0a13ef747f (diff)
downloadfreebsd-ports-gnome-f474b349ca76c3614f2f862cfb328e9d2b6621f2.tar.gz
freebsd-ports-gnome-f474b349ca76c3614f2f862cfb328e9d2b6621f2.tar.zst
freebsd-ports-gnome-f474b349ca76c3614f2f862cfb328e9d2b6621f2.zip
fix malloc.h bug in -current
PR: 40346 Submitted by: Dan Nelson <dnelson@allantgroup.com>
Diffstat (limited to 'devel/gindent')
-rw-r--r--devel/gindent/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/devel/gindent/Makefile b/devel/gindent/Makefile
index 6439766c0f63..12199e68fe88 100644
--- a/devel/gindent/Makefile
+++ b/devel/gindent/Makefile
@@ -18,6 +18,7 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -26,4 +27,8 @@ MAKE_ARGS= BERKELEY_DEFAULTS=1
MAN1= gindent.1
+post-patch:
+ @${GREP} -lR "malloc.h" ${WRKSRC} | ${XARGS} \
+ ${REINPLACE_CMD} -e "s/malloc.h/stdlib.h/g"
+
.include <bsd.port.mk>