aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-12-27 23:34:19 +0800
committerwxs <wxs@FreeBSD.org>2011-12-27 23:34:19 +0800
commit047124b26a3858d4c090a7ebc9af9704d80e6b3c (patch)
tree3a2395088654c1c2fd0dbb87adbb50b529af29e6 /devel/git
parentb789142346e6f38f80ae623d68c62ed3fa8a928c (diff)
downloadfreebsd-ports-gnome-047124b26a3858d4c090a7ebc9af9704d80e6b3c.tar.gz
freebsd-ports-gnome-047124b26a3858d4c090a7ebc9af9704d80e6b3c.tar.zst
freebsd-ports-gnome-047124b26a3858d4c090a7ebc9af9704d80e6b3c.zip
Fix an issue where a documentation symlink can be extracted with an incorrect
owner. This only happens if the distfile is extracted as a non-root user, which is why nobody has noticed this before (I imagine not many people extract and build as non-root). Because it's not a big deal and not likely to hit the majority of users, I'm not bumping PORTREVISION. Noticed by: Andrzej Tobola (private mail)
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 65236ede1be0..d2250e04fa0f 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -389,8 +389,14 @@ post-install:
(cd ${WRKDIR}/man5/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man5)
(cd ${WRKDIR}/man7/ && ${COPYTREE_SHARE} \* ${MANPREFIX}/man/man7)
.if defined (WITH_HTMLDOCS)
+ # Manually remove the index.html symlink before installing, and then
+ # recreate it after. This is necessary because the distfile is
+ # extracted with --no-same-owner. If the distfile is extracted as a
+ # non-root user then the symlink will have the incorrect owner.
+ ${RM} -f ${WRKDIR}/htmldocs/index.html
${MKDIR} ${DOCSDIR}
(cd ${WRKDIR}/htmldocs/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
+ ${LN} -s ${DOCSDIR}/git.html ${DOCSDIR}/index.html
.endif
-${RM} -f ${PREFIX}/lib/perl5/${PERL_VERSION}/mach/perllocal.pod
${MKDIR} ${PREFIX}/share/emacs/site-lisp/git