aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2008-01-17 07:29:11 +0800
committerflz <flz@FreeBSD.org>2008-01-17 07:29:11 +0800
commit9fbafcdda925b9c949f63e970e9283dd7a3decb2 (patch)
tree3c8ea4d13edd09cc45195739bb74994426a22fe7 /devel/git
parent05f80dd7bd455b98df8b85df927438d40af6e0fd (diff)
downloadfreebsd-ports-gnome-9fbafcdda925b9c949f63e970e9283dd7a3decb2.tar.gz
freebsd-ports-gnome-9fbafcdda925b9c949f63e970e9283dd7a3decb2.tar.zst
freebsd-ports-gnome-9fbafcdda925b9c949f63e970e9283dd7a3decb2.zip
- Update the port to 1.5.3.8.
- Fix handling of OPTIONS as WITHOUT_GUI wouldn trigger the dependency on Tk. - Add some more manpages, and install GUI-related manpages only when necessary. - Silence some commands. - Install git-daemon rc script. - Add git-shell to /etc/shells. PR: ports/119728 Submitted by: flz Approved by: anholt (maintainer)
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile40
-rw-r--r--devel/git/distinfo12
-rw-r--r--devel/git/files/git-daemon.in29
-rw-r--r--devel/git/files/patch-while-case298
-rw-r--r--devel/git/pkg-plist2
5 files changed, 65 insertions, 316 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index ef0b90cda5b3..21eb23f86739 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.5.3.2
+PORTVERSION= 1.5.3.8
CATEGORIES= devel
MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
@@ -60,11 +60,12 @@ MAN1= git-add.1 \
git-fast-import.1 \
git-fetch-pack.1 \
git-fetch.1 \
+ git-filter-branch.1 \
git-fmt-merge-msg.1 \
- git-format-patch.1 \
git-for-each-ref.1 \
- git-fsck.1 \
+ git-format-patch.1 \
git-fsck-objects.1 \
+ git-fsck.1 \
git-gc.1 \
git-get-tar-commit-id.1 \
git-grep.1 \
@@ -73,8 +74,8 @@ MAN1= git-add.1 \
git-http-push.1 \
git-imap-send.1 \
git-index-pack.1 \
- git-init.1 \
git-init-db.1 \
+ git-init.1 \
git-instaweb.1 \
git-local-fetch.1 \
git-log.1 \
@@ -84,12 +85,12 @@ MAN1= git-add.1 \
git-ls-tree.1 \
git-mailinfo.1 \
git-mailsplit.1 \
- git-merge.1 \
git-merge-base.1 \
git-merge-file.1 \
git-merge-index.1 \
git-merge-one-file.1 \
git-merge-tree.1 \
+ git-merge.1 \
git-mergetool.1 \
git-mktag.1 \
git-mktree.1 \
@@ -133,10 +134,12 @@ MAN1= git-add.1 \
git-show.1 \
git-ssh-fetch.1 \
git-ssh-upload.1 \
+ git-stash.1 \
git-status.1 \
git-stripspace.1 \
- git-svnimport.1 \
+ git-submodule.1 \
git-svn.1 \
+ git-svnimport.1 \
git-symbolic-ref.1 \
git-tag.1 \
git-tar-tree.1 \
@@ -151,10 +154,11 @@ MAN1= git-add.1 \
git-verify-pack.1 \
git-verify-tag.1 \
git-whatchanged.1 \
- git-write-tree.1 \
- gitk.1
+ git-write-tree.1
MAN3= Git.3
-MAN5= gitattributes.5 gitignore.5
+MAN5= gitattributes.5 \
+ gitignore.5 \
+ gitmodules.5
MAN7= git.7
USE_BZIP2= yes
@@ -171,13 +175,19 @@ MAKE_ENV+= CURLDIR=${LOCALBASE} \
LIBMD_SHA1=yes
MAKE_ARGS+= prefix="${PREFIX}"
USE_OPENSSL= yes
+USE_RC_SUBR= git-daemon
+
+SHELLS= /etc/shells
OPTIONS= GUI "Enable building of GUI tools" on \
SVN "Enable required dependencies for SVN tools" off
.include <bsd.port.pre.mk>
-.ifdef WITH_GUI
+.ifndef WITHOUT_GUI
+MAN1+= git-citool.1 \
+ git-gui.1 \
+ gitk.1
PLIST_SUB+= GUI=""
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
MAKE_ENV+= TCL_PATH=tclsh8.4 TCLTK_PATH=wish8.4
@@ -192,13 +202,13 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Ter
.endif
pre-patch:
- ${REINPLACE_CMD} -e 's|OPENSSLDIR|OPENSSLBASE|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|OPENSSLDIR|OPENSSLBASE|g' ${WRKSRC}/Makefile
post-patch:
@${REINPLACE_CMD} -e 's|share/man/man3|man/man3|' ${WRKSRC}/perl/Makefile.PL
post-build:
- ${SED} -e'1s|#!/usr/bin/python|#!${PYTHON_CMD}|' \
+ @${SED} -e'1s|#!/usr/bin/python|#!${PYTHON_CMD}|' \
${WRKSRC}/contrib/p4import/git-p4import.py > \
${WRKSRC}/contrib/p4import/git-p4import
@@ -230,4 +240,10 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/contrib/fast-import/git-p4 \
${PREFIX}/bin/
+ @${ECHO_MSG} "===> Updating ${SHELLS}"
+ @${CP} ${SHELLS} ${SHELLS}.bak
+ @(${GREP} -v ${PREFIX}/bin/git-shell ${SHELLS}.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/git-shell) > ${SHELLS}
+ @${RM} ${SHELLS}.bak
+
.include <bsd.port.post.mk>
diff --git a/devel/git/distinfo b/devel/git/distinfo
index f52b5b4fb386..5c5db749c2f7 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,6 +1,6 @@
-MD5 (git-1.5.3.2.tar.bz2) = 2113337dd27141a6890ff84f25164901
-SHA256 (git-1.5.3.2.tar.bz2) = e39b5492f3982a4f935e48294c775ddd0e63fdd2ba75b675f882479d29329d45
-SIZE (git-1.5.3.2.tar.bz2) = 1344171
-MD5 (git-manpages-1.5.3.2.tar.bz2) = 375183e7370877f752674063e4336dfa
-SHA256 (git-manpages-1.5.3.2.tar.bz2) = b6c6c444e8c1a7f4d5b3a1307739f583cf90e58f4ddfb8156005958f087e904f
-SIZE (git-manpages-1.5.3.2.tar.bz2) = 147283
+MD5 (git-1.5.3.8.tar.bz2) = bb2477df09d4af52b05f0ee64d6ccc54
+SHA256 (git-1.5.3.8.tar.bz2) = f98c6b900c9f3b87a1fbbe0c5f466e9d981cb9f1d193066b6d371df4b8066b77
+SIZE (git-1.5.3.8.tar.bz2) = 1363259
+MD5 (git-manpages-1.5.3.8.tar.bz2) = 6aebdb18ab71309d6404f5be3cd7f09d
+SHA256 (git-manpages-1.5.3.8.tar.bz2) = 73a7cc2c0473694d454a6b7cb311ccdeb82f350bc8e652229d361592ea0a482f
+SIZE (git-manpages-1.5.3.8.tar.bz2) = 147875
diff --git a/devel/git/files/git-daemon.in b/devel/git/files/git-daemon.in
new file mode 100644
index 000000000000..92495ff66bc2
--- /dev/null
+++ b/devel/git/files/git-daemon.in
@@ -0,0 +1,29 @@
+#! /bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: git_daemon
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable git_daemon:
+#
+#git_daemon_enable="YES"
+
+. %%RC_SUBR%%
+
+name="git_daemon"
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+: ${git_daemon_enable:=NO}
+: ${git_daemon_directory:=%%PREFIX%%/git}
+: ${git_daemon_flags:="--syslog"}
+
+command="%%PREFIX%%/bin/git-daemon"
+command_args="${git_daemon_directory} &"
+
+run_rc_command "$1"
diff --git a/devel/git/files/patch-while-case b/devel/git/files/patch-while-case
deleted file mode 100644
index ae5e7a1c6f55..000000000000
--- a/devel/git/files/patch-while-case
+++ /dev/null
@@ -1,298 +0,0 @@
-Option parsing in the Git shell scripts uses the construct 'while
-case "$#" in 0) break ;; esac; do ... done'. This is neat, because
-it needs no external commands invocation. But for the FreeBSD's
-original Bourne shell (that is not fully IEEE 1003.2-compliant) the
-'case' construct that has not matched patterns does not modify the
-exit value. As per IEEE 1003.2, it should return zero: see
-http://opengroup.org/onlinepubs/000095399, Shell and Utilities
-Volume (XCU), Case Conditional Construct.
-
-The fix is to add the case branch '*) : ;;'. It also needs no
-external commands invocation and it does its work, because ':'
-always returns zero.
-
-FreeBSD has the PR 116559,
- http://www.freebsd.org/cgi/query-pr.cgi?pr=116559
-that fixes the shell issue. If it will be committed, this patch
-will not be needed anymore for systems that will have the fixed
-/bin/sh.
-
-Signed-off-by: Eygene Ryabinkin <rea-git@codelabs.ru>
----
- contrib/examples/git-gc.sh | 2 +-
- contrib/examples/git-tag.sh | 2 +-
- contrib/examples/git-verify-tag.sh | 2 +-
- git-am.sh | 2 +-
- git-clean.sh | 2 +-
- git-commit.sh | 2 +-
- git-fetch.sh | 2 +-
- git-filter-branch.sh | 2 +-
- git-instaweb.sh | 2 +-
- git-ls-remote.sh | 2 +-
- git-merge.sh | 2 +-
- git-mergetool.sh | 2 +-
- git-pull.sh | 2 +-
- git-quiltimport.sh | 2 +-
- git-rebase--interactive.sh | 2 +-
- git-rebase.sh | 4 ++--
- git-repack.sh | 2 +-
- git-reset.sh | 2 +-
- git-submodule.sh | 2 +-
- 19 files changed, 20 insertions(+), 20 deletions(-)
-
-diff --git contrib/examples/git-gc.sh b/contrib/examples/git-gc.sh
-index 2ae235b..60cb348 100755
---- contrib/examples/git-gc.sh
-+++ contrib/examples/git-gc.sh
-@@ -9,7 +9,7 @@ SUBDIRECTORY_OK=Yes
- . git-sh-setup
-
- no_prune=:
--while case $# in 0) break ;; esac
-+while case $# in 0) break ;; *) : ;; esac
- do
- case "$1" in
- --prune)
-diff --git contrib/examples/git-tag.sh b/contrib/examples/git-tag.sh
-index 5ee3f50..26aab69 100755
---- contrib/examples/git-tag.sh
-+++ contrib/examples/git-tag.sh
-@@ -14,7 +14,7 @@ username=
- list=
- verify=
- LINES=0
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- -a)
-diff --git contrib/examples/git-verify-tag.sh b/contrib/examples/git-verify-tag.sh
-index 37b0023..9a0f011 100755
---- contrib/examples/git-verify-tag.sh
-+++ contrib/examples/git-verify-tag.sh
-@@ -5,7 +5,7 @@ SUBDIRECTORY_OK='Yes'
- . git-sh-setup
-
- verbose=
--while case $# in 0) break;; esac
-+while case $# in 0) break;; *) : ;; esac
- do
- case "$1" in
- -v|--v|--ve|--ver|--verb|--verbo|--verbos|--verbose)
-diff --git git-am.sh b/git-am.sh
-index 6809aa0..0bd8d34 100755
---- git-am.sh
-+++ git-am.sh
-@@ -109,7 +109,7 @@ dotest=.dotest sign= utf8=t keep= skip= interactive= resolved= binary=
- resolvemsg= resume=
- git_apply_opt=
-
--while case "$#" in 0) break;; esac
-+while case "$#" in 0) break;; *) : ;; esac
- do
- case "$1" in
- -d=*|--d=*|--do=*|--dot=*|--dote=*|--dotes=*|--dotest=*)
-diff --git git-clean.sh b/git-clean.sh
-index a5cfd9f..1fac731 100755
---- git-clean.sh
-+++ git-clean.sh
-@@ -26,7 +26,7 @@ rmrf="rm -rf --"
- rm_refuse="echo Not removing"
- echo1="echo"
-
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- -d)
-diff --git git-commit.sh b/git-commit.sh
-index bb113e8..5f298c1 100755
---- git-commit.sh
-+++ git-commit.sh
-@@ -89,7 +89,7 @@ force_author=
- only_include_assumed=
- untracked_files=
- templatefile="`git config commit.template`"
--while case "$#" in 0) break;; esac
-+while case "$#" in 0) break;; *) : ;; esac
- do
- case "$1" in
- -F|--F|-f|--f|--fi|--fil|--file)
-diff --git git-fetch.sh b/git-fetch.sh
-index c3a2001..dac2d72 100755
---- git-fetch.sh
-+++ git-fetch.sh
-@@ -27,7 +27,7 @@ shallow_depth=
- no_progress=
- test -t 1 || no_progress=--no-progress
- quiet=
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- -a|--a|--ap|--app|--appe|--appen|--append)
-diff --git git-filter-branch.sh b/git-filter-branch.sh
-index a4b6577..02b567b 100755
---- git-filter-branch.sh
-+++ git-filter-branch.sh
-@@ -105,7 +105,7 @@ filter_tag_name=
- filter_subdir=
- orig_namespace=refs/original/
- force=
--while case "$#" in 0) usage;; esac
-+while case "$#" in 0) usage;; *) : ;; esac
- do
- case "$1" in
- --)
-diff --git git-instaweb.sh b/git-instaweb.sh
-index b79c6b6..c85f8c0 100755
---- git-instaweb.sh
-+++ git-instaweb.sh
-@@ -61,7 +61,7 @@ stop_httpd () {
- test -f "$fqgitdir/pid" && kill `cat "$fqgitdir/pid"`
- }
-
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- --stop|stop)
-diff --git git-ls-remote.sh b/git-ls-remote.sh
-index b7e5d04..4ef4341 100755
---- git-ls-remote.sh
-+++ git-ls-remote.sh
-@@ -13,7 +13,7 @@ die () {
- }
-
- exec=
--while case "$#" in 0) break;; esac
-+while case "$#" in 0) break;; *) : ;; esac
- do
- case "$1" in
- -h|--h|--he|--hea|--head|--heads)
-diff --git git-merge.sh b/git-merge.sh
-index 3a01db0..94a50aa 100755
---- git-merge.sh
-+++ git-merge.sh
-@@ -122,7 +122,7 @@ merge_name () {
- case "$#" in 0) usage ;; esac
-
- have_message=
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- -n|--n|--no|--no-|--no-s|--no-su|--no-sum|--no-summ|\
-diff --git git-mergetool.sh b/git-mergetool.sh
-index 47a8055..0e286dd 100755
---- git-mergetool.sh
-+++ git-mergetool.sh
-@@ -268,7 +268,7 @@ merge_file () {
- cleanup_temp_files
- }
-
--while case $# in 0) break ;; esac
-+while case $# in 0) break ;; *) : ;; esac
- do
- case "$1" in
- -t|--tool*)
-diff --git git-pull.sh b/git-pull.sh
-index 5e96d1f..722ed4e 100755
---- git-pull.sh
-+++ git-pull.sh
-@@ -16,7 +16,7 @@ test -z "$(git ls-files -u)" ||
- die "You are in the middle of a conflicted merge."
-
- strategy_args= no_summary= no_commit= squash=
--while case "$#,$1" in 0) break ;; *,-*) ;; *) break ;; esac
-+while case "$#,$1" in 0) break ;; *,-*) : ;; *) break ;; esac
- do
- case "$1" in
- -n|--n|--no|--no-|--no-s|--no-su|--no-sum|--no-summ|\
-diff --git git-quiltimport.sh b/git-quiltimport.sh
-index 9de54d1..4039617 100755
---- git-quiltimport.sh
-+++ git-quiltimport.sh
-@@ -5,7 +5,7 @@ SUBDIRECTORY_ON=Yes
-
- dry_run=""
- quilt_author=""
--while case "$#" in 0) break;; esac
-+while case "$#" in 0) break;; *) : ;; esac
- do
- case "$1" in
- --au=*|--aut=*|--auth=*|--autho=*|--author=*)
-diff --git git-rebase--interactive.sh b/git-rebase--interactive.sh
-index abc2b1c..54e4299 100755
---- git-rebase--interactive.sh
-+++ git-rebase--interactive.sh
-@@ -317,7 +317,7 @@ do_rest () {
- done
- }
-
--while case $# in 0) break ;; esac
-+while case $# in 0) break ;; *) : ;; esac
- do
- case "$1" in
- --continue)
-diff --git git-rebase.sh b/git-rebase.sh
-index 3bd66b0..29cfab2 100755
---- git-rebase.sh
-+++ git-rebase.sh
-@@ -122,7 +122,7 @@ finish_rb_merge () {
-
- is_interactive () {
- test -f "$dotest"/interactive ||
-- while case $#,"$1" in 0,|*,-i|*,--interactive) break ;; esac
-+ while case $#,"$1" in 0,|*,-i|*,--interactive) break ;; *) : ;; esac
- do
- shift
- done && test -n "$1"
-@@ -130,7 +130,7 @@ is_interactive () {
-
- is_interactive "$@" && exec git-rebase--interactive "$@"
-
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- --continue)
-diff --git git-repack.sh b/git-repack.sh
-index 156c5e8..aac771e 100755
---- git-repack.sh
-+++ git-repack.sh
-@@ -9,7 +9,7 @@ SUBDIRECTORY_OK='Yes'
-
- no_update_info= all_into_one= remove_redundant=
- local= quiet= no_reuse= extra=
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- -n) no_update_info=t ;;
-diff --git git-reset.sh b/git-reset.sh
-index 1dc606f..eb92610 100755
---- git-reset.sh
-+++ git-reset.sh
-@@ -11,7 +11,7 @@ require_work_tree
- update= reset_type=--mixed
- unset rev
-
--while case $# in 0) break ;; esac
-+while case $# in 0) break ;; *) : ;; esac
- do
- case "$1" in
- --mixed | --soft | --hard)
-diff --git git-submodule.sh b/git-submodule.sh
-index 3320998..78a25ad 100755
---- git-submodule.sh
-+++ git-submodule.sh
-@@ -251,7 +251,7 @@ modules_list()
- done
- }
-
--while case "$#" in 0) break ;; esac
-+while case "$#" in 0) break ;; *) : ;; esac
- do
- case "$1" in
- add)
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index e81088479dd6..4ee4d52898f3 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -115,6 +115,8 @@ bin/git-send-email
bin/git-send-pack
bin/git-sh-setup
bin/git-shell
+@exec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells; rm -f /etc/shells.bak
+@unexec echo "Updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells; rm -f /etc/shells.bak
bin/git-shortlog
bin/git-show
bin/git-show-branch