aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-10-13 02:57:40 +0800
committerwxs <wxs@FreeBSD.org>2009-10-13 02:57:40 +0800
commit988605a9ace0bed057ee0844e5cfcca27e55364f (patch)
treef27eb2e4ef173d185dcedb803a87705746a821b3 /devel/git
parent2dd5996977a385b8a7fa31b14f8a1953bd9a7518 (diff)
downloadfreebsd-ports-gnome-988605a9ace0bed057ee0844e5cfcca27e55364f.tar.gz
freebsd-ports-gnome-988605a9ace0bed057ee0844e5cfcca27e55364f.tar.zst
freebsd-ports-gnome-988605a9ace0bed057ee0844e5cfcca27e55364f.zip
- Update to 1.6.5
- Add V=1 to MAKE_ENV (I like to actually see what's going on in the build, and it results in useful build logs when it fails) - Silence the verify target
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile10
-rw-r--r--devel/git/distinfo18
-rw-r--r--devel/git/pkg-plist7
3 files changed, 22 insertions, 13 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 2aa6209541a6..f4e8fcadc217 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= git
-PORTVERSION= 1.6.4.4
+PORTVERSION= 1.6.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_KERNEL_ORG}
MASTER_SITE_SUBDIR= software/scm/${PORTNAME}
@@ -173,12 +173,14 @@ USE_BZIP2= yes
USE_PERL5= yes
USE_ICONV= yes
USE_GMAKE= yes
-CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
MAKE_ENV+= CURLDIR=${LOCALBASE} \
NEEDS_LIBICONV=yes \
OLD_ICONV=yes \
PERL_PATH=${PERL} \
- LIBMD_SHA1=yes
+ LIBMD_SHA1=yes \
+ ICONVDIR=${LOCALBASAE} \
+ V=1
MAKE_ARGS+= prefix="${PREFIX}"
USE_OPENSSL= yes
USE_RC_SUBR= git_daemon
@@ -253,7 +255,7 @@ PLIST_SUB+= CVS="@comment "
.endif
verify: checksum
- gpg --verify ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}.sign \
+ @gpg --verify ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}.sign \
${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
post-patch:
diff --git a/devel/git/distinfo b/devel/git/distinfo
index f0c85836c87d..e4a27623adc1 100644
--- a/devel/git/distinfo
+++ b/devel/git/distinfo
@@ -1,9 +1,9 @@
-MD5 (git-1.6.4.4.tar.bz2) = b150352782998ca1f84185e6af53ec26
-SHA256 (git-1.6.4.4.tar.bz2) = fc7e4d6c4172c62c93d5e974019f7193b03c8bc0a1c6f3a9fcc1d0928b808d7a
-SIZE (git-1.6.4.4.tar.bz2) = 2174826
-MD5 (git-manpages-1.6.4.4.tar.bz2) = 5ee880f408f1299d541c273fb7e3c1db
-SHA256 (git-manpages-1.6.4.4.tar.bz2) = a2b2fb1aabdbb3e1e8ae9472523b9fef23c3e8a992bb8f68f17ad832a6e59c98
-SIZE (git-manpages-1.6.4.4.tar.bz2) = 248348
-MD5 (git-1.6.4.4.tar.bz2.sign) = b8fda36fc6d83353d50c6320d166f5ac
-SHA256 (git-1.6.4.4.tar.bz2.sign) = 300662edacd5bd7ca460c87b584efbcb89ce0377924f7316288669608394608b
-SIZE (git-1.6.4.4.tar.bz2.sign) = 248
+MD5 (git-1.6.5.tar.bz2) = da86c1736c55edb9f446828581137b51
+SHA256 (git-1.6.5.tar.bz2) = 377962fe1176a36030ca450d801fe745adc88a69bbba69d76d48e141d0147f92
+SIZE (git-1.6.5.tar.bz2) = 2243169
+MD5 (git-manpages-1.6.5.tar.bz2) = 17b46ccbec5e02e82a76f7ee81a0b182
+SHA256 (git-manpages-1.6.5.tar.bz2) = 4fb88e4217a82594581a8cae148766fea77a2d9778141fde8bc17517e90a5ca4
+SIZE (git-manpages-1.6.5.tar.bz2) = 252127
+MD5 (git-1.6.5.tar.bz2.sign) = 324a578d8a81b31d371d78dd91702b3d
+SHA256 (git-1.6.5.tar.bz2.sign) = b3831f40bb522a819147aa4f47439b83a391925155113d7c6daeae8beda97fae
+SIZE (git-1.6.5.tar.bz2.sign) = 248
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index b50ca72a1fb8..61d2638bb25f 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -111,8 +111,10 @@ libexec/git-core/git-receive-pack
libexec/git-core/git-reflog
libexec/git-core/git-relink
libexec/git-core/git-remote
+libexec/git-core/git-remote-curl
libexec/git-core/git-repack
libexec/git-core/git-repo-config
+libexec/git-core/git-replace
libexec/git-core/git-request-pull
libexec/git-core/git-rerere
libexec/git-core/git-reset
@@ -319,7 +321,11 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/git-reflog.html
%%HTMLDOCS%%%%DOCSDIR%%/git-relink.html
%%HTMLDOCS%%%%DOCSDIR%%/git-remote.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-remote-helpers.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-remote-helpers.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-repack.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-replace.html
+%%HTMLDOCS%%%%DOCSDIR%%/git-replace.txt
%%HTMLDOCS%%%%DOCSDIR%%/git-repo-config.html
%%HTMLDOCS%%%%DOCSDIR%%/git-request-pull.html
%%HTMLDOCS%%%%DOCSDIR%%/git-rerere.html
@@ -706,6 +712,7 @@ share/git-core/templates/info/exclude
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.4.2.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.4.3.txt
%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.4.4.txt
+%%HTMLDOCS%%%%DOCSDIR%%/RelNotes-1.6.5.txt
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/INSTALL
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/README
%%GITWEB%%%%EXAMPLESDIR%%/gitweb/git-favicon.png