aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-04-07 20:15:19 +0800
committerwxs <wxs@FreeBSD.org>2011-04-07 20:15:19 +0800
commit380a1450ef01759a7076ac74215256c34bfbc5e0 (patch)
tree099854e26ceaae2598ddda1321ca11471fe99404 /devel/git
parented1c28e9aabc3edc12de46b14aa07329977d32a0 (diff)
downloadfreebsd-ports-gnome-380a1450ef01759a7076ac74215256c34bfbc5e0.tar.gz
freebsd-ports-gnome-380a1450ef01759a7076ac74215256c34bfbc5e0.tar.zst
freebsd-ports-gnome-380a1450ef01759a7076ac74215256c34bfbc5e0.zip
Add OPTION for subversion-freebsd dependency.
PR: ports/156234 Submitted by: dougb@
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 014b6e3fadba..fd12d349d365 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -185,6 +185,7 @@ WANT_PERL= yes
OPTIONS= GUI "Enable building of GUI tools" off \
SVN "Enable required dependencies for SVN tools" off \
+ SVN_FBSD "Use subversion-freebsd dependency (implies SVN)" off \
GITWEB "Install gitweb" off \
CONTRIB "Install contributed scripts" on \
P4 "Enable Perforce support" on \
@@ -265,10 +266,14 @@ PLIST_SUB+= GUI="@comment "
MAKE_ARGS+= NO_TCLTK=yes
.endif
-.ifdef (WITH_SVN)
+.ifdef (WITH_SVN) || defined(WITH_SVN_FBSD)
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
- svn:${PORTSDIR}/devel/subversion
+ ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion
+.ifdef (WITH_SVN_FBSD)
+RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion-freebsd
+.else
+RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+.endif
PLIST_SUB+= SVN=""
MAN1+= git-svn.1
.else