aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-12-19 00:17:32 +0800
committerwxs <wxs@FreeBSD.org>2011-12-19 00:17:32 +0800
commitaeab759515717529b17e3a515e1328df2aaa29f7 (patch)
tree885a2e6edc6285131670823f2f24fd8dbf5bbb57 /devel/git
parent585c49fdde65a2081daf354ccc5e02803d2dca2a (diff)
downloadfreebsd-ports-gnome-aeab759515717529b17e3a515e1328df2aaa29f7.tar.gz
freebsd-ports-gnome-aeab759515717529b17e3a515e1328df2aaa29f7.tar.zst
freebsd-ports-gnome-aeab759515717529b17e3a515e1328df2aaa29f7.zip
Switch to installing contrib files using COPYTREE_BIN instead of
COPYTREE_SHARE. The documentation in the hooks says you should set executable permissions on the hook before setting it up in a repository, but if you update git the permissions get reset. Just install the entire contrib directory with executable bit set. What we really need is a "COPYTREE_ASIS" that just leaves the permissions as they are. Note I am intentionally not bumping PORTREVISION as this is a minor change and this port gets updated fairly regularly. PR: ports/163167 Submitted by: Matthias Fechner <idefix@fechner.net>
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile2
-rw-r--r--devel/git/pkg-plist4
2 files changed, 3 insertions, 3 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 18498651c138..5724289794d1 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -407,7 +407,7 @@ post-install:
@${ECHO_MSG} "===> Installing contributed scripts"
${MKDIR} ${PREFIX}/share/git-core/contrib
(cd ${WRKSRC}/contrib/ && \
- ${COPYTREE_SHARE} \* ${PREFIX}/share/git-core/contrib)
+ ${COPYTREE_BIN} \* ${PREFIX}/share/git-core/contrib)
.endif
.ifdef (WITH_P4)
${INSTALL_SCRIPT} ${WRKSRC}/contrib/p4import/git-p4import ${PREFIX}/bin/
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 49be77f9e483..28d99a062f50 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -1008,5 +1008,5 @@ share/git-core/templates/info/exclude
%%CONTRIB%%@dirrm share/git-core/contrib/workdir
%%CONTRIB%%@dirrm share/git-core/contrib
@dirrm share/git-core
-%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/git_remote_helpers/git
-%%PYTHON%%@dirrm %%PYTHON_SITELIBDIR%%/git_remote_helpers
+%%PYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%/git_remote_helpers/git
+%%PYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%/git_remote_helpers