aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glade3
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
committermarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
commite83248f2b323aa90dfea75471b86ccc444a80f88 (patch)
treef4fc2dbabf96cb67c502479d9fc13f40bf0d0108 /devel/glade3
parent52dd0c5de1d6a7165dc355ecf161f52bb7dbbfda (diff)
downloadfreebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.gz
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.zst
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'devel/glade3')
-rw-r--r--devel/glade3/Makefile30
-rw-r--r--devel/glade3/distinfo6
-rw-r--r--devel/glade3/pkg-plist146
3 files changed, 128 insertions, 54 deletions
diff --git a/devel/glade3/Makefile b/devel/glade3/Makefile
index 709288bd77b6..4d851505e4f9 100644
--- a/devel/glade3/Makefile
+++ b/devel/glade3/Makefile
@@ -3,11 +3,11 @@
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/glade3/Makefile,v 1.21 2006/10/08 19:17:28 mezz Exp $
+# $MCom: ports/devel/glade3/Makefile,v 1.29 2007/03/13 17:16:00 mezz Exp $
#
PORTNAME= glade3
-PORTVERSION= 3.0.3
+PORTVERSION= 3.2.0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -20,28 +20,40 @@ INSTALLS_ICONS= yes
USE_XLIB= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 libxml2 gnomeprefix gnomehack
+USE_GNOME= gnometarget gtk20 libxml2 gnomeprefix gnomehack \
+ gnomedocutils desktopfileutils
WANT_GNOME= yes
USE_GETTEXT= yes
+INSTALLS_OMF= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-DOCSDIR= share/doc/gladeui
+DOCSDIR= ${PREFIX}/share/doc/gladeui
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not build on 4.X
-.endif
-
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
CONFIGURE_ARGS+=--enable-gnome
-PKGNAMESUFFIX:= -gnome
+PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-gnome
.else
CONFIGURE_ARGS+=--disable-gnome
.endif
+.if ${HAVE_GNOME:Mpygtk2}!=""
+USE_PYTHON= yes
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygtk2
+PLIST_SUB+= PYTHON:=""
+.else
+CONFIGURE_ARGS+=--disable-python
+PLIST_SUB+= PYTHON:="@comment "
+.endif
+
+post-install:
+ ${MKDIR} ${PREFIX}/lib/glade3/bindings
+ @-update-desktop-database
+
.include <bsd.port.post.mk>
diff --git a/devel/glade3/distinfo b/devel/glade3/distinfo
index 795b32c24102..8839fa72dcee 100644
--- a/devel/glade3/distinfo
+++ b/devel/glade3/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/glade3-3.0.3.tar.bz2) = 1e965bbce1febdb6260a42467c0fd957
-SHA256 (gnome2/glade3-3.0.3.tar.bz2) = e31394ac998abde7dc1eb0951635430892e35bb82913e70d6d28c2d6b7c880e8
-SIZE (gnome2/glade3-3.0.3.tar.bz2) = 868366
+MD5 (gnome2/glade3-3.2.0.tar.bz2) = bee0aeb66b29ac40b24d9413aace15cc
+SHA256 (gnome2/glade3-3.2.0.tar.bz2) = 4ca06cc1ab8670858b0295fc126aa39f059a0b90f0c399022770ee0b522eb35e
+SIZE (gnome2/glade3-3.2.0.tar.bz2) = 1344693
diff --git a/devel/glade3/pkg-plist b/devel/glade3/pkg-plist
index a4a2a8277d5a..e8205659f8e9 100644
--- a/devel/glade3/pkg-plist
+++ b/devel/glade3/pkg-plist
@@ -1,51 +1,54 @@
bin/glade-3
-include/libgladeui-1.0/libgladeui/atk.xpm
-include/libgladeui-1.0/libgladeui/fixed_bg.xpm
-include/libgladeui-1.0/libgladeui/glade-accumulators.h
-include/libgladeui-1.0/libgladeui/glade-app.h
-include/libgladeui-1.0/libgladeui/glade-base-editor.h
-include/libgladeui-1.0/libgladeui/glade-builtins.h
-include/libgladeui-1.0/libgladeui/glade-catalog.h
-include/libgladeui-1.0/libgladeui/glade-clipboard-view.h
-include/libgladeui-1.0/libgladeui/glade-clipboard.h
-include/libgladeui-1.0/libgladeui/glade-command.h
-include/libgladeui-1.0/libgladeui/glade-cursor.h
-include/libgladeui-1.0/libgladeui/glade-custom.h
-include/libgladeui-1.0/libgladeui/glade-debug.h
-include/libgladeui-1.0/libgladeui/glade-editor-property.h
-include/libgladeui-1.0/libgladeui/glade-editor.h
-include/libgladeui-1.0/libgladeui/glade-fixed.h
-include/libgladeui-1.0/libgladeui/glade-gtk.h
-include/libgladeui-1.0/libgladeui/glade-id-allocator.h
-include/libgladeui-1.0/libgladeui/glade-marshallers.h
-include/libgladeui-1.0/libgladeui/glade-palette-box.h
-include/libgladeui-1.0/libgladeui/glade-palette-expander.h
-include/libgladeui-1.0/libgladeui/glade-palette-item.h
-include/libgladeui-1.0/libgladeui/glade-palette.h
-include/libgladeui-1.0/libgladeui/glade-parameter.h
-include/libgladeui-1.0/libgladeui/glade-parser.h
-include/libgladeui-1.0/libgladeui/glade-placeholder.h
-include/libgladeui-1.0/libgladeui/glade-popup.h
-include/libgladeui-1.0/libgladeui/glade-project-view.h
-include/libgladeui-1.0/libgladeui/glade-project.h
-include/libgladeui-1.0/libgladeui/glade-property-class.h
-include/libgladeui-1.0/libgladeui/glade-property.h
-include/libgladeui-1.0/libgladeui/glade-signal-editor.h
-include/libgladeui-1.0/libgladeui/glade-signal.h
-include/libgladeui-1.0/libgladeui/glade-utils.h
-include/libgladeui-1.0/libgladeui/glade-widget-class.h
-include/libgladeui-1.0/libgladeui/glade-widget.h
-include/libgladeui-1.0/libgladeui/glade-xml-utils.h
-include/libgladeui-1.0/libgladeui/glade.h
+include/libgladeui-1.0/gladeui/atk.xpm
+include/libgladeui-1.0/gladeui/fixed_bg.xpm
+include/libgladeui-1.0/gladeui/glade-accumulators.h
+include/libgladeui-1.0/gladeui/glade-app.h
+include/libgladeui-1.0/gladeui/glade-base-editor.h
+include/libgladeui-1.0/gladeui/glade-binding.h
+include/libgladeui-1.0/gladeui/glade-builtins.h
+include/libgladeui-1.0/gladeui/glade-catalog.h
+include/libgladeui-1.0/gladeui/glade-clipboard-view.h
+include/libgladeui-1.0/gladeui/glade-clipboard.h
+include/libgladeui-1.0/gladeui/glade-command.h
+include/libgladeui-1.0/gladeui/glade-cursor.h
+include/libgladeui-1.0/gladeui/glade-custom.h
+include/libgladeui-1.0/gladeui/glade-debug.h
+include/libgladeui-1.0/gladeui/glade-design-layout.h
+include/libgladeui-1.0/gladeui/glade-design-view.h
+include/libgladeui-1.0/gladeui/glade-editor-property.h
+include/libgladeui-1.0/gladeui/glade-editor.h
+include/libgladeui-1.0/gladeui/glade-fixed.h
+include/libgladeui-1.0/gladeui/glade-id-allocator.h
+include/libgladeui-1.0/gladeui/glade-marshallers.h
+include/libgladeui-1.0/gladeui/glade-palette-box.h
+include/libgladeui-1.0/gladeui/glade-palette-expander.h
+include/libgladeui-1.0/gladeui/glade-palette-item.h
+include/libgladeui-1.0/gladeui/glade-palette.h
+include/libgladeui-1.0/gladeui/glade-parameter.h
+include/libgladeui-1.0/gladeui/glade-parser.h
+include/libgladeui-1.0/gladeui/glade-placeholder.h
+include/libgladeui-1.0/gladeui/glade-popup.h
+include/libgladeui-1.0/gladeui/glade-project-view.h
+include/libgladeui-1.0/gladeui/glade-project.h
+include/libgladeui-1.0/gladeui/glade-property-class.h
+include/libgladeui-1.0/gladeui/glade-property.h
+include/libgladeui-1.0/gladeui/glade-signal-editor.h
+include/libgladeui-1.0/gladeui/glade-signal.h
+include/libgladeui-1.0/gladeui/glade-utils.h
+include/libgladeui-1.0/gladeui/glade-widget-adaptor.h
+include/libgladeui-1.0/gladeui/glade-widget.h
+include/libgladeui-1.0/gladeui/glade-xml-utils.h
+include/libgladeui-1.0/gladeui/glade.h
+%%PYTHON:%%lib/glade3/bindings/libgladepython.la
+%%PYTHON:%%lib/glade3/bindings/libgladepython.so
%%GNOME:%%lib/glade3/modules/libgladegnome.la
%%GNOME:%%lib/glade3/modules/libgladegnome.so
lib/glade3/modules/libgladegtk.la
lib/glade3/modules/libgladegtk.so
lib/libgladeui-1.la
lib/libgladeui-1.so
-lib/libgladeui-1.so.4
-libdata/pkgconfig/glade-3.pc
-libdata/pkgconfig/libgladeui-1.0.pc
+lib/libgladeui-1.so.5
+libdata/pkgconfig/gladeui-1.0.pc
%%DOCSDIR%%/GladeApp.html
%%DOCSDIR%%/GladeClipboard.html
%%DOCSDIR%%/GladeClipboardView.html
@@ -97,6 +100,7 @@ share/gnome/glade3/pixmaps/16x16/accellabel.png
share/gnome/glade3/pixmaps/16x16/alignment.png
share/gnome/glade3/pixmaps/16x16/arrow.png
share/gnome/glade3/pixmaps/16x16/aspectframe.png
+share/gnome/glade3/pixmaps/16x16/assistant.png
%%GNOME:%%share/gnome/glade3/pixmaps/16x16/bonobodock.png
%%GNOME:%%share/gnome/glade3/pixmaps/16x16/bonobodockitem.png
share/gnome/glade3/pixmaps/16x16/button.png
@@ -161,6 +165,7 @@ share/gnome/glade3/pixmaps/16x16/imagemenuitem.png
share/gnome/glade3/pixmaps/16x16/inputdialog.png
share/gnome/glade3/pixmaps/16x16/label.png
share/gnome/glade3/pixmaps/16x16/layout.png
+share/gnome/glade3/pixmaps/16x16/linkbutton.png
share/gnome/glade3/pixmaps/16x16/list.png
share/gnome/glade3/pixmaps/16x16/listitem.png
share/gnome/glade3/pixmaps/16x16/menu.png
@@ -170,10 +175,14 @@ share/gnome/glade3/pixmaps/16x16/menutoolbutton.png
share/gnome/glade3/pixmaps/16x16/messagedialog.png
share/gnome/glade3/pixmaps/16x16/notebook.png
share/gnome/glade3/pixmaps/16x16/optionmenu.png
+share/gnome/glade3/pixmaps/16x16/pagesetupdialog.png
+share/gnome/glade3/pixmaps/16x16/printdialog.png
share/gnome/glade3/pixmaps/16x16/progressbar.png
share/gnome/glade3/pixmaps/16x16/radiobutton.png
share/gnome/glade3/pixmaps/16x16/radiomenuitem.png
share/gnome/glade3/pixmaps/16x16/radiotoolbutton.png
+share/gnome/glade3/pixmaps/16x16/recentchooser.png
+share/gnome/glade3/pixmaps/16x16/recentchooserdialog.png
share/gnome/glade3/pixmaps/16x16/ruler.png
share/gnome/glade3/pixmaps/16x16/scrolledwindow.png
share/gnome/glade3/pixmaps/16x16/separatormenuitem.png
@@ -202,6 +211,7 @@ share/gnome/glade3/pixmaps/22x22/accellabel.png
share/gnome/glade3/pixmaps/22x22/alignment.png
share/gnome/glade3/pixmaps/22x22/arrow.png
share/gnome/glade3/pixmaps/22x22/aspectframe.png
+share/gnome/glade3/pixmaps/22x22/assistant.png
%%GNOME:%%share/gnome/glade3/pixmaps/22x22/bonobodock.png
%%GNOME:%%share/gnome/glade3/pixmaps/22x22/bonobodockitem.png
share/gnome/glade3/pixmaps/22x22/button.png
@@ -266,6 +276,7 @@ share/gnome/glade3/pixmaps/22x22/imagemenuitem.png
share/gnome/glade3/pixmaps/22x22/inputdialog.png
share/gnome/glade3/pixmaps/22x22/label.png
share/gnome/glade3/pixmaps/22x22/layout.png
+share/gnome/glade3/pixmaps/22x22/linkbutton.png
share/gnome/glade3/pixmaps/22x22/list.png
share/gnome/glade3/pixmaps/22x22/listitem.png
share/gnome/glade3/pixmaps/22x22/menu.png
@@ -275,10 +286,14 @@ share/gnome/glade3/pixmaps/22x22/menutoolbutton.png
share/gnome/glade3/pixmaps/22x22/messagedialog.png
share/gnome/glade3/pixmaps/22x22/notebook.png
share/gnome/glade3/pixmaps/22x22/optionmenu.png
+share/gnome/glade3/pixmaps/22x22/pagesetupdialog.png
+share/gnome/glade3/pixmaps/22x22/printdialog.png
share/gnome/glade3/pixmaps/22x22/progressbar.png
share/gnome/glade3/pixmaps/22x22/radiobutton.png
share/gnome/glade3/pixmaps/22x22/radiomenuitem.png
share/gnome/glade3/pixmaps/22x22/radiotoolbutton.png
+share/gnome/glade3/pixmaps/22x22/recentchooser.png
+share/gnome/glade3/pixmaps/22x22/recentchooserdialog.png
share/gnome/glade3/pixmaps/22x22/ruler.png
share/gnome/glade3/pixmaps/22x22/scrolledwindow.png
share/gnome/glade3/pixmaps/22x22/separatormenuitem.png
@@ -305,20 +320,51 @@ share/gnome/glade3/pixmaps/22x22/window.png
share/gnome/glade3/pixmaps/devhelp.png
share/gnome/glade3/pixmaps/plus.png
share/gnome/glade3/pixmaps/selector.png
+share/gnome/help/glade/C/figures/main-window.png
+share/gnome/help/glade/C/glade.xml
+share/gnome/help/glade/C/legal.xml
+share/gnome/help/glade/bg/figures/main-window.png
+share/gnome/help/glade/bg/glade.xml
+share/gnome/help/glade/bg/legal.xml
+share/gnome/help/glade/en_GB/figures/main-window.png
+share/gnome/help/glade/en_GB/glade.xml
+share/gnome/help/glade/en_GB/legal.xml
+share/gnome/help/glade/sv/figures/main-window.png
+share/gnome/help/glade/sv/glade.xml
+share/gnome/help/glade/sv/legal.xml
+share/gnome/omf/glade/glade-C.omf
+share/gnome/omf/glade/glade-bg.omf
+share/gnome/omf/glade/glade-en_GB.omf
+share/gnome/omf/glade/glade-sv.omf
+share/icons/hicolor/16x16/apps/glade-3.png
+share/icons/hicolor/22x22/apps/glade-3.png
+share/icons/hicolor/24x24/apps/glade-3.png
+share/icons/hicolor/32x32/apps/glade-3.png
share/icons/hicolor/48x48/apps/glade-3.png
+share/icons/hicolor/scalable/apps/glade-3.svg
share/locale/ar/LC_MESSAGES/glade3.mo
share/locale/az/LC_MESSAGES/glade3.mo
+share/locale/bg/LC_MESSAGES/glade3.mo
+share/locale/ca/LC_MESSAGES/glade3.mo
share/locale/da/LC_MESSAGES/glade3.mo
+share/locale/de/LC_MESSAGES/glade3.mo
+share/locale/el/LC_MESSAGES/glade3.mo
share/locale/en_CA/LC_MESSAGES/glade3.mo
share/locale/en_GB/LC_MESSAGES/glade3.mo
share/locale/es/LC_MESSAGES/glade3.mo
share/locale/fr/LC_MESSAGES/glade3.mo
share/locale/gl/LC_MESSAGES/glade3.mo
+share/locale/hu/LC_MESSAGES/glade3.mo
+share/locale/it/LC_MESSAGES/glade3.mo
share/locale/ja/LC_MESSAGES/glade3.mo
share/locale/ko/LC_MESSAGES/glade3.mo
+share/locale/lt/LC_MESSAGES/glade3.mo
+share/locale/mk/LC_MESSAGES/glade3.mo
+share/locale/ml/LC_MESSAGES/glade3.mo
share/locale/ms/LC_MESSAGES/glade3.mo
share/locale/nb/LC_MESSAGES/glade3.mo
share/locale/nn/LC_MESSAGES/glade3.mo
+share/locale/pa/LC_MESSAGES/glade3.mo
share/locale/pl/LC_MESSAGES/glade3.mo
share/locale/pt/LC_MESSAGES/glade3.mo
share/locale/pt_BR/LC_MESSAGES/glade3.mo
@@ -326,12 +372,23 @@ share/locale/ru/LC_MESSAGES/glade3.mo
share/locale/sk/LC_MESSAGES/glade3.mo
share/locale/sv/LC_MESSAGES/glade3.mo
share/locale/ta/LC_MESSAGES/glade3.mo
+share/locale/th/LC_MESSAGES/glade3.mo
share/locale/tr/LC_MESSAGES/glade3.mo
share/locale/uk/LC_MESSAGES/glade3.mo
share/locale/vi/LC_MESSAGES/glade3.mo
share/locale/zh_CN/LC_MESSAGES/glade3.mo
share/locale/zh_HK/LC_MESSAGES/glade3.mo
share/locale/zh_TW/LC_MESSAGES/glade3.mo
+@dirrm share/gnome/omf/glade
+@dirrm share/gnome/help/glade/sv/figures
+@dirrm share/gnome/help/glade/sv
+@dirrm share/gnome/help/glade/en_GB/figures
+@dirrm share/gnome/help/glade/en_GB
+@dirrm share/gnome/help/glade/bg/figures
+@dirrm share/gnome/help/glade/bg
+@dirrm share/gnome/help/glade/C/figures
+@dirrm share/gnome/help/glade/C
+@dirrm share/gnome/help/glade
@dirrm share/gnome/glade3/pixmaps/22x22
@dirrm share/gnome/glade3/pixmaps/16x16
@dirrm share/gnome/glade3/pixmaps
@@ -339,8 +396,9 @@ share/locale/zh_TW/LC_MESSAGES/glade3.mo
@dirrm share/gnome/glade3
@dirrm %%DOCSDIR%%
@dirrm lib/glade3/modules
+@dirrm lib/glade3/bindings
@dirrm lib/glade3
-@dirrm include/libgladeui-1.0/libgladeui
+@dirrm include/libgladeui-1.0/gladeui
@dirrm include/libgladeui-1.0
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@@ -364,3 +422,7 @@ share/locale/zh_TW/LC_MESSAGES/glade3.mo
@dirrmtry share/locale/ko
@dirrmtry share/locale/gl/LC_MESSAGES
@dirrmtry share/locale/gl
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/ca/LC_MESSAGES
+@dirrmtry share/locale/ca