aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glg/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
committermarcus <marcus@FreeBSD.org>2003-11-16 04:37:04 +0800
commit71ad4933995cc892d62e378ee5be6ac15c6e62ef (patch)
tree610711606eefa728d01e4e333cc0119ea924f1f6 /devel/glg/Makefile
parent8918e3de46086cf18a356130171394cc05affdc3 (diff)
downloadfreebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.gz
freebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.tar.zst
freebsd-ports-gnome-71ad4933995cc892d62e378ee5be6ac15c6e62ef.zip
unPERLify, and use ${FIND} and ${XARGS} where appropriate.
PR: 48253 Submitted by: Simon 'portlint' Schubert <corecode@corecode.ath.cx>
Diffstat (limited to 'devel/glg/Makefile')
-rw-r--r--devel/glg/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/glg/Makefile b/devel/glg/Makefile
index 47847f8e8ff0..3f20cdc1b915 100644
--- a/devel/glg/Makefile
+++ b/devel/glg/Makefile
@@ -17,6 +17,7 @@ MASTER_SITE_SUBDIR= kris
MAINTAINER= lo_gafet@users.sourceforge.net
COMMENT= Open Application Builder (code generator) for the GTK and/or GNOME
+USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gtk12
WANT_GNOME= yes
@@ -28,7 +29,7 @@ USE_GNOME+= gnomelibs
.endif
pre-build:
- ${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${PERL} \
- -pi -e "s@gtk-config@${GTK_CONFIG}@g"
+ ${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
+ 's@gtk-config@${GTK_CONFIG}@g'
.include <bsd.port.post.mk>