aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glib20/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-08-23 13:11:32 +0800
committerjylefort <jylefort@FreeBSD.org>2006-08-23 13:11:32 +0800
commita3d49505e1eb76aa2b7b25ad9fde808d3048360e (patch)
tree38f66f3f02927b5f9319307e3350e38d68be3f85 /devel/glib20/Makefile
parent694fe929277a46d2abae19dd4e77a932787dbe43 (diff)
downloadfreebsd-ports-gnome-a3d49505e1eb76aa2b7b25ad9fde808d3048360e.tar.gz
freebsd-ports-gnome-a3d49505e1eb76aa2b7b25ad9fde808d3048360e.tar.zst
freebsd-ports-gnome-a3d49505e1eb76aa2b7b25ad9fde808d3048360e.zip
Fix string collation by using the icu library, since the FreeBSD libc
does not support UTF-8 collation.
Diffstat (limited to 'devel/glib20/Makefile')
-rw-r--r--devel/glib20/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 6042cb345639..533cf227ed00 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -42,12 +42,20 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
+OPTIONS= COLLATION_FIX "fix string collation" off
+
.include <bsd.port.pre.mk>
.if ( ( ${OSVERSION} < 504101 ) || ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600012 ) )
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gthread_gthread-posix.c
.endif
+.if defined(WITH_COLLATION_FIX)
+LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-glib_Makefile.in \
+ ${FILESDIR}/extra-patch-glib_gunicollate.c
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|%%X11BASE%%|${X11BASE}|g' \