aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glib20
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
commit0b42143dea1a55d0f1f6d09704bbc131e1b633ed (patch)
treebc54902eb18f738e45a91362b2b0faf1ec6d04fa /devel/glib20
parent773c9ca4ac44ac67652d01f1e985e4df8dab5301 (diff)
downloadfreebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.gz
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.zst
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile20
-rw-r--r--devel/glib20/distinfo4
-rw-r--r--devel/glib20/files/extra-patch-gthread_gthread-posix.c32
-rw-r--r--devel/glib20/files/patch-glib_gutils.c20
-rw-r--r--devel/glib20/files/patch-gthread_gthread-posix.c32
-rw-r--r--devel/glib20/pkg-plist18
6 files changed, 89 insertions, 37 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 1b2a139341b9..a6d5ad9a05f5 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= glib
-PORTVERSION= 2.4.8
+PORTVERSION= 2.6.3
+PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/2.4,} \
- ftp://ftp.gtk.org/pub/gtk/v2.4/ \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/2.6,} \
+ ftp://ftp.gtk.org/pub/gtk/v2.6/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
@@ -38,4 +39,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 600012
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gthread_gthread-posix.c
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/glib/gutils.c
+
+.include <bsd.port.post.mk>
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index da94272ac8f6..0d5183d695b5 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/glib-2.4.8.tar.bz2) = e160a5feecf46e0fbb36db09c356953c
-SIZE (gnome2/glib-2.4.8.tar.bz2) = 2152755
+MD5 (gnome2/glib-2.6.3.tar.bz2) = 8f69ad5387197114b356efc64ce88d77
+SIZE (gnome2/glib-2.6.3.tar.bz2) = 2300144
diff --git a/devel/glib20/files/extra-patch-gthread_gthread-posix.c b/devel/glib20/files/extra-patch-gthread_gthread-posix.c
new file mode 100644
index 000000000000..8796dd629960
--- /dev/null
+++ b/devel/glib20/files/extra-patch-gthread_gthread-posix.c
@@ -0,0 +1,32 @@
+--- gthread/gthread-posix.c.orig Mon Nov 1 13:47:12 2004
++++ gthread/gthread-posix.c Wed Mar 9 14:21:20 2005
+@@ -115,7 +115,11 @@
+ # define PRIORITY_NORMAL_VALUE priority_normal_value
+ #endif /* POSIX_MIN_PRIORITY && POSIX_MAX_PRIORITY */
+
++#define G_THREAD_STACK_SIZE32 (1*1024*1024)
++#define G_THREAD_STACK_SIZE64 (2*1024*1024)
++
+ static gulong g_thread_min_stack_size = 0;
++static gulong g_thread_default_stack_size = 0;
+
+ #define G_MUTEX_SIZE (sizeof (pthread_mutex_t))
+
+@@ -307,8 +312,16 @@
+ if (stack_size)
+ {
+ stack_size = MAX (g_thread_min_stack_size, stack_size);
+- posix_check_cmd (pthread_attr_setstacksize (&attr, stack_size));
+ }
++ else
++ {
++ if (sizeof(void *) == 8)
++ g_thread_default_stack_size = G_THREAD_STACK_SIZE64;
++ else
++ g_thread_default_stack_size = G_THREAD_STACK_SIZE32;
++ stack_size = MAX (g_thread_min_stack_size, g_thread_default_stack_size);
++ }
++ posix_check_cmd (pthread_attr_setstacksize (&attr, stack_size));
+ #endif /* HAVE_PTHREAD_ATTR_SETSTACKSIZE */
+
+ #ifdef PTHREAD_SCOPE_SYSTEM
diff --git a/devel/glib20/files/patch-glib_gutils.c b/devel/glib20/files/patch-glib_gutils.c
new file mode 100644
index 000000000000..d32b910ad8ca
--- /dev/null
+++ b/devel/glib20/files/patch-glib_gutils.c
@@ -0,0 +1,20 @@
+--- glib/gutils.c.orig Sat Sep 4 15:49:27 2004
++++ glib/gutils.c Sat Sep 4 15:55:24 2004
+@@ -1466,7 +1466,7 @@
+ data_dirs = (gchar *) g_getenv ("XDG_DATA_DIRS");
+
+ if (!data_dirs || !data_dirs[0])
+- data_dirs = "/usr/local/share/:/usr/share/";
++ data_dirs = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
+ #endif
+ data_dir_vector = g_strsplit (data_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
+
+@@ -1509,7 +1509,7 @@
+ conf_dirs = (gchar *) g_getenv ("XDG_CONFIG_DIRS");
+
+ if (!conf_dirs || !conf_dirs[0])
+- conf_dirs = "/etc/xdg";
++ conf_dirs = "%%X11BASE%%/etc/xdg:/usr/local/etc/xdg:/etc/xdg";
+ #endif
+ conf_dir_vector = g_strsplit (conf_dirs, G_SEARCHPATH_SEPARATOR_S, 0);
+ }
diff --git a/devel/glib20/files/patch-gthread_gthread-posix.c b/devel/glib20/files/patch-gthread_gthread-posix.c
index bdf24590d4cc..47c5ab8f1591 100644
--- a/devel/glib20/files/patch-gthread_gthread-posix.c
+++ b/devel/glib20/files/patch-gthread_gthread-posix.c
@@ -1,15 +1,7 @@
---- gthread/gthread-posix.c.orig Tue Sep 7 17:57:53 2004
-+++ gthread/gthread-posix.c Tue Sep 7 17:58:30 2004
-@@ -116,6 +116,7 @@
- #endif /* POSIX_MIN_PRIORITY && POSIX_MAX_PRIORITY */
-
- static gulong g_thread_min_stack_size = 0;
-+static gulong g_thread_default_stack_size = 0x100000;
-
- #define G_MUTEX_SIZE (sizeof (pthread_mutex_t))
-
-@@ -125,7 +126,8 @@
- g_thread_impl_init()
+--- gthread/gthread-posix.c.orig Mon Nov 1 13:47:12 2004
++++ gthread/gthread-posix.c Wed Mar 9 14:21:20 2005
+@@ -125,7 +129,8 @@
+ g_thread_impl_init(void)
{
#ifdef _SC_THREAD_STACK_MIN
- g_thread_min_stack_size = MAX (sysconf (_SC_THREAD_STACK_MIN), 0);
@@ -18,7 +10,7 @@
#endif /* _SC_THREAD_STACK_MIN */
#ifdef HAVE_PRIORITIES
# ifdef G_THREADS_IMPL_POSIX
-@@ -176,7 +178,7 @@
+@@ -176,7 +181,7 @@
result = pthread_mutex_trylock ((pthread_mutex_t *) mutex);
#ifdef G_THREADS_IMPL_POSIX
@@ -27,17 +19,3 @@
return FALSE;
#else /* G_THREADS_IMPL_DCE */
if (result == 0)
-@@ -307,8 +309,12 @@
- if (stack_size)
- {
- stack_size = MAX (g_thread_min_stack_size, stack_size);
-- posix_check_cmd (pthread_attr_setstacksize (&attr, stack_size));
- }
-+ else
-+ {
-+ stack_size = MAX (g_thread_min_stack_size, g_thread_default_stack_size);
-+ }
-+ posix_check_cmd (pthread_attr_setstacksize (&attr, stack_size));
- #endif /* HAVE_PTHREAD_ATTR_SETSTACKSIZE */
-
- #ifdef PTHREAD_SCOPE_SYSTEM
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 5a7533881bfe..5bebbaa72a30 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -22,6 +22,7 @@ include/glib-2.0/glib/ghook.h
include/glib-2.0/glib/gi18n-lib.h
include/glib-2.0/glib/gi18n.h
include/glib-2.0/glib/giochannel.h
+include/glib-2.0/glib/gkeyfile.h
include/glib-2.0/glib/glist.h
include/glib-2.0/glib/gmacros.h
include/glib-2.0/glib/gmain.h
@@ -29,6 +30,7 @@ include/glib-2.0/glib/gmarkup.h
include/glib-2.0/glib/gmem.h
include/glib-2.0/glib/gmessages.h
include/glib-2.0/glib/gnode.h
+include/glib-2.0/glib/goption.h
include/glib-2.0/glib/gpattern.h
include/glib-2.0/glib/gprimes.h
include/glib-2.0/glib/gprintf.h
@@ -41,6 +43,7 @@ include/glib-2.0/glib/gscanner.h
include/glib-2.0/glib/gshell.h
include/glib-2.0/glib/gslist.h
include/glib-2.0/glib/gspawn.h
+include/glib-2.0/glib/gstdio.h
include/glib-2.0/glib/gstrfuncs.h
include/glib-2.0/glib/gstring.h
include/glib-2.0/glib/gthread.h
@@ -72,18 +75,19 @@ include/glib-2.0/gobject/gvaluecollector.h
include/glib-2.0/gobject/gvaluetypes.h
lib/libglib-2.0.a
lib/libglib-2.0.so
-lib/libglib-2.0.so.400
+lib/libglib-2.0.so.600
lib/libgmodule-2.0.a
lib/libgmodule-2.0.so
-lib/libgmodule-2.0.so.400
+lib/libgmodule-2.0.so.600
lib/libgobject-2.0.a
lib/libgobject-2.0.so
-lib/libgobject-2.0.so.400
+lib/libgobject-2.0.so.600
lib/libgthread-2.0.a
lib/libgthread-2.0.so
-lib/libgthread-2.0.so.400
+lib/libgthread-2.0.so.600
libdata/pkgconfig/glib-2.0.pc
libdata/pkgconfig/gmodule-2.0.pc
+libdata/pkgconfig/gmodule-no-export-2.0.pc
libdata/pkgconfig/gobject-2.0.pc
libdata/pkgconfig/gthread-2.0.pc
share/aclocal/glib-2.0.m4
@@ -148,10 +152,12 @@ share/locale/sr@Latn/LC_MESSAGES/glib20.mo
share/locale/sr@ije/LC_MESSAGES/glib20.mo
share/locale/sv/LC_MESSAGES/glib20.mo
share/locale/ta/LC_MESSAGES/glib20.mo
+share/locale/tl/LC_MESSAGES/glib20.mo
share/locale/tr/LC_MESSAGES/glib20.mo
share/locale/uk/LC_MESSAGES/glib20.mo
share/locale/vi/LC_MESSAGES/glib20.mo
share/locale/wa/LC_MESSAGES/glib20.mo
+share/locale/xh/LC_MESSAGES/glib20.mo
share/locale/yi/LC_MESSAGES/glib20.mo
share/locale/zh_CN/LC_MESSAGES/glib20.mo
share/locale/zh_TW/LC_MESSAGES/glib20.mo
@@ -159,6 +165,10 @@ share/locale/zh_TW/LC_MESSAGES/glib20.mo
@unexec rmdir %D/share/locale/ne 2> /dev/null || true
@unexec rmdir %D/share/locale/sr@ije/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/sr@ije 2> /dev/null || true
+@unexec rmdir %D/share/locale/tl/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/tl 2> /dev/null || true
+@unexec rmdir %D/share/locale/xh/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/xh 2> /dev/null || true
@unexec rmdir %D/share/locale/yi/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/yi 2> /dev/null || true
@dirrm share/glib-2.0/gettext/po