aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gmake
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-10-09 04:52:38 +0800
committerbapt <bapt@FreeBSD.org>2014-10-09 04:52:38 +0800
commit0a14032002a3cabbaf9c5d35627e2857f085fe05 (patch)
tree69ae096352951e1662875c22b9ef7b3e102932b8 /devel/gmake
parent65e15f43e14fd357e8524f6ddbc5fdac0a09dbde (diff)
downloadfreebsd-ports-gnome-0a14032002a3cabbaf9c5d35627e2857f085fe05.tar.gz
freebsd-ports-gnome-0a14032002a3cabbaf9c5d35627e2857f085fe05.tar.zst
freebsd-ports-gnome-0a14032002a3cabbaf9c5d35627e2857f085fe05.zip
Update to 4.1
Exp-run by: antoine
Diffstat (limited to 'devel/gmake')
-rw-r--r--devel/gmake/Makefile8
-rw-r--r--devel/gmake/distinfo4
-rw-r--r--devel/gmake/files/patch-default.c11
-rw-r--r--devel/gmake/files/patch-main.c17
-rw-r--r--devel/gmake/files/patch-read.c52
-rw-r--r--devel/gmake/files/patch-remake.c59
-rw-r--r--devel/gmake/pkg-plist2
7 files changed, 5 insertions, 148 deletions
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index ec6722bb0c4a..a308394df262 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gmake
-PORTVERSION= 3.82
-PORTREVISION= 2
+PORTVERSION= 4.1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= make
@@ -34,9 +33,4 @@ CONFIGURE_ENV+= MAKEINFO="makeinfo --no-split"
INFO= make
-post-patch:
- @${REINPLACE_CMD} -e '/no-print-dir/s/@itemx/@item/' \
- ${WRKSRC}/doc/make.texi
- @${RM} ${WRKSRC}/doc/make.info*
-
.include <bsd.port.mk>
diff --git a/devel/gmake/distinfo b/devel/gmake/distinfo
index 6f75d6baced1..ab429ab49f5a 100644
--- a/devel/gmake/distinfo
+++ b/devel/gmake/distinfo
@@ -1,2 +1,2 @@
-SHA256 (make-3.82.tar.bz2) = e2c1a73f179c40c71e2fe8abf8a8a0688b8499538512984da4a76958d0402966
-SIZE (make-3.82.tar.bz2) = 1242186
+SHA256 (make-4.1.tar.bz2) = 0bc7613389650ee6a24554b52572a272f7356164fd2c4132b0bcf13123e4fca5
+SIZE (make-4.1.tar.bz2) = 1327342
diff --git a/devel/gmake/files/patch-default.c b/devel/gmake/files/patch-default.c
deleted file mode 100644
index 06555ef4d702..000000000000
--- a/devel/gmake/files/patch-default.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- default.c.orig 2014-01-03 01:20:16.000000000 -0800
-+++ default.c 2014-01-03 01:20:21.000000000 -0800
-@@ -408,7 +408,7 @@
- "OBJC", "gcc",
- #else
- "CC", "cc",
-- "CXX", "g++",
-+ "CXX", "c++",
- "OBJC", "cc",
- #endif
-
diff --git a/devel/gmake/files/patch-main.c b/devel/gmake/files/patch-main.c
deleted file mode 100644
index 9935ca7d7c27..000000000000
--- a/devel/gmake/files/patch-main.c
+++ /dev/null
@@ -1,17 +0,0 @@
-When gmake automatically restart itself because one of its includes is updated,
-the "MAKEFLAGS" environment variable is no more honoured.
-
-http://savannah.gnu.org/bugs/?30723
-
-diff -rU3 -N make-3.82.orig/main.c make-3.82/main.c
---- main.c.orig 2010-07-19 07:10:53.000000000 +0000
-+++ main.c 2014-01-10 10:55:32.000000000 +0000
-@@ -2093,7 +2093,7 @@
- const char *pv = define_makeflags (1, 1);
- char *p = alloca (sizeof ("MAKEFLAGS=") + strlen (pv) + 1);
- sprintf (p, "MAKEFLAGS=%s", pv);
-- putenv (p);
-+ putenv (allocated_variable_expand (p));
- }
-
- if (ISDB (DB_BASIC))
diff --git a/devel/gmake/files/patch-read.c b/devel/gmake/files/patch-read.c
deleted file mode 100644
index 4ca91c48663c..000000000000
--- a/devel/gmake/files/patch-read.c
+++ /dev/null
@@ -1,52 +0,0 @@
-Add a fix for bug #30612 (http://savannah.gnu.org/bugs/index.php?30612)
-from GNU make's CVS repository (revision 1.194).
-
-Taken from pkgsrc repository: devel/gmake/patches/patch-ah
-
---- read.c.orig 2010-07-13 01:20:42.000000000 +0000
-+++ read.c
-@@ -3028,7 +3028,7 @@ parse_file_seq (char **stringp, unsigned
- {
- /* This looks like the first element in an open archive group.
- A valid group MUST have ')' as the last character. */
-- const char *e = p + nlen;
-+ const char *e = p;
- do
- {
- e = next_token (e);
-@@ -3084,19 +3084,19 @@ parse_file_seq (char **stringp, unsigned
- Go to the next item in the string. */
- if (flags & PARSEFS_NOGLOB)
- {
-- NEWELT (concat (2, prefix, tp));
-+ NEWELT (concat (2, prefix, tmpbuf));
- continue;
- }
-
- /* If we get here we know we're doing glob expansion.
- TP is a string in tmpbuf. NLEN is no longer used.
- We may need to do more work: after this NAME will be set. */
-- name = tp;
-+ name = tmpbuf;
-
- /* Expand tilde if applicable. */
-- if (tp[0] == '~')
-+ if (tmpbuf[0] == '~')
- {
-- tildep = tilde_expand (tp);
-+ tildep = tilde_expand (tmpbuf);
- if (tildep != 0)
- name = tildep;
- }
-@@ -3152,7 +3152,10 @@ parse_file_seq (char **stringp, unsigned
- else
- {
- /* We got a chain of items. Attach them. */
-- (*newp)->next = found;
-+ if (*newp)
-+ (*newp)->next = found;
-+ else
-+ *newp = found;
-
- /* Find and set the new end. Massage names if necessary. */
- while (1)
diff --git a/devel/gmake/files/patch-remake.c b/devel/gmake/files/patch-remake.c
deleted file mode 100644
index 8a72a2c02804..000000000000
--- a/devel/gmake/files/patch-remake.c
+++ /dev/null
@@ -1,59 +0,0 @@
-Fix parallel builds. One port that exhibits this issue is webkit-gtk >= 1.8.
-
-http://savannah.gnu.org/bugs/?30653
-
-Index: remake.c
-===================================================================
-RCS file: /sources/make/make/remake.c,v
-retrieving revision 1.147
-diff -u -r1.147 remake.c
---- remake.c 13 Jul 2010 01:20:42 -0000 1.147
-+++ remake.c 5 Aug 2010 01:02:18 -0000
-@@ -614,6 +614,12 @@
- d->file->dontcare = file->dontcare;
- }
-
-+ /* We may have already encountered this file earlier in the same
-+ * pass before we knew we'd be updating this target. In that
-+ * case calling update_file now would result in the file being
-+ * inappropriately pruned so we toggle the considered bit back
-+ * off first. */
-+ d->file->considered = !considered;
-
- dep_status |= update_file (d->file, depth);
-
-Index: tests/scripts/features/parallelism
-===================================================================
-RCS file: /sources/make/make/tests/scripts/features/parallelism,v
-retrieving revision 1.16
-diff -u -r1.16 parallelism
---- tests/scripts/features/parallelism 5 Jul 2010 18:32:03 -0000 1.16
-+++ tests/scripts/features/parallelism 5 Aug 2010 01:02:18 -0000
-@@ -164,6 +164,27 @@
-
- rmfiles('inc.mk');
-
-+utouch(-15, 'file2');
-+utouch(-10, 'file4');
-+utouch(-5, 'file1');
-+
-+run_make_test(q!
-+.INTERMEDIATE: file3
-+
-+file4: file3
-+ @mv -f $< $@
-+
-+file3: file2
-+ @touch $@
-+
-+file2: file1
-+ @touch $@
-+!,
-+ '--no-print-directory -j2');
-+
-+rmfiles('file1', 'file2', 'file3', 'file4');
-+
-+
- if ($all_tests) {
- # Implicit files aren't properly recreated during parallel builds
- # Savannah bug #26864
diff --git a/devel/gmake/pkg-plist b/devel/gmake/pkg-plist
index e8aeeba36d95..cb51cf793a08 100644
--- a/devel/gmake/pkg-plist
+++ b/devel/gmake/pkg-plist
@@ -1,5 +1,7 @@
bin/gmake
+include/gnumake.h
%%NLS%%share/locale/be/LC_MESSAGES/make.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/make.mo
%%NLS%%share/locale/da/LC_MESSAGES/make.mo
%%NLS%%share/locale/de/LC_MESSAGES/make.mo
%%NLS%%share/locale/es/LC_MESSAGES/make.mo