aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnome-vfs1
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /devel/gnome-vfs1
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'devel/gnome-vfs1')
-rw-r--r--devel/gnome-vfs1/Makefile24
-rw-r--r--devel/gnome-vfs1/pkg-plist4
2 files changed, 8 insertions, 20 deletions
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 0e6e1a2e64dd..1775fc998cf0 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -16,37 +16,29 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- iconv.3:${PORTSDIR}/converters/libiconv
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
-RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gnome-mime-data-2.0.pc:${PORTSDIR}/misc/gnomemimedata
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix glib12 libxml gtk12 orbit gconf \
+ gnomemimedata gnomelibs
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
- --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
- @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
-
-post-patch:
- @${PERL} -pi -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
+ @${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/libcharset/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/gnome-vfs1/pkg-plist b/devel/gnome-vfs1/pkg-plist
index beba41f47813..ec29ffe212d7 100644
--- a/devel/gnome-vfs1/pkg-plist
+++ b/devel/gnome-vfs1/pkg-plist
@@ -111,10 +111,6 @@ share/locale/tr/LC_MESSAGES/gnome-vfs.mo
share/locale/uk/LC_MESSAGES/gnome-vfs.mo
share/locale/wa/LC_MESSAGES/gnome-vfs.mo
share/locale/zh_TW/LC_MESSAGES/gnome-vfs.mo
-@dirrm lib/vfs/modules
@dirrm lib/vfs/extfs
@dirrm include/gnome-vfs-1.0/libgnomevfs
@dirrm include/gnome-vfs-1.0
-@dirrm etc/vfs/modules
-@dirrm etc/vfs
-@unexec /bin/rmdir %D/lib/vfs 2>/dev/null || /usr/bin/true