aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnome-vfs
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-05-06 05:04:31 +0800
committermarcus <marcus@FreeBSD.org>2002-05-06 05:04:31 +0800
commit3172cc30b46d388d14b25db9b44527d4b718a9b9 (patch)
treec97cf7ebbcaeb496091d70d1fa6e3340703ce72c /devel/gnome-vfs
parent9540385a219adbeef1779f49b411761cef111665 (diff)
downloadfreebsd-ports-gnome-3172cc30b46d388d14b25db9b44527d4b718a9b9.tar.gz
freebsd-ports-gnome-3172cc30b46d388d14b25db9b44527d4b718a9b9.tar.zst
freebsd-ports-gnome-3172cc30b46d388d14b25db9b44527d4b718a9b9.zip
Fix a problem with locating file type pixmaps. Bump PORTREVISION.
Diffstat (limited to 'devel/gnome-vfs')
-rw-r--r--devel/gnome-vfs/Makefile1
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index faa4daefd971..859485ca2c1e 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomevfs2
PORTVERSION= 1.9.14
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020501
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
new file mode 100644
index 000000000000..c9cffae7aa99
--- /dev/null
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_gnome-vfs-utils.c
@@ -0,0 +1,11 @@
+--- libgnomevfs/gnome-vfs-utils.c.orig Sun May 5 17:01:22 2002
++++ libgnomevfs/gnome-vfs-utils.c Sun May 5 17:02:24 2002
+@@ -774,7 +774,7 @@
+ paths = g_strsplit (gnome_var, ":", 0);
+
+ for (temp_paths = paths; *temp_paths != NULL; temp_paths++) {
+- full_filename = g_strconcat (*temp_paths, "/share/pixmaps/", relative_filename, NULL);
++ full_filename = g_strconcat (*temp_paths, "/share/gnome/pixmaps/", relative_filename, NULL);
+ if (hack_file_exists (full_filename)) {
+ g_strfreev (paths);
+ return full_filename;