aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnomevfs2
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-06-13 16:46:21 +0800
committersobomax <sobomax@FreeBSD.org>2002-06-13 16:46:21 +0800
commita359b2fce8937e254b2fd8eaac7a93c935be7b1d (patch)
tree788153996743a3918e44e44f965d2a15bbc70742 /devel/gnomevfs2
parentb0c0d35debd83eef80c5198b3bd8a1911501d632 (diff)
downloadfreebsd-ports-gnome-a359b2fce8937e254b2fd8eaac7a93c935be7b1d.tar.gz
freebsd-ports-gnome-a359b2fce8937e254b2fd8eaac7a93c935be7b1d.tar.zst
freebsd-ports-gnome-a359b2fce8937e254b2fd8eaac7a93c935be7b1d.zip
Don't assume that ~/.gnome directory always exists - it may not be true for
virgin users, who never used neither GNOME1 desktop not any GNOME1 apps. Bump portrevision.
Diffstat (limited to 'devel/gnomevfs2')
-rw-r--r--devel/gnomevfs2/Makefile1
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs::gnome-vfs-application-registry.c29
2 files changed, 30 insertions, 0 deletions
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 4c0072a9e5a2..5af705123c40 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomevfs2
PORTVERSION= 1.9.17
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020607
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs::gnome-vfs-application-registry.c b/devel/gnomevfs2/files/patch-libgnomevfs::gnome-vfs-application-registry.c
new file mode 100644
index 000000000000..bd679de032d2
--- /dev/null
+++ b/devel/gnomevfs2/files/patch-libgnomevfs::gnome-vfs-application-registry.c
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- libgnomevfs/gnome-vfs-application-registry.c 2002/06/13 07:31:15 1.1
++++ libgnomevfs/gnome-vfs-application-registry.c 2002/06/13 08:25:24
+@@ -940,6 +940,8 @@
+ static void
+ gnome_vfs_application_registry_init (void)
+ {
++ gchar *tmp;
++
+ if (gnome_vfs_application_registry_initialized)
+ return;
+
+@@ -961,6 +963,14 @@
+ gnome_registry_dir.dirname = g_strdup (DATADIR "/application-registry");
+ gnome_registry_dir.system_dir = TRUE;
+
++ tmp = g_strconcat (g_get_home_dir(), "/.gnome", NULL);
++ if (mkdir (tmp, 0700) &&
++ errno != EEXIST) {
++ g_warning("Could not create per-user Gnome configuration directory: %s",
++ tmp);
++ }
++ g_free(tmp);
++
+ user_registry_dir.dirname = g_strconcat (g_get_home_dir(), "/.gnome/application-info", NULL);
+ user_registry_dir.system_dir = FALSE;
+