aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnustep-make
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-12-14 13:16:10 +0800
committerdinoex <dinoex@FreeBSD.org>2004-12-14 13:16:10 +0800
commitaf8faa7a24a67004ef16af6cba1827a86d136589 (patch)
tree44637cd8b6e07221f16e3e004d29e720a41dd248 /devel/gnustep-make
parenta0b8887e2d28d69178ff83431a09daedf37d2c32 (diff)
downloadfreebsd-ports-gnome-af8faa7a24a67004ef16af6cba1827a86d136589.tar.gz
freebsd-ports-gnome-af8faa7a24a67004ef16af6cba1827a86d136589.tar.zst
freebsd-ports-gnome-af8faa7a24a67004ef16af6cba1827a86d136589.zip
- handle stale shared libs from gcc-objc installs
- force ldconfig when needed PR: 74940
Diffstat (limited to 'devel/gnustep-make')
-rw-r--r--devel/gnustep-make/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 8fe7964ab0b9..4cb4276d6fff 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -35,4 +35,20 @@ CONFIGURE_ARGS+= --with-thread-lib="${PTHREAD_LIBS}"
GNUSTEP_WITHOUT_LIBOBJC= yes
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ @if test ! -f "${TARGLIB}/libobjc.so"; then \
+ ${ECHO_MSG} "libobjc.so not found, please update your gcc"; \
+ ${FALSE}; \
+ fi; \
+ if test `${LDCONFIG} -r | grep libobjc.so | wc -l` -eq 0; then \
+ ${ECHO_MSG} "trying to fix ldconfig.hints"; \
+ ${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -m "${TARGLIB}";\
+ if test `${LDCONFIG} -f "${WRKDIR}/ldconfig.hints" -r | grep libobjc.so | wc -l` -eq 0; then \
+ ${ECHO_MSG} "libobjc.so not in path"; \
+ ${FALSE}; \
+ fi; \
+ fi; \
+
+.include <bsd.port.post.mk>